Apple rilascia la patch per i problemi grafici di MacBook Pro 17

Apple rilascia la patch per i problemi grafici di MacBook Pro 17

Apple ha rilasciato un aggiornamento firmware per i portatili ammiraglia della propria linea che vanno a risolvere i problemi emersi all'inzio del mese

di pubblicata il , alle 13:17 nel canale Apple
Apple
 

Apple ha rilasciato nel corso della giornata odierna una patch destinata agli utenti dei sistemi MacBook Pro 17" unibody immesso sul mercato nel corso del mese di gennaio.

MacBook Pro Graphics Firmware Update 1.0, questo il nome della patch, è destinata a risolvere i problemi noti di visualizzazione emersi all'inzio del mese in corso e relativi esclusivamente al nuovo portatile da 17 pollici della Mela. Si tratta, lo ricordiamo, della comparsa di anomale linee fantasma, di colorazione azzurro-verde o viola, quando si utilizza il sistema con la GPU GeForce 9600M GT.

Nelle note di rilascio si legge:

"Questo aggiornamento firmware è raccomandato a tutti gli utenti di MacBook Pro 17 pollici (Early 2009) e risolve il problema delle linee verticali o delle grafiche distorte sul display del notebook"

La patch è di ridottissime dimensioni, 770KB. Trattandosi di un aggiornamento firmware è opportuno seguire attentamente le istruzioni illustrate a questo indirizzo.

Resta aggiornato sulle ultime offerte

Ricevi comodamente via email le segnalazioni della redazione di Hardware Upgrade sui prodotti tecnologici in offerta più interessanti per te

Quando invii il modulo, controlla la tua inbox per confermare l'iscrizione.
Leggi la Privacy Policy per maggiori informazioni sulla gestione dei dati personali

52 Commenti
Gli autori dei commenti, e non la redazione, sono responsabili dei contenuti da loro inseriti - info
opelio26 Marzo 2009, 13:55 #1
Vicenda conclusasi bene per fortuna. Ma credo che anche su questa notizia arriveranno i sindacalisti anti apple a dire le solite banalità, purtroppo.
ilratman26 Marzo 2009, 13:58 #2
Originariamente inviato da: opelio
Vicenda conclusasi bene per fortuna. Ma credo che anche su questa notizia arriveranno i sindacalisti anti apple a dire le solite banalità, purtroppo.


eccomi con le banalità:

il problema descritto è tipico di un errore ram o surriscaldamento gpu, quindi mi aspetto che il firmware abbia solamente diminuito le frequenze di entrambe.

il problema era tipico anche per la serie 9400 degli inspiron dell e appunto si risolveva in questo modo.
DjLode26 Marzo 2009, 14:05 #3
Originariamente inviato da: ilratman
eccomi con le banalità:

il problema descritto è tipico di un errore ram o surriscaldamento gpu, quindi mi aspetto che il firmware abbia solamente diminuito le frequenze di entrambe.

il problema era tipico anche per la serie 9400 degli inspiron dell e appunto si risolveva in questo modo.


Dalla news precedente:

"In particolare alcuni utenti segnalano la comparsa di anomale linee fantasma, di colorazione azzurro-verde o viola, quando si utilizza il sistema con la GPU GeForce 9600M GT. Il problema, inoltre, sembrerebbe non correlato ad utilizzi intensivi o prolungati. Utilizzando, invece, la GPU integrata GeForce 9400M non si riscontra alcun problema di visualizzazione."

Se non è correlato ad utilizzi intensivi e prolungati dubito fortemente sia un problema di surriscaldamento.
ilratman26 Marzo 2009, 14:06 #4
Originariamente inviato da: DjLode
Dalla news precedente:

"In particolare alcuni utenti segnalano la comparsa di anomale linee fantasma, di colorazione azzurro-verde o viola, quando si utilizza il sistema con la GPU GeForce 9600M GT. Il problema, inoltre, sembrerebbe non correlato ad utilizzi intensivi o prolungati. Utilizzando, invece, la GPU integrata GeForce 9400M non si riscontra alcun problema di visualizzazione."

Se non è correlato ad utilizzi intensivi e prolungati dubito fortemente sia un problema di surriscaldamento.



se rileggi quello che ho scritto è meglio.

non ho detto surriscaldamento ram ma solo errore ram video o surriscaldamento gpu.

hai mai provato ad andare su con la frequenza della memoria video?

mi sa di no!

con la 9400 non succede perchè usa la ram di sistema.
Eraser|8526 Marzo 2009, 14:21 #5
sto firmware riduce le frequenze della gpu, altro che fix.. :|
theJanitor26 Marzo 2009, 14:25 #6
diminuzione delle frequenze?

edit:

Originariamente inviato da: ilratman
eccomi con le banalità:

il problema descritto è tipico di un errore ram o surriscaldamento gpu, quindi mi aspetto che il firmware abbia solamente diminuito le frequenze di entrambe.

il problema era tipico anche per la serie 9400 degli inspiron dell e appunto si risolveva in questo modo.


Originariamente inviato da: Eraser|85
sto firmware riduce le frequenze della gpu, altro che fix.. :|



non sono il solo a pensarlo
s0nnyd3marco26 Marzo 2009, 14:28 #7
Io sicuramente nn sono un fanboy della apple... ma penso che prima di azzardare ipotesi bisognerebbe avere una chiara idea della causa del problema. Se è solo un problema di fimware allora è tutto ok, ma se è effettivamente un problema di surriscaldamento e il firmware solamente abbassa le frequenze operative allora mi sa che nn ci siamo.
ilratman26 Marzo 2009, 14:32 #8
Originariamente inviato da: s0nnyd3marco
Io sicuramente nn sono un fanboy della apple... ma penso che prima di azzardare ipotesi bisognerebbe avere una chiara idea della causa del problema. Se è solo un problema di fimware allora è tutto ok, ma se è effettivamente un problema di surriscaldamento e il firmware solamente abbassa le frequenze operative allora mi sa che nn ci siamo.


guarda è successa la stessa cosa con le prime serie di 8800gt overcloccate con le ram a 700mhz dove molti utenti avevano questi artefatti, ed era già successo con el schede mobile 7900 dei portatili inspiron 9400, e la soluzione è stata diminuire la frequenza delle ram.

un errore ci può sempre stare nella produzione e magari una partita di memorie può non reggere le frequenze che sono imposte dal bios video.

non è niente di drammatico solo che bisognerebbe teneresi un po' di margine prima di mandare fuori il prodotto.
xorosho26 Marzo 2009, 14:35 #9
Qualcuno ha qualche conferma, per caso?

Perchè potrebbe anche essere che semplicemente faccia partire prima le ventole. Questa ipotesi credo possa venire in mente a chiunque abbia un MBP perchè IN GENERE le ventole partono solo quando le temperature salgono di parecchio per mantenere il più possibile SILENZIOSO il portatile (scelta eventualmente opinabile, ma è stata in passato la scelta di Apple).

Ho cercato qualche link che chiarisse questo (non dovrebbe essere difficile verificare le frequenze prima e dopo e monitorare quando partono le ventole) ma non l'ho trovato.
ilratman26 Marzo 2009, 14:38 #10
Originariamente inviato da: xorosho
Qualcuno ha qualche conferma, per caso?

Perchè potrebbe anche essere che semplicemente faccia partire prima le ventole. Questa ipotesi credo possa venire in mente a chiunque abbia un MBP perchè IN GENERE le ventole partono solo quando le temperature salgono di parecchio per mantenere il più possibile SILENZIOSO il portatile (scelta eventualmente opinabile, ma è stata in passato la scelta di Apple).

Ho cercato qualche link che chiarisse questo (non dovrebbe essere difficile verificare le frequenze prima e dopo e monitorare quando partono le ventole) ma non l'ho trovato.


sarebbe l'ideale che qualcuno con il mac pro in questione facesse la prova prima e dopo!

comuqneu mi sento di escludere ventole perchè gli artefatti c'erano anche in 2d da quel che ho visto e li la scheda scalda pochissimo.

Devi effettuare il login per poter commentare
Se non sei ancora registrato, puoi farlo attraverso questo form.
Se sei già registrato e loggato nel sito, puoi inserire il tuo commento.
Si tenga presente quanto letto nel regolamento, nel rispetto del "quieto vivere".

La discussione è consultabile anche qui, sul forum.
 
^