Firefox 53 è ufficiale: con Project Quantum maggiore velocità e meno ''crash''

Firefox 53 è ufficiale: con Project Quantum maggiore velocità e meno ''crash''

Molte le novità in arrivo con la nuova versione di Firefox 53 annunciata oggi per Windows, Mac, Linux e Android. Il nuovo Quantum Compositor permetterà di avere più velocità di renderizzazione delle pagine ma anche meno problemi. Ecco tutte le novità.

di Bruno Mucciarelli pubblicata il , alle 17:01 nel canale Web
Firefox
 

Resta aggiornato sulle ultime offerte

Ricevi comodamente via email le segnalazioni della redazione di Hardware Upgrade sui prodotti tecnologici in offerta più interessanti per te

Quando invii il modulo, controlla la tua inbox per confermare l'iscrizione

14 Commenti
Gli autori dei commenti, e non la redazione, sono responsabili dei contenuti da loro inseriti - info
Pino9021 Aprile 2017, 14:18 #11
Originariamente inviato da: Erotavlas_turbo
Mi è capita la stessa cosa con alcuni PC soprattutto su windows. Ti consiglio di cancellare il profilo di firefox e di crearne uno nuovo.
Se utilizzi sync, una volta creato il nuovo profilo, ti ripristina tutto quanto compresi i componenti aggiuntivi.
Riguardo ad hangout, ci sono alternative migliori come qualità che non richiedono alcuna registrazione come jitsi.


Scusami solo per assicurarmi di aver ben capito: devo cancellare il profilo "localmente" e poi rifare il login giusto?

Purtroppo su HO non posso decidere, è uno dei software che devo usare per lavoro

Per il resto, io ho riscontrato lo stesso identico problema su Windows, Gentoo e Ubuntu, hanno iniziato tutti contemporaneamente un paio di mesi fa

Appena mi dai conferma provo con la cancellazione del profilo.

Grazie mille

Il multiprocesso (non due processi come adesso) è previsto per la versione 55. Il biprocesso per tutti gli utenti era previsto per la versione 53, ma è stato posticipato alla versione 57 e sarà quindi multiprocesso vero.
Adesso viene attivato solo per gli utenti che soddisfano il requisito di non avere componenti aggiuntivi non compatibili. Non sono più presenti le percentuali degli utenti in questo sito.


Grazie, molto interessante. Quindi mi stai dicendo che visto che vedo spesso anche 5 o 6 processi per una sola finestra significa che è già stato attivato e le estensioni che uso sono compatibili? Questo sarebbe rassicurante!

Grazie ancora
Erotavlas_turbo22 Aprile 2017, 22:26 #12
Originariamente inviato da: calabar
Certamente, in questo caso mi pareva superfluo fare questa distinzione, sempre di multiprocesso si tratta, anche se non abbiamo un processo per ogni scheda.

Per definizione è sufficiente che il numero di processi sia maggiore di 1 per chiamarlo multiprocesso.
Comunque c'è molta differenza tra i vari casi, come descritto qui.

Originariamente inviato da: calabar
Piuttosto la versione 57 la vedo ancora troppo vicina, Mozilla non può pensare che gli sviluppatori possano stare dietro a tempistiche di questo tipo, e le API hanno bisogno di essere ampiate ancora, o si perderanno una marea di funzionalità che a mio parere sono il vero punto di forza di Firefox.
Oltretutto la versione 57 è troppo vicina alla nuova versione ESR (che se non sbaglio è la 59) e al fine supporto della ESR attuale, non lasciando molto margine a chi ha l'esigenza di mantenere la compatibilità con le vecchie estensioni ancora per qualche tempo.
Insomma, con la nuova ESR di FF59, a mio parere la cosa migliore sarebbe rimandare questo passaggio a FF60 (per il quale possibilmente questa dovrebbe essere l'unica novità, in maniera tale che chi abbia esigenza di mantenere la compatibilità possa rimanere con la ESR ancora per un periodo significativo di tempo (sperando che magari nel frattempo venga colmato il "vuoto" lasciato dal taglio di compatibilità.


Sul discorso delle API sono d'accordo mentre sulla tempistica meno visto che saranno passati oltre due anni quando uscirà la versione 57 dalla loro presentazione. Comunque meglio fare un buon lavoro e rimandare il tutto.

Da notare che firefox e opera per android sono gli unici browser mobile a supportare le estensioni.

Originariamente inviato da: Pino90
Scusami solo per assicurarmi di aver ben capito: devo cancellare il profilo "localmente" e poi rifare il login giusto?

Purtroppo su HO non posso decidere, è uno dei software che devo usare per lavoro

Per il resto, io ho riscontrato lo stesso identico problema su Windows, Gentoo e Ubuntu, hanno iniziato tutti contemporaneamente un paio di mesi fa

Appena mi dai conferma provo con la cancellazione del profilo.

Grazie mille

Su windows ho risolto cancellando e ricreando il profilo dentro le cartelle del profilo utente e sfruttando sync.

Originariamente inviato da: Pino90
Grazie, molto interessante. Quindi mi stai dicendo che visto che vedo spesso anche 5 o 6 processi per una sola finestra significa che è già stato attivato e le estensioni che uso sono compatibili? Questo sarebbe rassicurante!

Grazie ancora


Si, il processo GPU Quantum Compositor richiede (Windows 7 SP1 o superiore, Multi-processo abilitato e una GPU supportata). Fonte.
Secondo mozilla circa il 25% degli utenti. Per verificare se attivo:
[LIST=1]
[*] Digitare about:support nella barra degli indirizzi
[*] Verificare la presenza dei valori GPUProcessPid e GPIPRocess nella sezione Diagnostics.
[/LIST]

Inoltre, in futuro sarà aggiunta una sezione prestazioni che permetterà di personalizzare quanta RAM e CPU far utilizzare a firefox.
opeNTEch23 Aprile 2017, 11:23 #13
Originariamente inviato da: Sandro kensan
@pino
hai provato a usare la ESR? è una versione più datata e forse può dare meno problemi nel tuo caso.

Non sapevo esistesse.Grazie!
Recentemente ho problemi di phpMyAdmin con Windows 10 1607 64bit e Firefox 32/64 bit oltre la versione 50.1.0. La pagina phpMyAdmin smette di caricare risultando inutilizzabile. Con Windows 7 64 bit nessun problema.
Proverò questa ESR.

EDIT - PROVATA: Firefox ver. 52.1.0ESR 64bit stesso problema, mentre con la più vecchia 45.9.0ESR 64bit non ho problemi.
Adotterò comunque questa ESR d'ora in avanti sperando che risolvano in futuro (Microsoft o Mozilla), altrimenti prima o poi dovrò cambiare browser o sistema operativo
ronin78924 Aprile 2017, 18:19 #14
Originariamente inviato da: opeNTEch
Non sapevo esistesse.Grazie!
Recentemente ho problemi di phpMyAdmin con Windows 10 1607 64bit e Firefox 32/64 bit oltre la versione 50.1.0. La pagina phpMyAdmin smette di caricare risultando inutilizzabile. Con Windows 7 64 bit nessun problema.
Proverò questa ESR.

EDIT - PROVATA: Firefox ver. 52.1.0ESR 64bit stesso problema, mentre con la più vecchia 45.9.0ESR 64bit non ho problemi.
Adotterò comunque questa ESR d'ora in avanti sperando che risolvano in futuro (Microsoft o Mozilla), altrimenti prima o poi dovrò cambiare browser o sistema operativo


nessun problema con firefox 53 64bit e linuxmint lmde2

Devi effettuare il login per poter commentare
Se non sei ancora registrato, puoi farlo attraverso questo form.
Se sei già registrato e loggato nel sito, puoi inserire il tuo commento.
Si tenga presente quanto letto nel regolamento, nel rispetto del "quieto vivere".

La discussione è consultabile anche qui, sul forum.
 
^