Bug per le cpu AMD Opteron

Bug per le cpu AMD Opteron

Un bug nell'esecuzione di una specifica istruzione potrebbe portate ad un blocco di sistema in soluzioni opteron. Un fix è già in cantiere

di pubblicata il , alle 16:46 nel canale Processori
AMD
 

Sono emerse on line alcune informazioni su un bug nei processori AMD Opteron, soluzioni per sistemi Socket 940 indirizzati ad utilizzi in workstation e in server a più processori.

Il bug interessa le istruzioni REP MOVS: potrebbe portare ad avere un salto d'istruzioni successive, oppure generare una dimensione dei dati e dell'indirizzo non corretti.
Quale conseguenza diretta di questo bug si potrebbe verificare uno stallo del sistema, oppure la generazione di risultati non corretti.

AMD è al corrente del problema, avendolo evidenziato nel proprio bollettino del mese di Giugno 2004, e al lavoro per introdurre un bug fix. Il bug può essere corretto con un semplice aggiornamento del bios della scheda madre, anche se stando ai dati attuali i produttori di soluzioni Opteron non hanno ancora rilasciato nulla.

Che vi possano essere bug nei processori è evento molto frequente e che non deve sorprendere. Nella maggior parte dei casi, sia per Intel che per AMD, questi vengono risolti via aggiornamenti dei bios. In alcuni casi, tuttavia, bug particolarmente gravi richiedono nuovi stepping di processore, con la conseguenza di tempi d'intervento particolarmente più lunghi.

Ulteriori dettagli sono disponibili sul sito tedesco 3DChips, a questo indirizzo.

Resta aggiornato sulle ultime offerte

Ricevi comodamente via email le segnalazioni della redazione di Hardware Upgrade sui prodotti tecnologici in offerta più interessanti per te

Quando invii il modulo, controlla la tua inbox per confermare l'iscrizione.
Leggi la Privacy Policy per maggiori informazioni sulla gestione dei dati personali

29 Commenti
Gli autori dei commenti, e non la redazione, sono responsabili dei contenuti da loro inseriti - info
JoJo23 Giugno 2004, 16:51 #1
Cavolo... speravo di trovare già un paio di pagine di botta e risposta tra AMD-FANS e INTEL-FANS per farmi 2 risate... ripassa tra un'oretta, va!
Dias23 Giugno 2004, 17:04 #2
Cioè, se apro la calcolatrice e faccio 2+2 mi da come risultato 5?
Scherzo eh
Wonder23 Giugno 2004, 17:06 #3
No, credo che ti dia sempre 4 ma se chiedi un caffe forse ti fa un cappuccio
DioBrando23 Giugno 2004, 17:32 #4
Originariamente inviato da JoJo
Cavolo... speravo di trovare già un paio di pagine di botta e risposta tra AMD-FANS e INTEL-FANS per farmi 2 risate... ripassa tra un'oretta, va!


io invece mi aspettavo la stessa indignazione che sento quando ci sn lo stesso tipo di notizie sui Mac da parte degli Opteron/AMD fans...chissà come mai ancora niente


per curiosità il bug riguarda in qlc modo l'utilizzo del socket 940? Ergo, potrebbe coinvolgere anche gli FX?
|unknown|23 Giugno 2004, 17:32 #5
ank'io volevo le zuffe amd-intel e qualke pro intel ke sfotteva cn subito il proamd ke sparava etc
cmq se è una cosa frequente come dicono xke farci la news?
seccio23 Giugno 2004, 17:34 #6
Originariamente inviato da JoJo
Cavolo... speravo di trovare già un paio di pagine di botta e risposta tra AMD-FANS e INTEL-FANS per farmi 2 risate... ripassa tra un'oretta, va!



FLAME Mode__ ON

MA porca miseria che schifezza che sono queste patacche di AMD ! ci credo che costano così poco ! fan cagare!!! aspettare una revisione!? si bonanotte e chi s'è preso una CPU bacata ? che dovrebbe dire?


Cacchio e poi tutti a chiedersi perchè intel fa prezzi alti ! forse perchè fa prodotti che VALGONO davvero!!
Con AMD si è semper sul filo del rasoio ! e questa ne è un ulteriore prova!!!


FLAME Mode__ OFF

sto scherzando ovviamente !! speriamo che tutto si risolva visto che ho in progetto proprio un AMD (939) , e per me un ritorno ad AMD sarebbe parecchio strano visto il mio affetto verso Intel....

Credo che cmq siano risolvibili da bios...!

PS sul flame mode ragazzi ....SCATENATEVI!!


[B][OT][/B]
certo è che con i guai alla macchina che mi sono successi , ormai il rifarmi il pc è l'ultimo dei miei pensieri...
[B][/OT][/B]
Diego7223 Giugno 2004, 18:10 #7

oppps

hehehe Ad ogni buon conto
AMD US!! ^________^
leoneazzurro23 Giugno 2004, 18:22 #8
Entrambe le aziende hanno le loro belle liste di "bug" (Intel le chiama "errata" sui loro siti. In genere vengono corretti con i nuovi stepping dei processori, ed in effetti se si guardano le liste si vede che pochini non sono da entrambe le parti.
TyGerONE23 Giugno 2004, 18:31 #9

HO SALVATO IL LINK

di questa notizia. Alla prox news su bug da parte di Intel/Apple & Co. faccio un bel "quote"
Serpico7823 Giugno 2004, 18:36 #10

Bug

Non è una novità che spesso ci siano dei bug anche nell'implementazione di microprocessori e chipset, uno dei casi più clamorosi era accaduto con una delle prime versioni di Pentium che "sbagliava" a fare una divisione, e in quel caso si era ricorso alla sostituzione con nuovi processori, se non ricordo male in cambio di un Pentium bacato ti davano in cambio un Pentium MMX nuovo di pacca
oppure il bug del KT133A con gli Hard Disk ATA133 che era stato risolto con un aggiornamento del Bios, non sono eventi infrequenti ma diventano noti al grande pubblico solo se sono particolarmente clamorosi.....

Devi effettuare il login per poter commentare
Se non sei ancora registrato, puoi farlo attraverso questo form.
Se sei già registrato e loggato nel sito, puoi inserire il tuo commento.
Si tenga presente quanto letto nel regolamento, nel rispetto del "quieto vivere".

La discussione è consultabile anche qui, sul forum.
 
^