PDA

View Full Version : [Thread Ufficiale] TP-Link TD-W8970v1 - Firmware OpenWRT


Pagine : [1] 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22

Bovirus
08-04-2014, 07:35
- Scopo di questo thread

Questo thread si occupa esclusivamente del prodotto

TP-LINK TD-W8970 (v1)

ed esclsuisavamente uin merito a

aggiornamento firmware OpenWRT

Per altre richieste sul modem TP-LINK TD-W8970 (v1) ed ilf rimware standard fare riferimento al thread

TP-LINK TD-W8970 (v1) - Thread ufficiale (http://creativecommons.org/licenses/by-nc-sa/2.5/it/)


- OpenWRT - pagina ufficiale per mdoem TD_W8970v1

TP-LINK WD-8970 (v1) - OpenWRT (openwrt.org) (http://wiki.openwrt.org/toh/tp-link/td-w8970)


- Licenza Creative Commons

Il contenuto di questo post è rilasciato con licenza

Creative Commons Attribution-Noncommercial-Share Alike 2.5 (http://creativecommons.org/licenses/by-nc-sa/2.5/it/)

rylos
11-04-2014, 12:08
Ciao a tutti! Per chi fosse interessato, da circa 4 mesi sto lavorando insieme ai ragazzi di OpenWRT per far funzionare in modo corretto il nostro mitico W8970.

Questo router è un hardware potente x OpenWRT, con ADSL/VDSL:
CPU: Lantiq XWay VRX268 @500MHz
RAM: 64 MiB
Flash: 8 MiB
Switch: 4x 1000mbps
WiFi: AR9381 (onboard) b/g/n
USB: 2 x 2.0

Aprendo il router e flashando un firmware custom perdete ovviamente la garanzia della casa madre.

Premessa, se siete sul firmware originale TPLINK del 15.04.2013 o precedenti allora potete flashare direttamente da interfaccia web;
Se invece siete sull'ultimo firmware del 28.08.2013 allora dovete, come me, eseguire il primo flash con un cavo seriale; è relativamente semplice, basta saldare 3 fili, flashare e dissaldare. I flash successivi si fanno dall'interfaccia Web di OpenWRT.
(TPLINK col firmware del 28 ha cambiato il bootloader proteggendo i flash da web, per fortuna via seriale non ci sono problemi).

L'immagine è basata sugli ultimi sorgenti OpenWRT trunk, con aggiunta la lingua italiana, apportate alcune patch per il corretto funzionamento dei led (gestibili da interfaccia web); disabilitato il debug del kernel, cosi l'immagine è ottimizzata.

Cosa funziona? Tutto! :
1) Switch gigabit (con tanto di utility console per chi lo vuole riconfigurare in modo avanzato)
2) ADSL con i vari tipi di incapsulamento(con possibilità di testare vari firmware software del chip vr9, per ora io sto usando l'originale tplink per il controllo del chip) - si può variare anche l'SNR con l'utility di configurazione via console
Funziona anche la VDSL, ma non credo che a qualcuno interessi, o sbaglio?
3) Wifi, con le varie protezioni (ho testato solo WPA2) - con potenza di trasmissione regolabile fino a 20Dbm
4) Le 2 USB - Una porta USB può anche essere utilizzata per estendere il rootfs cosi potete installare tutti i pacchetti che volete (io attualmente ho installato transmission, pureftp server, un server dlna, pyload ecc ecc)
5) Busybox l'ho ricompilato con il supporto a istruzioni avanzate, compreso il comando find e supporto a mtime (cosi per chi come me usa delle webcam può gestire gli archivi usb, cercare i files "più vecchi di una data" ed eliminarli, in modo programmato - con cron)

Avere OpenWRT su questo router (8mb di flash e 64mb di ram) permette di divertirsi parecchio, vista anche la sua CPU potente da 500Mhz.

Il tutto è stabile per un utilizzo quotidiano.

Le prossime cose che voglio analizzare in dettaglio sono i vari firmware per il chip VR9 (ADSL) per vedere quello più performante (quello fornito da TP-LINK nell'immagine del 28.08 non è il più recente per VR9).

GUIDA d'installazione
Ecco il necessario: https://drive.google.com/folderview?id=0B3ZoWoxOuVdsZnRwUTh2SklvTWM&usp=sharing

All'interno trovate 2 files:
L'immagine da flashare e
il firmware DSL del VR9 (con tutti i parametri ADSL modificabili, compreso SNR) da copiare nella cartella /lib/firmware di openwrt una volta avviato (con ssh o scp o ftp, come volete insomma)
Poi andate via ssh dentro la cartella /lib/firmware ed eseguite questo comando:
ln -s dsl_vr9_firmware_xdsl-05.04.08.00.00.06_05.04.04.04.00.01.bin vdsl.bin
(Se non fate questa operazione, l'ADSL non funzionerà).

GUIDA
{Noobs: Attenzione, leggete prima tutta la guida e vedete se fa al caso vostro, se avete lo conoscenze necessarie per seguirla / non mi prendo nessuna responsabilità, agite per vostra scelta :D}

Elenco del materiale necessario per programmare via seriale: (editerò questo post con aggiornamenti).

1) TPLINK TD-W8970 (ovviamente )
2) Un cavo usb->seriale CA-42 (quelli dei nokia vecchi) [costano circa 6€]
3) Windows (per questa guida) chi usa linux dovrebbe essere in grado da solo
4) Putty.exe Link
5) Tftpd 64bit o 32bit come preferite Link
6) I 2 files del firmware Link
7) WinSCP

Ora il cavo CA-42 dovrebbe avere 3 fili, GND RX e TX: prima di tagliare il connettore identificate i 3 fili e segnateveli aiutandovi con questa guida: Link (http://pinouts.ru/CellularPhones-Nokia/nokia_pop_pinout.shtml)

Saldate i 3 fili sulle rispettive piazzole seriali GND RX e TX come indicato qui: Link (wiki.openwrt.org/toh/tp-link/td-w8970) guardate la foto seriale zona J7 (c'è anche il 3.3volt ma non serve).

Annotate la porta seriale che vi assegna windows quando collegate il cavo (nel mio caso è COM5).

Settate la scheda di rete su ip statico 192.168.1.100 mask 255.255.255.0 (gateway e dns lasciateli pure vuoti).

Aprite putty, scegliete SERIAL e scrivete la porta (nel mio caso COM5), come velocità mettete 115200.

Il router deve essere spento e collegato con cavo di rete al PC e col cavo seriale collegato.

In putty aprite la connessione e avrete una schermata nera.
Ora accendete il router...se avete saldato bene vedrete in putty tutto il log del boot di linux...se è cosi, perfetto: spegnete il router.

Riaccendete il router e premete di continuo il tasto "t" sulla tastiera.

Vedrete che avrete interrotto il boot, vi trovate nella console UBOOT del router, date invio e vi darà errore per via delle "t" che avete scritto...ora siete al prompt.

Avviate tftpd come amministratori e settatelo in ascolto sull'IP 192.168.1.100 e la cartella condivisa deve contenere il mio firmware.

Ora in putty scrivete:
tftpboot 0x80800000 openwrt-lantiq-xrx200-TDW8970-sysupgrade_vXXX.image
il nome del file potrebbe essere diverso (in base alla versione).

Se tutto va bene vedete dei ######### e vi dice che lo ha trasferito.
A questo punto scrivete:
sf erase 0x20000 0x7a0000 + invio
questo cancella kernel e rootfs (non vi preoccupate, il boot è intatto, occhio a non sbagliare i numeri!)

poi scrivete:
sf write 0x80800000 0x20000 0x680004

Questo scrive il firmware. Una volta finito spegnete il router da tastino e riaccendetelo. Vedrete il boot di OpenWRT. Aspettate, il primo boot è luuuuungo. Dopo qualche minuto provate dal browser ad aprire 192.168.1.1 se appare la web interface di OpenWRT siete a posto! Settate subito la password.

Una volta settata la password, aprite WinSCP e create una nuova connessione sul vostro router 192.168.1.1 utente:root password: la vostra
Copiate nel percorso /lib/firmware il file dsl_vr9_firmware_xdsl-05.04.08.00.00.06_05.04.04.04.00.01.bin e rinominatelo in vdsl.bin

Riavviate (o col tastino o da web openwrt). E' tutto pronto.
Benvenuti in OpenWRT

Licenza Creative Commons
Il contenuto di questo post è rilasciato con licenza
Creative Commons Attribution-Noncommercial-Share Alike 2.5 (http://creativecommons.org/licenses/by-nc-sa/2.5/it/)

rylos
11-04-2014, 12:14
[RISERVATO]

[Varie ed eventuali]

rylos
11-04-2014, 12:16
[RISERVATO]

[Link Utili]

massimo1995
11-04-2014, 12:31
^_^

palleggiatore
11-04-2014, 12:48
Non si può ancora flashare da web giusto?


Inviato dal mio telegrafo

Toigoweb
11-04-2014, 12:50
Mettiamo anche come ripristinare il fw originale ?

sil3nc3
11-04-2014, 13:01
aspettavo questo thread:D

sunvit
11-04-2014, 14:02
Finalmente....

Inviato dal mio GT-I9300 utilizzando Tapatalk

fasix
11-04-2014, 14:06
presente:
con questo FW posso installare dalla WEBGUI, giusto?

Firmware Version:0.6.0 1.2 v000c.0 Build 130201 Rel.54921n
Hardware Version:TD-W8970 v1 00000000
System up time:26 day(s) 18:46:44

strassada
11-04-2014, 14:37
@fasix
mi spiace ma per ora anche coi vecchi firmware originali, devi usare sempre la seriale.
quando rilasceranno un'immagine flashabile dal menù di firmware originali tp-link, troverai sicuramente notizia (e il file naturalmente).
Rylos ha ricopiato una vecchia guida, appena avrà tempo modificherà il primo post.

speed11
11-04-2014, 14:48
salve, io ho il firmware 0.6.0 2.1 v000c.0 Build 130415 Rel.34164n posso installare da webgui e posso rimettere l'originale sempre da webgui?

speed11
11-04-2014, 14:51
la risposta la già data strassada

massimo1995
11-04-2014, 15:02
speed11 segui post strassada

abarth83
13-04-2014, 10:02
aspettavo questo thread:D

idem mi iscrivo immediatamente:D

san80d
13-04-2014, 10:28
e seguiamo anche questo thread :)

achmav
13-04-2014, 10:30
Per chi fosse interessato al Wake On Wan, ecco come ottenerlo su firmware Openwrt in tre semplici passaggi:

- da Sistema/Software installate il pacchetto "ip"

- su Sistema/Avvio - Avvio Locale aggiungete questa stringa (chiaramente prima di exit 0) usando un indirizzo di vostra scelta che non dovrà mai essere usato (regolate di conseguenza il DHCP), nel mio caso ho usato il 192.168.1.254
ip neigh add 192.168.1.254 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br-lan
- create una nuova regola di Port Forward

Protocollo: UDP
External zone: Wan
Porta Esterna: (una porta di vostra scelta)
Internal zone: lan
Indirizzo IP Interno: 192.168.1.254 (o quello da voi scelto)
Porta interna: 9


Riavviate il router ed il gioco è fatto :D

achmav
13-04-2014, 10:35
Recupero anche una vecchia immagine da me postata sull'altro thread che mostra come collegare i fili di un cavo Nokia CA-42 alla seriale del TP_Link

http://imageshack.com/a/img837/3811/fw64.png

achmav
13-04-2014, 10:38
Script di riconnessione per JDownloader funzionante su firmware Openwrt.


[[]]
[[]]
[[[DEFINE routername="OpenWrt Attitude Adjustment"/]]]
[[]]
[[]]
[[]]
POST /cgi-bin/luci HTTP/1.1
Host: %%%routerip%%%
username=%%%user%%%&password=%%%pass%%%
[[]]
[[]]
stok=(.*?)/
[[]]
[[]]

[[]]
[[]]
POST /cgi-bin/luci/;stok=%%%stok%%%/admin/network/iface_shutdown/wan HTTP/1.1
Host: %%%routerip%%%
[[]]
[[]]

[[]]
[[[WAIT seconds="5"/]]]
[[]]

[[]]
[[]]
POST /cgi-bin/luci/;stok=%%%stok%%%/admin/network/iface_reconnect/wan HTTP/1.1
Host: %%%routerip%%%
[[]]
[[]]

[[]]

achmav
13-04-2014, 10:42
Per accendere/spegnere il WIFI ad orari/giorni stabiliti:

In Sistema/Operazioni Programmate inserire:

#disabilitare wifi (es. 00:30)
30 00 * * * uci set wireless.radio0.disabled=1 && uci commit wireless && wifi

#abilitare wifi (es. 06:30)
30 06 * * * uci set wireless.radio0.disabled=0 && uci commit wireless && wifi

nebbia88
13-04-2014, 10:52
- su Sistema/Avvio - Avvio Locale aggiungete questa stringa (chiaramente prima di exit 0) usando un indirizzo di vostra scelta che non dovrà mai essere usato (regolate di conseguenza il DHCP),

ip neigh add 192.168.1.254 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br-lan


puoi spiegare brevemente cosa c'è alla base di questa stringa apparentemente senza senso???

perche' bisogna inventarsi un ip inutilizzato? non si puo' usare quello della LAN del router?

Grazie

rylos
13-04-2014, 11:12
@achmav Gran belle informazioni

@tutti Ho compilato l'ultima rev, sempre da testare. Hanno abilitato una nuova partizione sulla flash, in grado di contenere il firmware VDSL.bin.

Edit: ne sto compilando un'altra adesso, con lo switch interno gestito dal kernel (v40503)

Totix92
13-04-2014, 11:16
e per tornare al firmware originale? come si fa? :mc:
Lunedì acquisterò il TP-Link TD-W8970 perché mi sono stancato del Netgear DGN2200v4 :muro:
se lo trovo con il penultimo firmware installerò l'originale openwrt altrimenti mi terrò il firmware originale ( anch'esso openwrt ) troppo sbattimento aprire il router e perdere la garanzia :D

strassada
13-04-2014, 11:50
mi sa che si trovano solo con l'ultimo firmware, del resto sono passati oltre 7 mesi.

achmav
13-04-2014, 11:51
puoi spiegare brevemente cosa c'è alla base di questa stringa apparentemente senza senso???

perche' bisogna inventarsi un ip inutilizzato? non si puo' usare quello della LAN del router?

Grazie

Dovendo tenere una porta sempre aperta, meglio che sia su un ip non utilizzato.
Maggiori info puoi trovarle quì (http://www.dd-wrt.com/wiki/index.php/WOL#Remote_Wake_On_LAN_via_Port_Forwarding)

rylos
13-04-2014, 14:28
Niente le partizioni sono errate e l'ADSL ora funziona però, torno alla 40335 in attesa di sistemazioni varie....

Inviato dal mio GT-I9300

ozlacs
13-04-2014, 14:58
la partizione separata del firmware servirebbe a non doverlo caricarlo ogni volta? o anche per caricare altri firmware?

nebbia88
13-04-2014, 15:10
Dovendo tenere una porta sempre aperta, meglio che sia su un ip non utilizzato.

scusa ma cosa pensi possa succedere tenedo aperta una porta se dietro non c'è nessuno che ascolta?? (es. sul router?)

non mi ha soddisfatto molto quella wiki se devo esser sincero..

pegasolabs
14-04-2014, 21:25
rylos perché non adegui il thread come spiegato in pvt? Così "ufficializziamo".

teo180
14-04-2014, 23:09
E possibile montarlo anche in altri modelli di tp-link più economici?

Totix92
14-04-2014, 23:11
no

rylos
15-04-2014, 07:15
@pegasolabs: ho adattato il post.
Puoi spostare? Grazie.

san80d
15-04-2014, 10:27
@pegasolabs: ho adattato il post.
Puoi spostare? Grazie.

quindi adesso e' thread ufficiale? bene

pegasolabs
15-04-2014, 11:39
Si tutto ok.

san80d
15-04-2014, 11:44
Si tutto ok.

ottimo

il_cantastorie
15-04-2014, 14:28
Ora che ho attivato la seconda USB come uno storage del Media Server sarebbe interesasnte poterla spegnere e accendere ad orari prestabiliti.

Qualcuno ha idea di come si faccia con questo router?

Ho trovato questa guida sull'USB ufficiale OpenWrt che conclude così:

On the TP-Link TL-MR3420, TL-MR3220, TL-WR841ND v7 & TL-WR842ND you can turn the power to the USB port on and off like this:

ON
echo 1 >/sys/class/gpio/gpio6/value
OFF
echo 0 >/sys/class/gpio/gpio6/value

Ho trovato anche questo, stasera lo provo:

luci-app-hd-idle

Chissà se per il nostro sono o meno valide?

Graziano.

il_cantastorie
16-04-2014, 09:36
luci-app-hd-idle

Chissà se per il nostro sono o meno valide?

Graziano.

Confermo che questo package stoppa un disco USB alimentato dal router direttamente quindi posso permettermi di lasciarlo sempre acceso. Non appena da Client DLNA o da share accedo lui lo riattiva istantaneamente. Sarebbe interessante capire se funziona anche con dispositivi NAS o box stupidi in JBOD o Raid0+1 USB e se questo package avverte la box di mettere i dischi in stand-by. Scusate se sono così specifico ma sto lavorando ad una soluzione domestica ad-hoc.

A proposito... mi piacerebbe provare asterisk.... se funzionasse sarebbe interessantissimo...

Graziano.

sunvit
16-04-2014, 10:31
Confermo che questo package stoppa un disco USB alimentato dal router direttamente quindi posso permettermi di lasciarlo sempre acceso. Non appena da Client DLNA o da share accedo lui lo riattiva istantaneamente. Sarebbe interessante capire se funziona anche con dispositivi NAS o box stupidi in JBOD o Raid0+1 USB e se questo package avverte la box di mettere i dischi in stand-by. Scusate se sono così specifico ma sto lavorando ad una soluzione domestica ad-hoc.

A proposito... mi piacerebbe provare asterisk.... se funzionasse sarebbe interessantissimo...

Graziano.

Grazie tante per la segnalazione...pacchetto veramente interessante.
Cercando hai trovato per caso un server ftp davvero valido con interfaccia luci?

abarth83
17-04-2014, 10:07
Grazie tante per la segnalazione...pacchetto veramente interessante.
Cercando hai trovato per caso un server ftp davvero valido con interfaccia luci?

sarebbe una figata:rolleyes:

grizu99
19-04-2014, 07:07
Buongiorno a tutti,
complimenti per il lavoro, ho installato la openwrt e creato la partizione exroot.
funziona tutto bene, anche se la configurazione del wifi ha qualche problema.
Ho capito che per evitare il "fermo" completo del wifi è meglio editare il file "wireless" "a mano" .
Ho provato anche ad installare "owncloud". Però quando provo ad accedere alla pagina web di owncloud ho questo messaggio "PHP module GD is not installed.". Ho provato a installare php e la cosa pare andare a buon fine , ma cmq il messaggio di errore persiste. Ho letto sul web varie risposte a questa problematica ma non ho ancora risolto.

Qualcuno ha installato con successo owncloud su questo router?
grazie e buon fine settimana.

massimo1995
20-04-2014, 08:35
^_^

massimo1995
21-04-2014, 16:01
^_^

massimo1995
21-04-2014, 17:10
^_^

achmav
21-04-2014, 18:01
Bravo massimo1995.
Ora aspettiamo la guida per ownCloud :D

rylos
21-04-2014, 18:19
Nuova build 40535 messa su drive. E' testata e funzionante, la sto usando ora.

ATTENZIONE che ci sono nuove impostazioni per l'adsl nel file /etc/config/network quindi se flashate dicendo di mantenere i vecchi settaggi potreste avere problemi.

Io mi sono creato un backup da Luci e poi mi sono riaggiustato i settings con winscp tranne il file network.
Ora si possono settare i toni adsl e altre cose.

config vdsl 'dsl'
option annex 'a'
option firmware '/lib/firmware/vdsl.bin'
option tone 'av'
option xfer_mode 'atm'

xamok
21-04-2014, 18:28
Ciao gente! È da una vita che seguo i 3d riguardanti il w8970, e finalmente mi sono deciso a flasharlo :D
Tutto bene, flash riuscito (rev 40335) nonostante la mia abilità da saldatore pari a 0.
Primo boot, metto i driver adsl, attivo il wifi, riavvio.
Prende la portante, in ethernet e in wifi dai pc navigo più che bene, ma con i device mobili non si connette. Spiego meglio: sia da iPhone che da tablet e smartphone android vedo la rete, metto la password ma non si riesce a connettere. Sull'iPhone e sul tablet ( quest'ultimo con rom originale) dice che la pwd è sbagliata, sul gNexus ( con rom cyano 4.4) non dice niente e prova a ripetere il processo di connessione.
Credo sia un problema tra i driver android ( ma anche quelli apple ?! ) e le varie chiavi, ho provato wpa e wpa2, sia aes che tkip, ma l'unico modo per connetterli e navigare è lasciare la rete aperta. Ora, non che non sia così generoso e solidale da non lasciare navigare qualcuno con la mia wifi, ma essendo in città non mi garba molto che chiunque si attacchi :D
Qualcuno ha delle idee ? Avete avuto problemi simili?

rylos
21-04-2014, 19:05
Ho avuto problemi simili in passato con router diversi, prova a cambiare il canale del wifi sul router.

achmav
21-04-2014, 19:11
Nessun problema di wifi con la 40335 e le mie varie periferiche android.
Probabilmente è un problema di configurazione del wifi su openwrt.

Verifica che su Configurazione Interfaccia sia impostato:

IMPOSTAZIONI GENERALI
Modalità: Punto di accesso
Rete: solo lan
Nascondi ESSID: no (puoi nasconderlo dopo che tutto funzioni)
Modalità WMM: si

SICUREZZA WIRELESS
Crittografia: WPA-PSK/WPA2-PSK Mixed mode
Cifratura: auto

FILTRO MAC
Filtro disabilitato (puoi abilitarlo successivamente)

@Rylos
Grazie per l'aggiornamento, cominciavo a sentirne la mancanza :D

xamok
21-04-2014, 20:54
Ho avuto problemi simili in passato con router diversi, prova a cambiare il canale del wifi sul router.

Nessun problema di wifi con la 40335 e le mie varie periferiche android.
Probabilmente è un problema di configurazione del wifi su openwrt.

Verifica che su Configurazione Interfaccia sia impostato:

IMPOSTAZIONI GENERALI
Modalità: Punto di accesso
Rete: solo lan
Nascondi ESSID: no (puoi nasconderlo dopo che tutto funzioni)
Modalità WMM: si

SICUREZZA WIRELESS
Crittografia: WPA-PSK/WPA2-PSK Mixed mode
Cifratura: auto

FILTRO MAC
Filtro disabilitato (puoi abilitarlo successivamente)

@Rylos
Grazie per l'aggiornamento, cominciavo a sentirne la mancanza :D

Azz, ho fatto tutto quello che avete detto e in più ho rigenerato il config della wifi (http://wiki.openwrt.org/doc/uci/wireless#regenerate.configuration) ( non si sa mai :O ) e funziona !
Nei prossimi giorni faccio un bell'extRoot e via ! Grazie ancora! :D :D

rylos
21-04-2014, 21:01
Con la build 40535 trovo l'ADSL stabilissima, consiglio a tutti il passaggio, e occhio ai file di configurazione come ho scritto prima.

pegasolabs
21-04-2014, 21:06
rylos un bel disclaimer dummy-proof però in prima pagina lo aggiungerei ;)

sunvit
21-04-2014, 21:30
Grazie rylos.

Inviato dal mio GT-I9300 utilizzando Tapatalk

abarth83
22-04-2014, 08:11
Con la build 40535 trovo l'ADSL stabilissima, consiglio a tutti il passaggio, e occhio ai file di configurazione come ho scritto prima.

ho seguito il tuo consiglio Rylos.. ma con alice non si connette ho resettato la configurazione prima di flashare poi flashato e caricato il vdsl... quindi tutto pulito ho settato la wan ma nulla da fare...
sono tornato indietro alla 335:(

rylos
22-04-2014, 08:18
Hai seguito le modifiche che ho postato in precedenza?
Io ho Aruba, quindi ho telecom anche io (aruba rivende telecom).

I tuoi settaggi se sono come i miei, sono pppoa con vc-mux e nient'altro di particolare. A questo punto devi editare il file "network" e mettere i valori come ho scritto prima:
annex a, atm ecc sotto la voce "dsl"

PS
Per chi dovesse avere problemi, il nuovo servizio adsl funziona, dovete solo smanettare un po' con i nuovi parametri.

Questo è un esempio (mia configurazione, con user pwd e mac cancellati ovviamente):

config interface 'wan'
option ifname 'nas0'
option proto 'pppoa'
option username 'useradsl'
option password 'passwordadsl'
option ipv6 '0'
option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config vdsl 'dsl'
option annex 'a'
option firmware '/lib/firmware/vdsl.bin'
option tone 'av'
option xfer_mode 'atm'

abarth83
22-04-2014, 08:28
Hai seguito le modifiche che ho postato in precedenza?
Io ho Aruba, quindi ho telecom anche io (aruba rivende telecom).

I tuoi settaggi se sono come i miei, sono pppoa con vc-mux e nient'altro di particolare. A questo punto devi editare il file "network" e mettere i valori come ho scritto prima:
annex a, atm ecc sotto la voce "dsl"

PS
Per chi dovesse avere problemi, il nuovo servizio adsl funziona, dovete solo smanettare un po' con i nuovi parametri.
a si ora ok mi ero dimenticato di mettere le stringhe aggiuntivi nel file network.
grazie

ozlacs
22-04-2014, 10:10
flashata con successo l'ultima build, adsl ok, l'unica cosa che ho dovuto modificare è il parametro 'xfer_mode', settandolo su "atm" dal valore di default "ptm"

rylos
22-04-2014, 10:45
Sto preparando una nuova build che metterò online oggi pomeriggio, in cui includo anche il supporto kernel all' NFS server (nelle ultime build me lo ero perso per strada nel file di configurazione della compilazione).

L'nfs server serve anche per chi come me, mette il boot pxe su openwrt per eseguire distro live o utilities da rete (clonezilla, gparted ecc). Molto comodo.

strassada
22-04-2014, 12:46
a quando un'immagine flashabile da GUI firmware originale?

massimo1995
22-04-2014, 13:00
^_^

strassada
22-04-2014, 13:18
la vdsl2 funziona in ptm

massimo1995
22-04-2014, 13:26
^_^

sunvit
22-04-2014, 14:45
Scusa ma se cloni l'usb i vari moduli aggiornati non li perdi?

Inviato dal mio GT-I9300 utilizzando Tapatalk

rylos
22-04-2014, 14:47
Se non erro extroot crea un md5sum sulle cartelle /lib /etc e /mnt
quindi eliminando queste 3 dalla periferica usb e ricopiando l'overlay extroot torna a posto (senza cancellare il resto).

massimo1995
22-04-2014, 15:22
^_^

rylos
22-04-2014, 15:30
Online la rev 40554 che sarà l'ultima fino a cambiamenti maggiori nel trunk openwrt.
È experimental perché non l'ho ancora flashata ma il primo che lo fa e conferma (io stasera) la rinomino in TESTED.

massimo1995
22-04-2014, 15:33
Online la rev 40554 che sarà l'ultima fino a cambiamenti maggiori nel trunk openwrt.
È experimental perché non l'ho ancora flashata ma il primo che lo fa e conferma (io stasera) la rinomino in TESTED.

rylos 6 GRANDE:sofico:

sunvit
22-04-2014, 16:25
@Massimo1995
Interessante openupload ma sai se è installabile nel ns router?

@rylos
Volevo provare l'ultima build ma ancora non la vedo...:D :D :D

strassada
22-04-2014, 16:51
mi sa che è il file con orario 7.08 (aggiornamento: ora rylos l'ha rinominato):
i server hanno orario della costa del pacifico, -9 ore rispetto a noi.

sunvit
22-04-2014, 18:30
Trovato grazie...

massimo1995
23-04-2014, 06:47
^_^

abarth83
23-04-2014, 07:19
Online la rev 40554 che sarà l'ultima fino a cambiamenti maggiori nel trunk openwrt.
È experimental perché non l'ho ancora flashata ma il primo che lo fa e conferma (io stasera) la rinomino in TESTED.

a me sta notte si è impallata l interfaccia WAN e ho dovuto riavviarla..

rylos
23-04-2014, 08:47
A me sta funzionando tutto bene.

Se siete interessati ad eliminare un po' di servizi a carico sul kernel che spesso non vengono usati potete rimuovere:

- il supporto a ipv6 (se non lo usate è inutile)
- il server nfs

Questi 2 pacchetti sono inclusi nella rom, ma sono disinstallabili (e reinstallabili volendo).

abarth83
23-04-2014, 08:54
A me sta funzionando tutto bene.

Se siete interessati ad eliminare un po' di servizi a carico sul kernel che spesso non vengono usati potete rimuovere:

- il supporto a ipv6 (se non lo usate è inutile)
- il server nfs

Questi 2 pacchetti sono inclusi nella rom, ma sono disinstallabili (e reinstallabili volendo).
ok si questo è utile saperlo.. più è snello meglio è;)

il nome dei pacchetti sono queti?
luci-proto-ipv6,
kmod-ipv6,
kmod-fs-nfs 3.10.36-1
kmod-fs-nfs-common 3.10.36-1
kmod-fs-nfsd 3.10.36-1
nfs-kernel-server 1.2.9-1

grizu99
23-04-2014, 20:46
salve, problema strano con il nuovo firmware. Se accedo via ftp da una postazione wireless a un server nas(openmediavault) collegato via cavo, entro vedo la lista delle cartelle, ma se provo ad accedere a una delle cartella la lista dei file non mi appare mai. Non riesco nemmeno ad accedere alla interfaccia web del nas. Se prova ad accedervi da una postazione su cavo lan non ho problemi. Con il firmware precedente nessun problema.Ho controllato le impostazioni del firewall del nas e mi sembrano identiche in entrambi i firmware, anche il resto delle impostazioni mi pare identico.

abarth83
24-04-2014, 06:24
Il problema della disconnessione wan persiste.. ho notata che avviene quando disabilito il wi-fi... infatti nel cron ho settato la disabilitazione del wi fi e riattivazione alle 7.00 ma quando si riattiva si disabilita la Wan:muro:

rylos
24-04-2014, 07:26
Si ho notato anch'io purtroppo. Ho già segnalato il problema sul trac di OpenWrt, vuol dire che aggiorneremo presto.... :)

@abarth83
Si ti confermo che i pacchetti sono quelli.

rylos
25-04-2014, 14:04
Per ora ho trovato un workaround per chi disabilita il wifi in modo schedulato e perde la connessione wan:

nei job cron aggiungete "&& ifup wan", il modulo dsl in effetti non si scollega, solo la wan perde il "ponte" in modo indefinito.

Ecco il job cron con il workaround:

#disabilitare wifi (es. 00:30)
30 00 * * * uci set wireless.radio0.disabled=1 && uci commit wireless && wifi && ifup wan

#abilitare wifi (es. 06:30)
30 06 * * * uci set wireless.radio0.disabled=0 && uci commit wireless && wifi && ifup wan


Quando sarà fixato nelle prossime build, questa modifica non servirà più.

massimo1995
26-04-2014, 11:48
^_^

rylos
26-04-2014, 12:13
Per chi la volesse provare è online la build 40569.

sunvit
26-04-2014, 16:09
Per chi la volesse provare è online la build 40569.

Appena installata...ok per la parte ADSL ed il resto ma come per la precedente rimane il bug della disabilitazione wifi e perdita connessione wan.

massimo1995
26-04-2014, 17:09
sunvit



sunvit ho appena finito di installare openupload sul openwrt-tdw8970
quindi in riferimento alla tua domanda se era installabile nel ns router?
la risposta e si
domani in giornata posto tutta la guida dettagliata ciao^_^

sunvit
26-04-2014, 17:18
sunvit



sunvit ho appena finito di installare openupload sul openwrt-tdw8970
quindi in riferimento alla tua domanda se era installabile nel ns router?
la risposta e si
domani in giornata posto tutta la guida dettagliata ciao^_^

Ok grazie non vedo l'ora di provarlo sul mio router.
Riguardo la tua guida per il serverftp sai come fare ad inserire nuovi utenti e "bloccarli" nella loro home directory?

massimo1995
27-04-2014, 07:04
Ok grazie non vedo l'ora di provarlo sul mio router.
Riguardo la tua guida per il serverftp sai come fare ad inserire nuovi utenti e "bloccarli" nella loro home directory?

no adesso non saprei dirti come fare ad inserire nuovi utenti, dopo l'installazione transmission-daemon l' ftp punta la root dei download torrent quindi non mi sono posto per il momento questo problema risolvibile

massimo1995
27-04-2014, 07:27
^_^

massimo1995
27-04-2014, 11:40
^_^

achmav
27-04-2014, 17:25
Grande massimo :D

Qualche domanda a riguardo.

Come web server stai utilizzando lighttpd o uhttpd o entrambi?
Perché sulla guida per owncloun su openwrt (http://wiki.openwrt.org/doc/howto/owncloud) il creatore afferma che sul TP-Link TL-WR2543ND con lighttpd, owncloud è estremamente lento. Sul nostro come gira?

Usando lighttpd immagino bisogna quindi installare (correggimi se sbaglio):
- lighttpd e dipendenze varie come da tua guida (http://www.hwupgrade.it/forum/showpost.php?p=41005102&postcount=40);
- phpmyadmin come da tua guida suindicata;
- ownclound.

Sul sito di phpMyAdmin ora riportano la versione 4.1.14, nella guida tu usi la 2.10.3, c'è un motivo particolare o posso usare l'utima?

Per quanto riguarda l'errore da te riscontrato, pare forse dipenda dalla mancanza, in fase di compilazione di openwrt, del supporto alla localizzazione. Se è questo il motivo e non si trova una soluzione, magari rylos potrebbe integrarlo nel prossimo firmware per vedere se si risolve (a meno che sia solo un errore che compare nel log e owncloud funzioni bene anche senza).

grizu99
27-04-2014, 18:16
Buona domenica,
volevo provare a capire se è il mio w8970 sfortunato, io imbranato oppure il firmware ancora un po’ acerbo. Io trovo openwrt stabile e veloce se si usa il router sfruttando le funzioni di base. Ma nel momento in cui provo ad usare le funzioni per cui ho montato questo firmware allora le cose cambiano. Il server minidlna se attivato comporta spesso riavvii del modem. Se uso trasmission ho un numero di riavvii del router ancora superiore e pur avendo “aperto” le porte la velocità dei torrent è sempre assai bassa se paragonata alla velocità con cui scarico da pc (testato con i torrent di linuxmint). Ho pensato che fosse colpa della chiavetta usb, ma né ho provato 3 di marche diverse, e con tutte stesso problema, ho anche usato 2 hardisk (sia ext4 che ntfs) alimentati ravvisando i medesimi problemi. Poi come ho scritto qualche post sopra solo la versione “40335” pare andare "d’accordo" al 100% con la mia rete. Buona serata

massimo1995
27-04-2014, 19:57
^_^

achmav
27-04-2014, 21:54
Perfetto, grazie massimo.
Nella guida sul wiki di openwrt che ti ho indicato prima è indicato come configurare uhttpd per owncloud, assegnandogli un'altra porta per non interferire con luci. Magari se ti va potresti provare così da testare la differenza di prestazioni con entrambi i server. Purtroppo in questi giorni non ho tempo da dedicare alle varie prove, per cui mi perdonerai se sfrutto la tua disponibilità e competenza. :)

@grizu99
Se non sbaglio anche tu eri interessato a owncloud :)

Comunque anch'io avevo problemi di riavvii quando usavo pyload, ma non con minidlna (che però uso poco e con pochi file indicizzati). Tieni comunque presente che openwrt è approdato da poco sul nostro router (a cui chiediamo di fare cose per cui non è stato progettato) per cui c'è da aspettarsi bug e problemi vari. Fortunatamente il grande Rylos ci tiene sempre costantemente aggiornati :)

nebbia88
27-04-2014, 22:24
@grizu

Provato con rtorrent?

massimo1995
28-04-2014, 14:49
@grizu

Provato con rtorrent?

ciao nebbia88 sai come installare rtorrent? perché non e disponbile su openwrt-luci o dove scaricare il file ipk graz ^_^

rylos
28-04-2014, 15:53
Ho messo in drive l'ultimo firmware oem DSL per il nostro router, ossia il file dsl_vr9_firmware_xdsl-05.06.00.08.01.06_05.05.02.00.01.01.bin

Lo sto usando da ieri sera, e mi tiene una velocità maggiore di circa 200/300kb mantenendo i db stabili a 6 (ovviamente nel mio caso).

Potete sostituirlo a quello attuale (sempre come vdsl.bin o come link simbolico).

A voi i test sulle vostre linee.... :)

strassada
28-04-2014, 16:32
in upload dovrebbe far agganciare qualcosina in più (mi riferisco a chi ha il profilo a 1216/1000 in upload e aggancia 100-200kbps in meno), ma ancora siamo distanti da quello che fanno normalmente altri modem e chipset.

nebbia88
28-04-2014, 17:32
che fortuna...

http://buildbot.openwrt.org:8010/broken_packages/lantiq/rtorrent/compile.txt

Totix92
28-04-2014, 18:03
in upload dovrebbe far agganciare qualcosina in più (mi riferisco a chi ha il profilo a 1216/1000 in upload e aggancia 100-200kbps in meno), ma ancora siamo distanti da quello che fanno normalmente altri modem e chipset.

sarebbe bello se tp-link lo implementasse con il prossimo firmware... ma la vedo dura... :(

@rylos
ci sono novità per l'installazione da interfaccia web di openwrt per chi ha l'ultimo firmware? si stanno muovendo o sono ancora fermi?

strassada
28-04-2014, 18:33
quel file è di un anno fa, purtroppo gli unici trovabili recenti sono quelli sugli AVM, al limite si potrebbe provare il 5.6.5.0.0.7_5.6.1.B.0.1 (ma a lanfi non si allineava nei test di marzo, bisognerebbe riprovare con le build recenti che hanno modifiche sull'adsl).

sunvit
28-04-2014, 18:47
quel file è di un anno fa, purtroppo gli unici trovabili recenti sono quelli sugli AVM, al limite si potrebbe provare il 5.6.5.0.0.7_5.6.1.B.0.1 (ma a lanfi non si allineava nei test di marzo, bisognerebbe riprovare con le build recenti che hanno modifiche sull'adsl).

Riesci a postarlo da qualche parte che lo proviamo?

strassada
29-04-2014, 00:12
si trova in questo archivio
http://pliki.gru.one.pl/11-2013/vr9.7z file netiaspot-vr9-A-dsl.bin
in altarnativa in questo firmware del Draytek Vigor130 ftp://ftp.draytek.com/Vigor130/Firmware/v3.7.5/Vigor130_v3.7.5_modem4.zip (con cosa aprire i file all o rst, non saprei, forse funziona anche draytools (su github...), oppure Firmware Mod Kit ecc...)
http://www.adslgr.com/forum/threads/735742-Review-DrayTek-2760n?p=5380838#post5380838
come si può vedere, anche col 2760 funziona in adsl2+ Annex A, ma non è specificato il dslam.
lato vdsl2, supporta il G.Vector.

rylos
29-04-2014, 09:41
@strassada: grazie per le delucidazioni.
Ho provato ad estrarre il firmware dal vigor con le draytools, ma estraggono solo la config e il filesystem del web quindi è inutile.

Confermo cmq che con l'ultima release OEM del firmware dsl la mia linea resta stabile rispetto al bin precedente.

Col bin precedente dopo qualche giorno l'SNR mi scendeva sui 5db senza mai più risalire (stesso effetto che mi faceva col firmware ufficiale tplink). Con questo mi resta stabilissima sui 6db.

Per quanto riguarda il flash via web ufficiale tplink (penultima versione) ci sto guardando.

rylos
29-04-2014, 14:07
Ho compilato una nuova build v40588 EXPERIMENTAL, che disabilita completamente il debug del kernel e mette vari pacchetti opzionali (compreso IPv6 e print server).

Questa manovra ha liberato ulteriori 200kB preziosi dalla flash.

nebbia88
29-04-2014, 19:10
Col bin precedente dopo qualche giorno l'SNR mi scendeva sui 5db senza mai più risalire (stesso effetto che mi faceva col firmware ufficiale tplink). Con questo mi resta stabilissima sui 6db.


immagino tu ti riferisca solo all'snr indicato? cioè non è che noti differenze reali...

nebbia88
30-04-2014, 22:36
scusate se me lo sono perso, qualcuno ne sa qualcosa??

https://forum.openwrt.org/viewtopic.php?pid=222065

strassada
30-04-2014, 22:41
i comandi permessi sono tanti, prima o poi almeno i più utili saranno disponibili su una paginetta, senza dover andare per forza di telnet

nebbia88
30-04-2014, 22:55
la mia domanda era un'altra.. qulacuno li ha provati? magari di quelli che lamentano portanti basse con questo modem... siete riusciti a risolvere?

strassada
30-04-2014, 23:10
ah, boh, finora nessuno ha postato qualcosa (rylos ha indicato tempo fa un comando, non ricordo se è uguale http://hwupgrade.it/forum/showpost.php?p=40709658&postcount=4193): evidentemente chi ha su openwrt ha la 7 mega oppure aggancia già il massimo (comunque quel comando è solo per l'snr in download) o non gli interessa ("noi" siamo in attesa di poter installarlo sul firmware direttamente da gui).
comunque spero che si creerà un altro thread (non importa che sia ufficiale, va bene anche in networking se no tutti sti test di linea "rovineranno" il thread. ovviamente guide e link a riscontri si potranno riportare qui) in particolare potendo cambiare al volo il file .bin xdsl, di test comparativi se ne possono fare a decine per linea. Pur non essendo come i Conexant, i Lantiq permettono di intervenire su decisamente più parametri dei Broadcom.

abarth83
01-05-2014, 19:57
Ho compilato una nuova build v40588 EXPERIMENTAL, che disabilita completamente il debug del kernel e mette vari pacchetti opzionali (compreso IPv6 e print server).

Questa manovra ha liberato ulteriori 200kB preziosi dalla flash.

build v40588 secondo me persiste il bug wi fi che disconette la wan..

massimo1995
02-05-2014, 14:10
openwrt-lantiq-xrx200-TDW8970-sysupgrade_v40588_EXPERIMENTAL
dsl_vr9_firmware_xdsl-05.06.00.08.01.06_05.05.02.00.01.01
liberato spazio 200kB preziosi dalla flash
box esterno 4tb extroot supportato
pacchetti opzionali (compreso IPv6 e print server) rimossi
performance ottimo aperture pagine web ultra veloce
come sempre grazie rylos :sofico:

massimo1995
02-05-2014, 15:35
raga dopo l'extroot ho questo errore :
kern.warn kernel: EXT4-fs warning (device sda1): __ext4_read_dirblock:908: error reading directory block (ino 9175108, block 0)
come posso risolvere?
grazie

abarth83
02-05-2014, 16:00
raga dopo l'extroot ho questo errore :
kern.warn kernel: EXT4-fs warning (device sda1): __ext4_read_dirblock:908: error reading directory block (ino 9175108, block 0)
come posso risolvere?
grazie

scusa hai provato se disconnettendo il wifi si disconette la wan?

sunvit
02-05-2014, 18:16
raga dopo l'extroot ho questo errore :
kern.warn kernel: EXT4-fs warning (device sda1): __ext4_read_dirblock:908: error reading directory block (ino 9175108, block 0)
come posso risolvere?
grazie

Hai provato a rifare tutto da zero e a formattare la pen drive?

Inviato dal mio GT-I9300 utilizzando Tapatalk

massimo1995
02-05-2014, 18:59
abarth83
ho disconnesso il wifi riesco a navigare sul web se puoi essere + dettagliato in modo da fare prove ti sarei grato
--------------------------------------------------------------------------------------
sunvit non e una pen drive ma un box esterno usb con hdd interno

nebbia88
02-05-2014, 19:07
suggerirei un fsck.ext4 per quell'hdd.. e magari smontarlo prima di scollegarlo..

sunvit
02-05-2014, 19:09
Credo che abarth dica:
Prova a navigare via WiFi poi staccalo riattaccalo e vedi se naviga ancora.
Per il tuo extroot ti chiedevo di provare a riformattare il supporto ma dato che è un box grandetto non credo ti verrà così semplice.

Inviato dal mio GT-I9300 utilizzando Tapatalk

abarth83
03-05-2014, 08:15
Credo che abarth dica:
Prova a navigare via WiFi poi staccalo riattaccalo e vedi se naviga ancora.
Per il tuo extroot ti chiedevo di provare a riformattare il supporto ma dato che è un box grandetto non credo ti verrà così semplice.

Inviato dal mio GT-I9300 utilizzando Tapatalk

si io ho provato e mi saltava la wan se a te va bene riprovo sono ritornato alla versione 335

ozlacs
03-05-2014, 14:51
build r40588, confermo che cade la wan all'accensione/spegnimento del wi-fi, per il resto ok

massimo1995
04-05-2014, 09:19
ho disabilitato + volte il wifi su 2 pc ma non succede nulla riesco a navigare senza disconnessione wan
openwrt-lantiq-xrx200-TDW8970-sysupgrade_v40588_EXPERIMENTAL
raga maggiori info per testare
mi sono accorto che con il smartpad ogni tanto o un calo di segnale e quindi una disconnessione dall'web ma con i pc nulla

commandospirit
04-05-2014, 11:17
Bellissimo!, seguo con molto interesse avendo questo fantastico modem router!, non sapevo supportasse anche la VDSL :sofico: :ciapet:

massimo1995
04-05-2014, 14:13
Bellissimo!, seguo con molto interesse avendo questo fantastico modem router!, non sapevo supportasse anche la VDSL :sofico: :ciapet:

benvenuto commandospirit

sunvit
04-05-2014, 14:47
ho disabilitato + volte il wifi su 2 pc ma non succede nulla riesco a navigare senza disconnessione wan
openwrt-lantiq-xrx200-TDW8970-sysupgrade_v40588_EXPERIMENTAL
raga maggiori info per testare
mi sono accorto che con il smartpad ogni tanto o un calo di segnale e quindi una disconnessione dall'web ma con i pc nulla

No no devi disabilitare il WiFi del router e non del PC.

Inviato dal mio GT-I9300 utilizzando Tapatalk

rylos
05-05-2014, 12:02
v40695 experimental online

massimo1995
05-05-2014, 18:26
No no devi disabilitare il WiFi del router e non del PC.

Inviato dal mio GT-I9300 utilizzando Tapatalk

si disabilito il wifi dal router per essere precisi dall'interfaccia web luci poi riavvio wifi sempre dal router nulla riesco a navigare senza disconnessione cqm domani provo l'ultima di rylos
v40695 experimental online
ps problema box esterno con hdd 500gb e hdd4tb risolto ho dovuto rifare la procedura extroot

massimo1995
06-05-2014, 07:16
caricati con successo nuova sysupgrade v40695
openwrt-lantiq-xrx200-TDW8970-sysupgrade_v40695_EXPERIMENTAL
dsl_vr9_firmware_xdsl-05.06.00.08.01.06_05.05.02.00.01.01
provo a testare wifi wan e v faccio sapere come sempre graz rylos
per rylos nella versione openwrt-lantiq-xrx200-TDW8970-sysupgrade_v40335 era disponibile in OpenWrt - LuCI un pacchetto di nome RTORRENT CHE ADESSO con il nuovo OpenWrt Barrier Breaker r40695 o con il vecchio v40588 non c'è
ce un modo semplice per installare rtorrent?

ozlacs
06-05-2014, 10:00
la variazione dell'snr si fà da console, con putty tramite ssh per esempio, il nome del comando e i paramatri da usare dovrebbero essere in giro nel thread.
io non ho avuto modo di testarlo in quanto ho un 7M con già portante massima, non sò se qualcun'altro abbia provato.

il firmware originale lo puoi tranquillamente flashare da interfaccia web di openwrt

strassada
06-05-2014, 12:51
su un forum polacco (openwrt.pl) in un thread su un porting per il td-w8970, si trova il file kmod-ltq-vdsl-fw-a_0.1-1_lantiq.ipk con al suo interno il file v9-A-dsl.bin tratto da un AVM, versione 5.6.7.3.1.7_5.6.1.E.1.1 se qualcuno vuole provarla, ho messo il file bin qui (https://mega.co.nz/#!3R51SCCZ!vIbrbBWE-PE4fPEMfMEACb2MmCRmc0_EmUFQvqvRbFc)

Totix92
06-05-2014, 14:05
ragazzi ma il cavo nokia ca-53 va bene? oppure deve essere per forza il cavo ca-42?
mi sta venendo la fissa di installare openwrt ma probabilmente per evitare di fare casini e di perdere la garanzia aspetterò il flashabile da interfaccia web... sapete se si sa qualcosa in merito all'header del bootloader dell'ultimo firmware originale tp-link?

sunvit
06-05-2014, 14:15
su un forum polacco (openwrt.pl) in un thread su un porting per il td-w8970, si trova il file kmod-ltq-vdsl-fw-a_0.1-1_lantiq.ipk con al suo interno il file v9-A-dsl.bin tratto da un AVM, versione 5.6.7.3.1.7_5.6.1.E.1.1 se qualcuno vuole provarla, ho messo il file bin qui (https://mega.co.nz/#!3R51SCCZ!vIbrbBWE-PE4fPEMfMEACb2MmCRmc0_EmUFQvqvRbFc)

Appena provato non va
idle request [0xff]


Inviato dal mio GT-I9300 utilizzando Tapatalk

strassada
06-05-2014, 17:34
sai su che dslam sei? potrebbe essere un'incompatibilità, anche per il dgn3500 su un paio di dslam con chip Broadcom non funzionano i i firmware adsl (modemhwe.bin) uguale e superiori alla 4.5.x.x.x.x, mentre funzionano tutti quelli precedenti.

penso anche io che nessuno di questi possa andare, ma boh, magari mettendo mano a qualcosa... se non sbaglio è come l'altro aggiunto: lato vdsl2 supporta il g.vector, lato adsl2+ teoricamente dovrebbe essere Annex A (l'1 finale della sestina adsl, indica Annex A se fosse 2 sarebbe Annex B)

sunvit
06-05-2014, 21:51
Si DSLAM Alcatel e purtroppo non va.

Inviato dal mio GT-I9300 utilizzando Tapatalk

rylos
07-05-2014, 08:09
OpenWRT v40718 online (EXPERIMENTAL)

x rtorrent: il package rtorrent da errori in fase di compilazione, ho però incluso transmission (quindi con compilazione ottimizzata al mio kernel) che trovate nella cartella packages

Quando rtorrent sarà sistemato sarà re-incluso.

Edit:
Transmission ha anche un package plugin x Luci, cosi lo potete gestire direttamente da web

Per chi fosse interessato, al link LINK (http://downloads.openwrt.org/snapshots/trunk/lantiq/packages/) finalmente è anche disponibile pyLoad 0.4.9 (ultima release stabile), per chi fosse interessato [pyLoad è un software simile a jdownloader]

Edit 2:
Non riesco a far funzionare in modo corretto pyload, forse manca ancora qualcosina a questo package:D

abarth83
07-05-2014, 18:05
rylos sono nella cacca ho aggiornato all ultima immagine ma il router non rispondeva a questo punto gli ho ridato di seriale ma quando do i comandi per cancellare la memoria mi dice offset len e gia qui non mi ricordo se era normale e poi aspetto aspetto ma l interfaccia non si carcia anzi mi sembra che ricominci sempra da capo il boot... cosa posso fare?

rylos
07-05-2014, 18:10
Quando carichi l'immagine via TFTPD ti dice la len del file in hex, quando esegui il comando di write devi usare quella len.
Cmq se hai il boot, è tutto ok, sei a posto...occhio ai comandi E A NON SOVRASCRIVERE IL BOOT (li sarebbe cacca davvero).

esempio:
sf write 0x80800000 0x20000 0xhex-letto-prima

Se programmi l'ultima EXPERIMENTAL e va in boot-loop (si riavvia all'infinito), carica l'ultima che ti andava.

abarth83
07-05-2014, 18:51
Quando carichi l'immagine via TFTPD ti dice la len del file in hex, quando esegui il comando di write devi usare quella len.
Cmq se hai il boot, è tutto ok, sei a posto...occhio ai comandi E A NON SOVRASCRIVERE IL BOOT (li sarebbe cacca davvero).

esempio:
sf write 0x80800000 0x20000 0xhex-letto-prima

Se programmi l'ultima EXPERIMENTAL e va in boot-loop (si riavvia all'infinito), carica l'ultima che ti andava.

ok apposto avevo dimenticato uno spazio cacchio stavo in palla...
e poi il bello che seguivo la solita guida cmq si ho ricaricato il mitico 40335.. e questa volta ho lasciato la seriale saldata e messa bene per eventuali altri scherzetti.:muro:

sunvit
07-05-2014, 19:45
Quindi l'ultima experimental non va o ti è successo qualcosa durante il flash?

Inviato dal mio GT-I9300 utilizzando Tapatalk

abarth83
08-05-2014, 07:23
Quindi l'ultima experimental non va o ti è successo qualcosa durante il flash?

Inviato dal mio GT-I9300 utilizzando Tapatalk

no non è successo nulla ho caricato l'immagine come sempre ma al riavvio nulla..boot loop e chiaramente non era raggiungibile da telnet interfaccia ecc..
ho dovuto rifleshare da seriale. eccola in foto sistemata con cavo per ventoline
http://i58.tinypic.com/2m7axhf.jpg

sunvit
08-05-2014, 11:41
Quindi a questo punto meglio che rylos la tolga.

Inviato dal mio GT-I9300 utilizzando Tapatalk

nebbia88
08-05-2014, 12:52
era utile se riprovavi e salvavi il log che dava da seriale!

massimo1995
08-05-2014, 13:16
raga non ho capito se questa funziona OpenWRT v40718 online (EXPERIMENTAL)
abarth83 hai avuto problemi con questo sysupgrade cqm ottima modifica mo la faccio come la tua ^_^

rylos
08-05-2014, 13:45
Sto facendo l'upload della v40728 [EXPERIMENTAL]

PS
Per chi chiedeva come gestire gli utenti di Pure-FTP: LINK (http://wiki.openwrt.org/doc/uci/pure-ftpd#creating.virtual.users)

sunvit
08-05-2014, 14:17
Sto facendo l'upload della v40728 [EXPERIMENTAL]

PS
Per chi chiedeva come gestire gli utenti di Pure-FTP: LINK (http://wiki.openwrt.org/doc/uci/pure-ftpd#creating.virtual.users)

Ero io...Grazie tante.

Inviato dal mio GT-I9300 utilizzando Tapatalk

abarth83
08-05-2014, 15:12
raga non ho capito se questa funziona OpenWRT v40718 online (EXPERIMENTAL)
abarth83 hai avuto problemi con questo sysupgrade cqm ottima modifica mo la faccio come la tua ^_^

si ho avuto problemi.. ho dovuto ridare di seriale ora c è la nuova release che però non ho provato.

nebbia88
08-05-2014, 16:32
immagino che un collegamento diretto tra seriale del pc al router non funzioni, in pratica con un null modem saldato correttamente..


hai rischiato seriamente di friggere l'rx del router se la seriale esce coi 12V dell' RS232!!!

http://wiki.openwrt.org/doc/hardware/port.serial

grizu99
09-05-2014, 16:12
anche con la versione v40728 non si aveva accesso alla interfaccia web, ho dovuto reinstallare la v40335 tramite seriale. Qualche temerario ha provato la versione che è ora disponibile la v40740?
due domande stupide, ma il file "config" sul sito a cosa serve?
ovviamente gli aggiornamenti una volta installata la openwrt tramite seriale li posso fare da interfaccia web, corretto?
considerazione da tenere presente: il tasto reset non pare andare, quindi se fate "esperimenti" con la configurazione delle interfacce e non riuscite + ad accedere al router (mi è capitato) l'unica soluzione credo che sia la seriale, confermate?
ciao!

abarth83
09-05-2014, 16:18
anche con la versione v40728 non si aveva accesso alla interfaccia web, ho dovuto reinstallare la v40335 tramite seriale. Qualche temerario ha provato la versione che è ora disponibile la v40740?
due domande stupide, ma il file "config" sul sito a cosa serve?
ovviamente gli aggiornamenti una volta installata la openwrt tramite seriale li posso fare da interfaccia web, corretto?
considerazione da tenere presente: il tasto reset non pare andare, quindi se fate "esperimenti" con la configurazione delle interfacce e non riuscite + ad accedere al router (mi è capitato) l'unica soluzione credo che sia la seriale, confermate?
ciao!
il config sono le impostazioni di rylos.
si gli aggiornamenti li fai da interfaccio luci.
si il reset non funziona.. bisogna andare di seriale:muro:

rylos
09-05-2014, 16:48
Se provate le ultime experimental postate qui il log del boot? Così vedo di capire cosa non va.

sunvit
09-05-2014, 19:22
OK.Spero di aver tempo domani.

Inviato dal mio GT-I9300 utilizzando Tapatalk

rylos
10-05-2014, 16:19
Ho flashato via seriale l'ultimo firmware TP-Link originale per estrarre il firmware dsl vr9 ma con rammarico ho scoperto che si tratta esattamente della nostra PENULTIMA versione...siamo più avanti noi insomma :)


/firmware # ls -ail
62 -rwxrwxr-x 1 772 xdslled.sh
65 lrwxrwxrwx 1 61 xcpe_hw.bin -> dsl_vr9_firmware_xdsl-05.04.08.00.00.06_05.04.04.04.00.01.bin
68 -rw-rw-r-- 1 92 vdsl.scr
64 -rwxrwxr-x 1 5321 eth_wan_setting.sh
61 -rwxrwxr-x 1 6184 dsl_wan_setting.sh
63 -rwxrwxr-x 1 815532 dsl_vr9_firmware_xdsl-05.04.08.00.00.06_05.04.04.04.00.01.bin
67 -rwxrwxr-x 1 233 dsl_cpe_pipe.sh
66 -rw-rw-r-- 1 92 adsl.scr
60 drwxrwxr-x 15 204 ..
1 drwxrwxr-x 2 228 .

strassada
10-05-2014, 17:54
stiamo provando a convincere la tp-link a farsi aggiornare la porte adsl, quantomeno il binario. vedremo nelle prossime settimane, teoricamente dovrebbe uscire un firmware per portare il td-w8970 alla pari degli altri appena aggiornati (es. rete guest)

rylos
10-05-2014, 18:42
v40746 = TESTED

massimo1995
10-05-2014, 19:28
ciao raga ho un problema alquanto strano sulla seconda porta usb in pratica riesco a montare la usb in formato ext4 come sdb1 ma poi dopo poco tempo si dissocia facendo all' primo tentativo fdisk -l la configura come sdb1 poi la dissocia dopo qulche tempo e rifacendo fdisk -l la configura come sdc1 come mai?
c'è un modo per fissare sdb1 graz:muro:

Totix92
10-05-2014, 19:41
stiamo provando a convincere la tp-link a farsi aggiornare la porte adsl, quantomeno il binario. vedremo nelle prossime settimane, teoricamente dovrebbe uscire un firmware per portare il td-w8970 alla pari degli altri appena aggiornati (es. rete guest)

speriamo :eek: :cool: tienici informati :D

ozlacs
10-05-2014, 20:45
v40746 = TESTED

nei settaggi del wifi manca la modalità n, c'è solo a,b,g e auto.
non ho modo in questo momento però di verificare l'effettiva modalità attiva perchè non ho roba wireless sottomano :D

pegasolabs
11-05-2014, 09:01
Non andate OT, grazie.

strassada
11-05-2014, 12:18
speriamo :eek: :cool: tienici informati :D

l'anno scorso mi risposero picche, vediamo sta volta.

comunque confido più in Draytek, coi modem code esterni per la serie 2760, col prossimo firmware potrebbero rilasciarne degli altri e più recenti, rispetto a quelli disponibili ora.
sempre sui draytek, ho anche trovato questo:
ftp://ftp.simet.com.tr/02_TEKNIK_SERVIS/01_DrayTek/Vigor_2760/DrayOs/3gdhcpfix_MF667_V2760.zip
cercando @(#) nel file .all, si trova
5.6.6.2.0.7 5.6.2.1.0.1
5.6.7.5.1.7 5.6.2.3.0.1

massimo1995
11-05-2014, 12:52
^_^

a1pollo
11-05-2014, 15:14
Salve a tutti
Ho il codesto router da un paio di giorni
Il router va benissimo
Vorrei mettere openwrt ma è ancora presto
Volevo chiedervi se le porte USB con hdd sopra,
Sono più veloci con openwrt.

Grazie!


PS. Bravi anche per openwrt!

massimo1995
11-05-2014, 15:26
Salve a tutti
Ho il codesto router da un paio di giorni
Il router va benissimo
Vorrei mettere openwrt ma è ancora presto
Volevo chiedervi se le porte USB con hdd sopra,
Sono più veloci con openwrt.

Grazie!


PS. Bravi anche per openwrt!

cosa intendi Volevo chiedervi se le porte USB con hdd sopra,
Sono più veloci con openwrt?
io faccio lo streaming da hdd 250 gb sata bridge e 4tb hdd minidlna verso tv sansung e altre tv senza problemi il firmware originale td-w8970 e troppo ma troppo limitato mentre con openwrt hai una macchina Linux ^_^

sunvit
11-05-2014, 15:43
Posso solo confermare quello che dice Massimo.
Peccato solo che non riesco a far andare pyload con account premium.

Inviato dal mio GT-I9300 utilizzando Tapatalk

massimo1995
11-05-2014, 15:43
ciao rylos ti voglio chiedere se e possibile cambiare percorso dell'file vdsl.bin per risparmiare spazio sulla console mi spiego meglio nella tua guida specifichi che bisogna Copiate nel percorso /lib/firmware il file _xdsl-05.06.00.08.01.06_05.05.02.00.01.01 e rinominatelo in vdsl.bin ,questo file occupa spazio per 864 KB l'limitandolo
la mia domanda: e possibile caricare su usb per ipotesi nel mio caso hdd sata questo file vdsl.bin e far puntare il td-w8970 per cercare vdsl.bin?graz:stordita:

rylos
11-05-2014, 20:10
Il file vdsl.bin lo puoi mettere nel percorso che preferisci, guarda la sezione dsl del file network:

root@OpenWrt:/etc/config# cat network | tail -n 6
config vdsl 'dsl'
option annex 'a'
option firmware '/lib/firmware/vdsl.bin'
option tone 'av'
option xfer_mode 'atm'

root@OpenWrt:/etc/config#


Edit 1
Ho fatto i test del wifi programmato con l'ultima TESTED e la wan non perde la connessione. (nel mio caso la wan6 non è presente, la elimino perchè non mi serve l'ipv6).

Edit 2
Ho anche verificato i settaggi del wifi, l'n esiste, guardate lo screenshot.

commandospirit
11-05-2014, 20:38
Scusatemi se vado in off topic, ma con il firmware stock ho problemi di disconnessioni che in un altro modem non ho.

Ne sapete qualcosa o avete lumi se con open wrt questo problema è stato risolto? :cry:

a1pollo
11-05-2014, 21:44
ciao, ho il firm. originale quando copio da pc su hdd che stanno sulle usb del router non va piu veloce di 2,5 mb al secondo sia con samba che via ftp,
volevo sapere se i trasferimenti vanno piu veloci con open wrt

massimo1995
12-05-2014, 08:08
ciao, ho il firm. originale quando copio da pc su hdd che stanno sulle usb del router non va piu veloce di 2,5 mb al secondo sia con samba che via ftp,
volevo sapere se i trasferimenti vanno piu veloci con open wrt

ciao a1pollo per avere una velocita maggiore di 2.5 (td-w8970 originale o openwrt) prova a collegare il cavo lan diretto all' td-w8970 utilizza filezilla o simili per avere una velocita pari a 7,8 mb/s


a1pollo , figlio di Apollo
Fece una palla di pelle di pollo
Tutti i pesci vennero a galla
Per vedere la palla di pelle di pollo
Fatta da Apelle figlio di Apollo

massimo1995
12-05-2014, 08:45
ciao raga per chi fosse interessato cercando su internet ho trovato una web gui diversa da quella originale transmission web vi posto il file:
http://www.mediafire.com/download/x84v34zyx1yxzu4/transmission-control-full.tar.gz
basta copiarla e rinominare l'originale

ozlacs
12-05-2014, 09:22
Edit 2
Ho anche verificato i settaggi del wifi, l'n esiste, guardate lo screenshot.

e che ti devo dire, con le release precedenti avevo come dal tuo screenshot, con l'ultima build ho questo:

http://img193.imagevenue.com/loc387/th_75502_DSC01521_122_387lo.jpg (http://img193.imagevenue.com/img.php?image=75502_DSC01521_122_387lo.jpg)

come detto però in questo momento non ho modo di verificare non avendo dispositivi wi-fi sottomano

abarth83
12-05-2014, 09:52
ciao raga per chi fosse interessato cercando su internet ho trovato una web gui diversa da quella originale transmission web vi posto il file:
http://www.mediafire.com/download/x84v34zyx1yxzu4/transmission-control-full.tar.gz
basta copiarla e rinominare l'originale

Uno screen?

massimo1995
12-05-2014, 10:17
Uno screen?

guarda http://code.google.com/p/transmission-control/
e una grafica diversa lo provata e anche in italiano lo cambiata perché la webgui originale transmission e un po brutta

lcapriotti
12-05-2014, 10:34
che prestazioni ci ottengono condividendo (SMB/NFS) un disco USB?

massimo1995
12-05-2014, 10:43
[QUOTE=lcapriotti;41082286]che prestazioni SI ottengono condividendo (SMB/NTFS) SU un disco USB INTENDEVI QUESTO?
MA SU MACCHINA LINUX E CONSIGLIABILE EXT4 ETX3 ECC...

lcapriotti
12-05-2014, 10:50
intendo dire: condividendo un disco (formattato ext4 o altro) in rete, che throughput si riesce ad ottenere?

massimo1995
12-05-2014, 10:55
intendo dire: condividendo un disco (formattato ext4 o altro) in rete, che throughput si riesce ad ottenere?
NON HO TESTATO throughput dati trasmessi in una unità di tempo MA su una rete domestica lo striaming non da problemi di qualità video e audio e dati io uso etx4

massimo1995
12-05-2014, 11:51
perchè usare queste porcate? l'ho provata tempo fa, la trovo inutile e uno dei vantaggi di transmission è che ha una interfaccia leggera e pulita.

se volete controllare a pieno transmission usate transgui per windows (scaricabile qui (https://code.google.com/p/transmisson-remote-gui/)) che si interfaccia tramite il suo protocollo di comunicazione oppure remote transmission sul Play Store per Android (scaricabile qui (https://play.google.com/store/apps/details?id=com.neogb.rtac&hl=it)) con lo stesso principio.

l'interfaccia web è giusto informativa, serve a poco altro.


Pigr8 SONO DACCORDO UTILIZZARE transgui per windows ALLEGERISCE IL CARICO SULLA NOSTRA SCATOLA INFATTI LA MIA ERA UNA OSSERVAZIONE

abarth83
12-05-2014, 12:22
Pigr8 SONO DACCORDO UTILIZZARE transgui per windows ALLEGERISCE IL CARICO SULLA NOSTRA SCATOLA INFATTI LA MIA ERA UNA OSSERVAZIONE

io avevo capito un interfaccia grafica per openwrt.. sentite una guida su come installare transmission si può fare o basta installare il pacchetto e quale?
avete provato la nuova release di rylos?

a1pollo
12-05-2014, 12:50
ciao,

ho provato via lan 100 ,e hai ragione, raggiungo circa 5,5 mb/s.

ho 2 hdd usb collegati al router, e i trasferimenti di files tra loro vanno al massimo
a 2 mb/s.
ora lo sto solo testando, in futuro passero' ad openwrt

altro:
ho un tv samsung, con samygo, su cui ho un client smb,
ho testato un bluray rip 1080p full untouched nell hdd usb sul router
e, un po si blocca e riparte a scatti ogni circa 10 secondi, potresti provarne qualcuno con openwrt?
ciao.


a1pelle , figlio di A1pollo....:banned:

Totix92
12-05-2014, 13:04
dubito che cambi qualcosa... io con il firmware originale raggiungo i 12.5 MB/s cioè il massimo della lan 100 mbits, e 9 MB/s con le usb.

a1pollo
12-05-2014, 13:16
quindi dovrei mettere un pennino wifi ,sul samsung, n150 o n300
per evitare rallentamenti.
Peccato preferivo via cavo.

massimo1995
12-05-2014, 13:41
^_^

massimo1995
12-05-2014, 13:43
quindi dovrei mettere un pennino wifi ,sul samsung, n150 o n300
per evitare rallentamenti.
Peccato preferivo via cavo.

anche io o un Samsung tv ma non ho rallentamenti con minidlna acquista dei powerline tp-link e risolvi

a1pollo
12-05-2014, 14:22
ma il tv ha comunque una lan 100

preciso che i film 1080p vanno bene
solo quelli untouched hanno scatti
che probabilmente hanno un bitrate alto


minidlna e' ok con i samsung?
il dlna del router non modificato non va

massimo1995
12-05-2014, 14:39
^_^

a1pollo
12-05-2014, 15:03
opewrt mi sta tirando sempre piu'
ma il router ha solo 1 settimana di vita

mi tira transmission sempre sul router :muro:

abarth83
12-05-2014, 16:01
I FILE transmission LI TROVI SU OpenWrt - LuCI
SE VUOI UNA CONFIGURAGIONE MINIMALE INSTALLA:
luci-app-transmission lo configuri e poi lo gestisci con transgui per windows
oppure:
scarica tramite OpenWrt - LuCI i seguenti file:
luci-app-transmission
transmission-cli
transmission-web
e gestisci i file torrentti da weg gui
avete provato la nuova release di rylos?
no non ho avuto tempo confermo per la versione openwrt-lantiq-xrx200-TDW8970-sysupgrade_v40695_EXPERIMENTAL 100%funzionante

ottimo proverò... sarebbe da mettere in cima tra le guide..

abarth83
13-05-2014, 16:09
provato ora Breaker r40746 tutto ok!

è vero nel wifi manca la modalità N ma una volta ripristinate le impostazione (io avevo il file di config wifi) la N ricompare tra le impostazioni.

non cè più il bug del wi-fi che se disabilitato disabilitava anche la WAN...

per ora solo questo.

massimo1995
14-05-2014, 06:24
no non è successo nulla ho caricato l'immagine come sempre ma al riavvio nulla..boot loop e chiaramente non era raggiungibile da telnet interfaccia ecc..
ho dovuto rifleshare da seriale. eccola in foto sistemata con cavo per ventoline
http://i58.tinypic.com/2m7axhf.jpg

eccola in foto sistemata con cavo per ventoline?
forse ho letto male ma hai abbinato sul td-w8970 una ventola per il raffredamento?
se ho capito bene puoi dire come hai fatto e i materiali da acquistare graz

rylos
14-05-2014, 07:10
Intende il connettore esterno per non dover saldare tutte le volte o per non doverlo aprire tutte le volte. Grande abarth, ho fatto anch'io esattamente cosi dopo aver visto la tua foto, molto comodo adesso.

abarth83
14-05-2014, 07:59
Nono non ho montato una ventolina ma ho usato solo i connettori per ventole. .. che poi non serve neppure una vemtolina riscalda ma nn eccessivamente secondo me.

massimo1995
14-05-2014, 08:18
Nono non ho montato una ventolina ma ho usato solo i connettori per ventole. .. che poi non serve neppure una vemtolina riscalda ma nn eccessivamente secondo me.
ok avevo capito male quindi il connettore che vedo e solo x gnd tx rx

abarth83
14-05-2014, 11:42
ok avevo capito male quindi il connettore che vedo e solo x gnd tx rx

si

xamok
15-05-2014, 09:22
Ciao Belli!
Stavo provando, purtroppo solo ora, a fare l'ExtRoot ed ho notato che nella root ci sono un mucchio di file con punti interrogativi, è normale?

Quando do un ls questo è quello che appare


root@OpenWrt:/# ls
O???
bin
dev
etc
lib
mnt
overlay
proc
rom
root
sbin
sys
tmp
usr
var
www
?
?????
???????????
?????b?????????????
?????????
??????????
??
?
???
?Ou??
??????
?{?
??????
??????
?????
?
???
???
???????[1?
?????????
???????????????????????
??
???
???
????
?
??
???????
???
?????????
????
??????????????????
??????
???????????????H?????????????7???????????
??
???????
????????????????????????????????????
?
?
?????
??????????????????
????????????
??
???
???????????????????????????????????????????????????????????????????
??????????????????????
???
???????
?????
???
????
?
?????????
???????
?
??????
root@OpenWrt:/#


Li avete anche voi ?

Dimenticavo, versione 40746, fw adsl l'ultimo postato
Credo che i punti interrogativi ci fossero anche con la precedente 40335, non mi sono ricordato di controllare :stordita:

sunvit
15-05-2014, 10:02
Io non ne ho.

Inviato dal mio GT-I9300 utilizzando Tapatalk

rylos
15-05-2014, 10:15
No non è normale il tuo output. Io ovviamente sono sulla stessa versione è questo è quanto:

root@OpenWrt:~# pwd
/root
root@OpenWrt:~# ls
root@OpenWrt:~# uname -a
Linux OpenWrt 3.10.36 #14 Sat May 10 12:37:06 CEST 2014 mips GNU/Linux
root@OpenWrt:~#

Il tuo output sembra il risultato di un filesystem danneggiato (o flash non corretto). L'hai scritta con la seriale? Hai messo il giusto len HEX nel sf write ?

massimo1995
15-05-2014, 15:01
^_^

xamok
15-05-2014, 15:03
No non è normale il tuo output. Io ovviamente sono sulla stessa versione è questo è quanto:

root@OpenWrt:~# pwd
/root
root@OpenWrt:~# ls
root@OpenWrt:~# uname -a
Linux OpenWrt 3.10.36 #14 Sat May 10 12:37:06 CEST 2014 mips GNU/Linux
root@OpenWrt:~#

Il tuo output sembra il risultato di un filesystem danneggiato (o flash non corretto). L'hai scritta con la seriale? Hai messo il giusto len HEX nel sf write ?

Ho flashato la 40335 con la seriale e l'ho usata stabilmente fino a ieri sera, quando ho aggiornato all'ultima tested . Stamattina ho fatto anche l'extroot, e a quanto pare sembra stabile ( quando ho provato a farlo con una versione precedente alla 40335, mi ricordo che dopo nemmeno un'ora si impallava tutto e dovevo togliere la chiavetta). Anche navigazione, transmission, upnp e wifi con relativo led funzionano; l'unica cosa che non mi tornava erano appunto quei punti interrogativi....
Gli hex li ho copiati pari pari dal primo post per la 40335, e visto che tutto funzionava non ho più toccato niente (anche perchè non ne ho avuto tempo :cry: )

Eseguendo i tuoi comandi, Rylos, mi esce il tuo stesso output,

root@OpenWrt:~# pwd
/root
root@OpenWrt:~# ls
root@OpenWrt:~# uname -a
Linux OpenWrt 3.10.36 #14 Sat May 10 12:37:06 CEST 2014 mips GNU/Linux
root@OpenWrt:~#

ma appena faccio un cd .. seguito da ls mi esce l'output di prima.

massimo1995
15-05-2014, 15:15
xamok hai provato a cambiare chiavetta usb?
questo problema lo hai solo qundo fai extroot?

xamok
15-05-2014, 15:16
xamok hai provato a cambiare chiavetta usb?

Dovrei? Adesso sembra funzionare stabilmente, e i punti li ho notati prima di mettere la chiavetta

massimo1995
15-05-2014, 15:22
Dovrei? Adesso sembra funzionare stabilmente, e i punti li ho notati prima di mettere la chiavetta

quindi problema risolto?:doh:

abarth83
15-05-2014, 15:38
si potrebbe fare una guida più completa per fare l extroot per esempio io stavo seguendo quella in prima pagina ma già inserendo la chiavetta non vedo nessuna partizione sda o sda1 poi ill resto non è chiaro magari elencare solo i comandi da dare in telnet... per i niubbi come me:cry:

rylos
15-05-2014, 15:58
ciao rylos ti devo chiedere di esaminare un problema che non riesco a risolvere che adesso ti spiego graz in anticipo alllllora:

la mia configurazione td-w8970 openwrt
extroot usb che viene vista come prima porta sda1

DOCKING STATION HARD DISK 2,5" 3,5" USB 2.0 SATA nella seconda porta usb con 2 hdd montati Punto di mountFile system montati come
sdb1 188.62 GB
sdc1 da 422.27 GB

il mio problema e che quando monto 2 hdd la mia configurazione sul Punto di Mount File system e questa:

/dev/sdg1 /mnt/sdb1 159.17 GB / 188.62 GB 11% (19.37GB)

/dev/sdf1 /mnt/sdc1 399.71 GB / 422.27 GB 0% (21.30 MB)

ora quello che non riesco a capire xche non rispetta le regole assegnate in fstab?per essere precisi e normale che monta:
/dev/sdf1 /mnt/sdc1

e possibile far montare
/dev/sdc1 /mnt/sdc1


Qualcosa non resetta il bus usb del kernel e quindi crea nuovi nomi sdx...vabeh poco male, un buon modo per non dare fastidio è chiamarli in modo diverso tipo /mnt/200gb e /mnt/500gb poi continui ad usare gli UUID in fstab.

Io non ho questi problemi però, quindi qualcosa è specifico ai tuoi device - pakages. Anch'io uso 2 chiavi usb e sono SEMPRE sdb e sdc (non uso ovviamente HDD-idle).

sunvit
15-05-2014, 16:03
Io ho un pen drive x l'extroot ed un harddisk ed hanno sempre lo stesso nome sda e sdb ed uso pure hdd-iddle ma come versione ho la 569

Inviato dal mio GT-I9300 utilizzando Tapatalk

massimo1995
15-05-2014, 16:07
Qualcosa non resetta il bus usb del kernel e quindi crea nuovi nomi sdx...vabeh poco male, un buon modo per non dare fastidio è chiamarli in modo diverso tipo /mnt/200gb e /mnt/500gb poi continui ad usare gli UUID in fstab.

Io non ho questi problemi però, quindi qualcosa è specifico ai tuoi device - pakages. Anch'io uso 2 chiavi usb e sono SEMPRE sdb e sdc (non uso ovviamente HDD-idle).

quindi provo a settare '/mnt/sda1' in '/mnt/200gb'

e poi mi faccio una bella ricerca su internet 'Qualcosa non resetta il bus usb del kernel ? vediamo che trovo grazie 1000% rylos

massimo1995
15-05-2014, 16:09
Io ho un pen drive x l'extroot ed un harddisk ed hanno sempre lo stesso nome sda e sdb ed uso pure hdd-iddle ma come versione ho la 569

Inviato dal mio GT-I9300 utilizzando Tapatalk

569 cosa? sysupgrade
il mio problema e qundo riavvio mi cambia il dev sdb1 in sdc1 ma questo con comporta il mal funzionamento tutto funge

io ho una usb e 2 hdd

massimo1995
15-05-2014, 16:18
^_^

sunvit
15-05-2014, 17:01
569 cosa? sysupgrade
il mio problema e qundo riavvio mi cambia il dev sdb1 in sdc1 ma questo con comporta il mal funzionamento tutto funge

io ho una usb e 2 hdd

Si certo sysupgrade v40569.

Inviato dal mio GT-I9300 utilizzando Tapatalk

abarth83
15-05-2014, 19:50
ok ho montato la pennetta ora ho un altro problema ho installato transmission ma una volta installato Tran. remote gui lo avvio e mi dice connection refused eppure i dati sono corretti c è poco da settare o devo cambiare qualcosa sotto luci?

massimo1995
16-05-2014, 04:29
^_^

xamok
16-05-2014, 07:58
Come non detto cari!
Questa notte, intorno a mezzanotte, si è impallato tutto. Prima ha perso la portante agganciando dopo 1-2 minuti quella a 8 mega, dopo altri 1-2 minuti ha ripreso la solita 11 mega. Tutto ciò mentre sui dispositivi non era possibile navigare. Riavviando il modem dal tastino dietro non si è più avviato (anche togliendo la penna usb per l'extroot), rimaneva acceso solo il led power e stamattina quando ho attaccato la seriale c'era la cli del bootloader ( c'era scritto VR9, correggetemi se sbaglio). Dopo aver dato invio ho riavviato sempre col tasto, e magicamente tutto è tornato alla normalità. Dopo un po' ho anche rimesso la chiavetta, e proprio come ieri sembra funzionare.
L'unica cosa che era pianificata per quell'ora era il limite di velocità di transmission, ma non avevo ancora caricato nessun torrent.

Metto anche il boot, il log del kernel e del sistema ( gli ultimi due così come me li da LUci)

Bootlog (http://pastebin.com/5nPJ0Lpr)
Kernel Log (http://pastebin.com/Ai4Q0rb4)
Syslog (http://pastebin.com/UiAtbdbD)

Au Revoir!

abarth83
16-05-2014, 08:44
devo cambiare qualcosa sotto luci?
CERTO CHE SI
QUINDI devi aggiungere sale pepe e un pizzico di zucchero hihihihi ^_^
scherzo
alllllora in OpenWrt - LuCI >sistema> avvio>abilita transmission
poi dopo averlo abilitato premi inizio e accertati di averlo caricato in:
OpenWrt - LuCI >stato>processi
apri Transmission Remote GUI e funge

ok non era abilitato ora ultimo problemino...
all avvio della gui sempre... sembra che si connetta poi mi dice:
404: Not found /transmission/

danytrevy
16-05-2014, 08:47
salve a tutti, ho appena flashato il mio router, dopo neanche 1 settimana di vita, ho seguito la guida del 1° post, ed ho montato l'ultimo FW disponibile:

openwrt-lantiq-xrx200-TDW8970-sysupgrade_v40746_TESTED.image
+
dsl_vr9_firmware_xdsl-05.04.08.00.00.06_05.04.04.04.00.01.bin

è andato tutto liscio, poi ho esteso la ROOTFS su una chiavina usb da 8gb, non senza qualche problema inziale poichè la partizione non veniva formattata in extfs4 poi ho risolto.
il router è un poco lento a partire, con il firmware originale sembrava + reattivo, ma poco male, da quello che vedo ne vale davvero la pena!
ho configurato la Wifi (anche a me non viene restituita l'opzione l'opzione n, ma solo a/b/g) ma poco male, il mio problema è che non funziona la dsl:

ho configurato la wan come dovrebbe essere per tiscali

https://www.dropbox.com/s/htigcdkydyhvdss/Screenshot%202014-05-16%2007.44.35.png
https://www.dropbox.com/s/jbc4nndbgfur6o2/Screenshot%202014-05-16%2007.45.15.png

(stessi parametri messi a router originale e funzionanti)

ierisera la portante dsl veniva agganciata, e la connessione sembrava funzionare, almeno così diceva dalla finestra di riepilogo iniziale, salvo poi non farmi navigare con il computer, poi ho spento.
stamani volevo riprovare e dalla finestra di riepilogo iniziale mi dice che non è partito il demone!
soluzione ad entrambi i problemi?



domanda da niubbo:
se resetto il router, devo reimpostare l'estensione della rottfs sulla usb semplicemente aggiungendo questi parametri al file /etc/config/fstab ?


config mount
option target /overlay
option device /dev/sda1
option fstype ext4
option options rw,sync
option enabled 1
option enabled_fsck 0

oppure devo rieseguire anche

- inserisci la chiavetta nella porta1
- dovresti trovarla in /dev/sda e la sua partizione in /dev/sda1
- per sicurezza io ho lanciato fdisk /dev/sda eliminato con d la partizione e con n ne ho creata un'altra nuova. Salvato con w.
- mkfs.ext4 /dev/sda1 -m 0
- mkdir /mnt/sda1
- mount /dev/sda1 /mnt/sda1 (questo serve solo ora per copiare i files col passo successivo)
- tar -C /overlay -cvf - . | tar -C /mnt/sda1 -xf - (copia i files nella USB)
- vi /etc/config/fstab
- aggiungi alle righe esistenti quelle di seguito (a per scrivere poi quando finisci ESC : wq se non sei esperto)


p.s. non sono un esperto di linux, ma ci voglio provare ugualmente, quindi nel caso moderate i termini tecnici :D:D:D:D:D

xamok
16-05-2014, 08:58
ok non era abilitato ora ultimo problemino...
all avvio della gui sempre... sembra che si connetta poi mi dice:
404: Not found /transmission/

Faceva così anche a me, poi ho visto che c'è da mettere anche la porta dopo l'indirizzo, quindi 192.168.1.1:9091 nel mio caso, mi manda poi lui nella cartella transmission.


salve a tutti, ho appena flashato il mio router, dopo neanche 1 settimana di vita, ho seguito la guida del 1° post, ed ho montato l'ultimo FW disponibile:

openwrt-lantiq-xrx200-TDW8970-sysupgrade_v40746_TESTED.image
+
dsl_vr9_firmware_xdsl-05.04.08.00.00.06_05.04.04.04.00.01.bin

è andato tutto liscio, poi ho esteso la ROOTFS su una chiavina usb da 8gb, non senza qualche problema inziale poichè la partizione non veniva formattata in extfs4 poi ho risolto.
il router è un poco lento a partire, con il firmware originale sembrava + reattivo, ma poco male, da quello che vedo ne vale davvero la pena!
ho configurato la Wifi (anche a me non viene restituita l'opzione l'opzione n, ma solo a/b/g) ma poco male, il mio problema è che non funziona la dsl:

ho configurato la wan come dovrebbe essere per tiscali

https://www.dropbox.com/s/htigcdkydyhvdss/Screenshot%202014-05-16%2007.44.35.png
https://www.dropbox.com/s/jbc4nndbgfur6o2/Screenshot%202014-05-16%2007.45.15.png

(stessi parametri messi a router originale e funzionanti)

ieri sera la portante dsl veniva agganciata, e la connessione sembrava funzionare, almeno così diceva dalla finestra di riepilogo iniziale, salvo poi non farmi navigare con il computer, poi ho spento.
stamani volevo riprovare e dalla finestra di riepilogo iniziale mi dice che non è partito il demone!
soluzione ad entrambi i problemi?



-- cut --

Per la parte dsl ha fatto lo stesso scherzo anche a me, hai modificato il file
/etc/config/network nell'ultima parte (quella che comincia con config vdsl)
in modo che sia simile a questo?


config vdsl 'dsl'
option annex 'a'
option firmware '/lib/firmware/vdsl.bin'
option tone 'av'
option xfer_mode 'atm'


Per la usb non so come aiutarti mi spiace :(

abarth83
16-05-2014, 09:13
Faceva così anche a me, poi ho visto che c'è da mettere anche la porta dopo l'indirizzo, quindi 192.168.1.1:9091 nel mio caso, mi manda poi lui nella cartella transmission.
:(
ma lato gui?
l ho fatto e mi dice winsock error 10109
non sono sicuro dove sia installato transmission..
edit:
ok dovevo mettere la cartella dove era installato tutto apposto grazie..

massimo1995
16-05-2014, 09:20
[QUOTE=abarth83;41098322]ok non era abilitato ora ultimo problemino...
all avvio della gui sempre... sembra che si connetta poi mi dice:
404: Not found /transmission/[/QUOTE
prova cosi:

risolto

massimo1995
16-05-2014, 09:29
salve a tutti, ho appena flashato il mio router, dopo neanche 1 settimana di vita, ho seguito la guida del 1° post, ed ho montato l'ultimo FW disponibile:

openwrt-lantiq-xrx200-TDW8970-sysupgrade_v40746_TESTED.image
+
dsl_vr9_firmware_xdsl-05.04.08.00.00.06_05.04.04.04.00.01.bin

è andato tutto liscio, poi ho esteso la ROOTFS su una chiavina usb da 8gb, non senza qualche problema inziale poichè la partizione non veniva formattata in extfs4 poi ho risolto.
il router è un poco lento a partire, con il firmware originale sembrava + reattivo, ma poco male, da quello che vedo ne vale davvero la pena!
ho configurato la Wifi (anche a me non viene restituita l'opzione l'opzione n, ma solo a/b/g) ma poco male, il mio problema è che non funziona la dsl:

ho configurato la wan come dovrebbe essere per tiscali

https://www.dropbox.com/s/htigcdkydyhvdss/Screenshot%202014-05-16%2007.44.35.png
https://www.dropbox.com/s/jbc4nndbgfur6o2/Screenshot%202014-05-16%2007.45.15.png

(stessi parametri messi a router originale e funzionanti)

ierisera la portante dsl veniva agganciata, e la connessione sembrava funzionare, almeno così diceva dalla finestra di riepilogo iniziale, salvo poi non farmi navigare con il computer, poi ho spento.
stamani volevo riprovare e dalla finestra di riepilogo iniziale mi dice che non è partito il demone!
soluzione ad entrambi i problemi?



domanda da niubbo:
se resetto il router, devo reimpostare l'estensione della rottfs sulla usb semplicemente aggiungendo questi parametri al file /etc/config/fstab ?


config mount
option target /overlay
option device /dev/sda1
option fstype ext4
option options rw,sync
option enabled 1
option enabled_fsck 0

oppure devo rieseguire anche

- inserisci la chiavetta nella porta1
- dovresti trovarla in /dev/sda e la sua partizione in /dev/sda1
- per sicurezza io ho lanciato fdisk /dev/sda eliminato con d la partizione e con n ne ho creata un'altra nuova. Salvato con w.
- mkfs.ext4 /dev/sda1 -m 0
- mkdir /mnt/sda1
- mount /dev/sda1 /mnt/sda1 (questo serve solo ora per copiare i files col passo successivo)
- tar -C /overlay -cvf - . | tar -C /mnt/sda1 -xf - (copia i files nella USB)
- vi /etc/config/fstab
- aggiungi alle righe esistenti quelle di seguito (a per scrivere poi quando finisci ESC : wq se non sei esperto)


p.s. non sono un esperto di linux, ma ci voglio provare ugualmente, quindi nel caso moderate i termini tecnici :D:D:D:D:D

cioa danytrevy io quando resetto rimuovo la chiavetta usb riavvio e poi resetto e chiaro che quando resetti ti riporta il sistema di default quindi devi rifare tutto daccapo

massimo1995
16-05-2014, 09:57
^_^

danytrevy
16-05-2014, 10:17
Per la parte dsl ha fatto lo stesso scherzo anche a me, hai modificato il file
/etc/config/network nell'ultima parte (quella che comincia con config vdsl)
in modo che sia simile a questo?


config vdsl 'dsl'
option annex 'a'
option firmware '/lib/firmware/vdsl.bin'
option tone 'av'
option xfer_mode 'atm'


Per la usb non so come aiutarti mi spiace :(

assolutamente no, io ho configurato solo tramite la webinterface.

come inserisco quei parametri, sempre con il comando vi ?
purtroppo potrò metterci nuovamente le mani solo domani mattina, quindi ci risentiamo domani sperando di risolvere, nel frattempo grazie a tutti.

abarth83
16-05-2014, 11:28
io ho un problema con extroot secondo me:
cm posso visualizzare i file della pennetta da 16Gb che ho installato?
con Winscp dovrei vederla sotto overlay ma nulla se copio i file nella cartella mi occupa la memoria del router...
sotto dev/ non cè una cartella sda o sda1 ma solo i file corrispondenti alla partizione..
se creo una cartella dal nome sda1 o sda sotto dev. mi dice che già esiste... cm cacchio vedo se ho fatto bene questo extroot cioè da dove vedo se è fatto carrettamente?
con df -h
le dimensioni della root è uguale a prima

ma se vado sotto luci- punto di mount mi da :
/dev/sda1 (15524 MB) /overlay ext4 rw,sync

massimo1995
16-05-2014, 12:01
io ho un problema con extroot secondo me:
cm posso visualizzare i file della pennetta da 16Gb che ho installato?
con Winscp dovrei vederla sotto overlay ma nulla se copio i file nella cartella mi occupa la memoria del router...
sotto dev/ non cè una cartella sda o sda1 ma solo i file corrispondenti alla partizione..
se creo una cartella dal nome sda1 o sda sotto dev. mi dice che già esiste... cm cacchio vedo se ho fatto bene questo extroot cioè da dove vedo se è fatto carrettamente?
con df -h
le dimensioni della root è uguale a prima

ma se vado sotto luci- punto di mount mi da :
/dev/sda1 (15524 MB) /overlay ext4 rw,sync
se ti occupa la memoria del router vuol dire che non e partito xtroot da usb vai in SISTEMA>Software>Spazio libero: 100% (4.95 GB) QUESTO E IL MIO GUARDA IL TUO

abarth83
16-05-2014, 12:02
guarda in mnt/sda1

e ma mi copia i file nel rooter invece che nella penna..
infatti mi dice come spazio libero 17% tipo quindi non è partito...

massimo1995
16-05-2014, 12:11
e ma mi copia i file nel rooter invece che nella penna..
infatti mi dice come spazio libero 17% tipo quindi non è partito...
QUINDI NON TI E PARTITO EXTROOT?
HAI RIAVVITAO DOPO LA PROCEDURA?
HAI CONFIGURATO FSTAB?

abarth83
16-05-2014, 12:27
QUINDI NON TI E PARTITO EXTROOT?
HAI RIAVVITAO DOPO LA PROCEDURA?
HAI CONFIGURATO FSTAB?

si modificato fstab riavviato fatto tutto..
poi il bello che la partizione me la crea sda1 tutto regolare ma non mi fa l extroot provato sia con i comandi che mi hai dato te che quelli in prima pagina potrei provare a cambiare pennetta ma nn credo sia quello il motivo che dici?:muro:

massimo1995
16-05-2014, 12:52
^_^

abarth83
16-05-2014, 13:09
IO USO UNA USB Kingston FAI COSI :
APRI PUTTY E DAI:
fdisk -l
USB MONTATA TI DODVREBBE SPUNTARE ALLA FINE SDA1
POI DAI:
block info
E GUARDA SEMPRE ALLA FINE
POI GUARDA SE LA MONTA sistema>Configurazione LED
se non la monta non saprei

o non la vedo con i tuo comandi ma andando sotto led cosa che non avevo fatto mai.. vedo sotto led2 Sandisck cruzer (la mia pennetta) ma sta sotto USB2 mentre io l ho inserito in usb 1 che è la presa usb vicino al cavo telefonico... te dove ce l hai la tua pennetta?

rylos
16-05-2014, 13:49
L'extroot non "si lega" al firmware se era stata creata da un firmware precedente....e quindi non si monta in /overlay qualsiasi cosa tu faccia, a parte un bel mkfs.ext4 nuovo.....è una cosa che non ho ben compreso nemmeno io.

abarth83
16-05-2014, 14:51
L'extroot non "si lega" al firmware se era stata creata da un firmware precedente....e quindi non si monta in /overlay qualsiasi cosa tu faccia, a parte un bel mkfs.ext4 nuovo.....è una cosa che non ho ben compreso nemmeno io.

Ma per cancellare tutto e ricominciare tutto da capo e ripulire il modem basta solo resettare da luci o devo riflashare tramite seriale?

rylos
16-05-2014, 15:08
Per partire da 0 basta resettare luci e formattare la penna usb per uno nuovo extroot.

nebbia88
16-05-2014, 18:40
L'extroot non "si lega" al firmware se era stata creata da un firmware precedente....e quindi non si monta in /overlay qualsiasi cosa tu faccia, a parte un bel mkfs.ext4 nuovo.....è una cosa che non ho ben compreso nemmeno io.

in realtà credo basti sistemare l' md5:

http://wiki.openwrt.org/doc/howto/extroot#recommended.by.extroot.maintainer

pero' in caso di pivot root meglio ricopiare tutto da flash a partizione extroot, non mi sembra bello trovarsi con il rootfs del firmware vecchio -.-

abarth83
16-05-2014, 21:02
extroot fatto ma per qualche motivo non mi andava poi ho cambiato pennette ne ho messa una da 8gb e nella usb2 del modem che però luci sez LED vede come usb1 e al riavvio 8gb cacchio a forza di batterci la testa..:muro:

NightSky256
16-05-2014, 23:57
Ciao a tutti,
Premetto che é la mia prima installazione openwrt anche se ho una certa esperienza su sistemi Linux perciò siate pure tecnici....

Ho caricato l'ultimo firmware qui linkato. E il firmware ADSL.

Risultato: ADSL: up. Ma Wan down.

Ho cambiato vpi e vci, user e password (aliceadsl) ma nulla...

Cosa ho sbagliato?

Nel log vedo: timeout waiting for PADO packets

Dimenticavo... file network settato come suggerito... ma nulla da fare

Inviato dal mio Nexus 7 utilizzando Tapatalk

massimo1995
17-05-2014, 07:27
extroot fatto ma per qualche motivo non mi andava poi ho cambiato pennette ne ho messa una da 8gb e nella usb2 del modem che però luci sez LED vede come usb1 e al riavvio 8gb cacchio a forza di batterci la testa..:muro:
mah secondo me non e normale che monta la usb nella usb2 che però luci sez LED vede come usb1
io lo collegata nella prima porta cioe vicino all cavo la vede come sda1 e certo avevi voglia di fare e rifare extrooot a vuoto MAGARI NELLA PROSSIMA sysupgrade SI RISOLVE

sunvit
17-05-2014, 07:48
Sei riuscito con pyload a far andare gli account premium?

Inviato dal mio GT-I9300 utilizzando Tapatalk

massimo1995
17-05-2014, 09:10
Sei riuscito con pyload a far andare gli account premium?

Inviato dal mio GT-I9300 utilizzando Tapatalk

ciao sunvit se questa domanda e rivolta a me io ti dico subito che non ho installato pyload per il momento

massimo1995
17-05-2014, 09:24
^_^

abarth83
17-05-2014, 09:55
mah secondo me non e normale che monta la usb nella usb2 che però luci sez LED vede come usb1
io lo collegata nella prima porta cioe vicino all cavo la vede come sda1 e certo avevi voglia di fare e rifare extrooot a vuoto MAGARI NELLA PROSSIMA sysupgrade SI RISOLVE

si non è normale cmq volevo provare di nuovo la pennetta da 16GB ma aspetto una nuova build a questo punto visto che sto anche gia scaricando con transmission grandissimo:) ...
ora per mettere la ciliegina sulla torta ci manca una guidarellla per installare pyload e poi sto apposto così non lo aggiorno neanche più lo tengo così fino che muore.:D :D

massimo1995
17-05-2014, 10:16
^_^

abarth83
17-05-2014, 10:30
ciao abarth83 io non penso proprio di installare pyload perché non piace lo utilizzato sull nslu2 e il gioco non vale la candela secondo me ma chi puo dirlo?
cmq non so se conosci PoWeR-Script.iNFo e mirc per win7
ora da poco ho finito di configurare OpenWRT - Proftp Server e adesso mi dedico all'equivalente spero di PoWeR-Script.iNFo cioe psybnc .
se quncuno a già installato psybnc posti una guida x favore ciao raga

sunvit ha installato pyload ma alquanto pare ha dei probl account premium quindi magari se lui e disponibile la puo fare lui la guida senza account premium
no non lo conosco se è per questo nn conoscevo neanche transmission o pylod.. per anni ho usato jdownloader e utorrent Stop. gli orizzonti si allargano con questo tplink..:doh:

NightSky256
17-05-2014, 10:58
Sono riuscito a fare qualcosa ma credo che questo firmware abbia qualche configurazione diversa...
Ho provato un image francese e una da un forum polacco ed entrambe mi fanno connettere a Telecom in pppoe.

Mentre questo (del quale mi fido molto di piu) non c'è verso di connetterlo in pppoe.

Riesco solo ad andare in pppoa ma non apre poi nulla che non sia https (normale con la mia linea Telecom in pppoa fa cosi anche su altri router)

Ho provato anche a fare la desume della etc esportata dai due firmware che vanno ma senza successo... ripristina tutto ma poi non connette la Wan....

Suggerimenti?

Per ora sono col fw francese :(

Inviato dal mio Nexus 7 utilizzando Tapatalk

danytrevy
17-05-2014, 13:52
allora, per sicurezza ho tolto la usb, ho resettato il router ed ho riniziato ad impostare la connessione adsl inserendo
pppoa
nome utente
vpi
vci
mtu
etc etc

ancora non funzionava fino a che non ho modificato quel parametro nel file /etc/config/network
da ptm ad atm

adesso come vedete il modem si connette

https://www.dropbox.com/s/vvy1joi3umo18lt/Screenshot%202014-05-17%2014.45.59.png

ed "esce"

https://www.dropbox.com/s/vm1xfl4aygah71r/Screenshot%202014-05-17%2014.46.19.png

ma di far navigare i dispositivi ad esso connessi proprio non ne vuol sapere!

sapete aiutarmi?
devo effetturare un bridge tra le interfacce?
Se si, come?

nebbia88
17-05-2014, 15:29
posta le config network e firewall altrimenti è un po' difficile capire dove sta l'inghippo...


Ho provato un image francese e una da un forum polacco ed entrambe mi fanno connettere a Telecom in pppoe.

Mentre questo (del quale mi fido molto di piu) non c'è verso di connetterlo in pppoe.


io non ti sapro' aiutare ma di solito se riporti il link dei vari fw di cui parli è meglio :D

provato altre vers. di rylos?

strassada
17-05-2014, 16:11
http://dl.eko.one.pl/trunk/lantiq/
http://chiliproject.tetaneutral.net/projects/tetaneutral/wiki/TD-W8970 http://h2.tetaneutral.net/lantiq/

danytrevy
17-05-2014, 16:34
posta le config network e firewall altrimenti è un po' difficile capire dove sta l'inghippo...


Grazie della disponibilità, e scusate la niubbaggine


questo il firewall configuration


config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'

config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config include 'miniupnpd'
option type 'script'
option path '/usr/share/miniupnpd/firewall.include'
option family 'IPv4'
option reload '1'

e questa la network configuration


config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fda7:0610:30a8::/48'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option macaddr 'e8:94:f6:5e:3a:4a'

config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'

config interface 'wan'
option _orig_ifname 'nas0'
option _orig_bridge 'false'
option proto 'pppoa'
option encaps 'vc'
option atmdev '0'
option vci '35'
option vpi '8'
option username 'XXXXXXXXXXXXXXXXXX'
option password 'XXXXX'
option mtu '1492'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config vdsl 'dsl'
option annex 'a'
option firmware '/lib/firmware/vdsl.bin'
option tone 'av'
option xfer_mode 'atm'

xamok
17-05-2014, 18:59
Grazie della disponibilità, e scusate la niubbaggine


-- cut --

e questa la network configuration


-- cut --

config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'

config interface 'wan'
option _orig_ifname 'nas0'
option _orig_bridge 'false'
option proto 'pppoa'
option encaps 'vc'
option atmdev '0'
option vci '35'
option vpi '8'
option username 'XXXXXXXXXXXXXXXXXX'
option password 'XXXXX'
option mtu '1492'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config vdsl 'dsl'
option annex 'a'
option firmware '/lib/firmware/vdsl.bin'
option tone 'av'
option xfer_mode 'atm'

Domanda magari scontata, hai provato a cambiare nel file /etc/config/network
questo
config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'

in questo?
config atm-bridge 'atm'
option vpi '8'
option vci '35'
option encaps 'vc'
option payload 'bridged'

Io nel mio file ho gli stessi valori in entrambe le sezioni, magari è quello che va cambiato, magari ho detto una boiata, non lo so !

danytrevy
17-05-2014, 19:30
Domanda magari scontata, hai provato a cambiare nel file /etc/config/network
questo
config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'

in questo?
config atm-bridge 'atm'
option vpi '8'
option vci '35'
option encaps 'vc'
option payload 'bridged'

Io nel mio file ho gli stessi valori in entrambe le sezioni, magari è quello che va cambiato, magari ho detto una boiata, non lo so !

avevo provato da interfaccia web, senza risultati.
comunque riprovo

aggiornamneto: niente da fare, anche cambiando quelle impostazioni non navigo con il pc

abarth83
18-05-2014, 08:35
ciao abarth83 io non penso proprio di installare pyload perché non piace lo utilizzato sull nslu2 e il gioco non vale la candela secondo me ma chi puo dirlo?
cmq non so se conosci PoWeR-Script.iNFo e mirc per win7
ora da poco ho finito di configurare OpenWRT - Proftp Server e adesso mi dedico all'equivalente spero di PoWeR-Script.iNFo cioe psybnc .
se quncuno a già installato psybnc posti una guida x favore ciao raga

sunvit ha installato pyload ma alquanto pare ha dei probl account premium quindi magari se lui e disponibile la puo fare lui la guida senza account premium
che poi dimme se sbaglio ma payload senza un account premium serve a poco.. meglio jdownloader..

massimo1995
18-05-2014, 08:40
che poi dimme se sbaglio ma payload senza un account premium serve a poco.. meglio jdownloader..

no sbagli ma secondo me serve anche un account premium quindi chi ha i soldini da buttare meglio torrent sul td-w8970 a sto punto freee o PoWeR-Script.iNFo per i file

NightSky256
18-05-2014, 10:29
Ho risolto... non so come ma mancava la sezione dsl nel file network e con i fw polacco e francese funzionava lo stesso.... ora va tutto anche con questo! Fantastico...

Inviato dal mio Nexus 7 utilizzando Tapatalk

abarth83
18-05-2014, 12:12
no sbagli ma secondo me serve anche un account premium quindi chi ha i soldini da buttare meglio torrent sul td-w8970 a sto punto freee o PoWeR-Script.iNFo per i file

si ho letto ma devo approfondire questo pewer script.info devo documentarmi meglio sulle pontenzialità

danytrevy
18-05-2014, 16:19
Io mi stò ancora "picchiando" con la conenssione internet:
il router esce, ma i dispositivi connessi alla lan no, intanto ho montato extfsroot, ed approfittando della connesione ho installato transmission e l'ho configurato, mi sono collegato tramite interfaccia web etc etc..
Però ho notato un problema, non sempre extfsroot viene applicato:
prima davo la colpa alla penna usb (un adattatore cinese per microsd)
ma poi ho usato un ssd che oltre alla porta sata ha anche la usb e che non ha mai dato problemi, ed al primo avvio di oggi extfsroot non era stato applicato, allora ho dato un soft reset ed è ripartito, la root è tornata ad essere di 500MB, ma non sempre ad ogni riavvio la cosa accade, lo stò verificando ora.

ma il mio problema maggiore è la connessione internet...:rolleyes: :rolleyes: :rolleyes:
questi i settaggi del firewall
https://www.dropbox.com/s/rj51jhrfu5csltk/Screenshot%202014-05-18%2016.53.21.png
https://www.dropbox.com/s/l0mfir6p76603te/Screenshot%202014-05-18%2016.53.54.png

danytrevy
18-05-2014, 16:36
ho risolto:
la mia scheda di rete del pc era configurata manualmente come
192.168.1.100
255.255.255.0
per flashare il fw openwrt

ed aveva anche impostatato il set mauale dei dns ma i campi erano vuoti.
adesso ho impostato tutto su automatico e vi stò scrivendo dal pc collegato al tp link! :D :D :D

è possibile che questa config del pc potesse "impallare" il router e bloccare la connessione internet ogni altro dispositivo????

abarth83
18-05-2014, 16:40
ho risolto:
la mia scheda di rete del pc era configurata manualmente come
192.168.1.100
255.255.255.0
per flashare il fw openwrt

ed aveva anche impostatato il set mauale dei dns ma i campi erano vuoti.
adesso ho impostato tutto su automatico e vi stò scrivendo dal pc collegato al tp link! :D :D :D

è possibile che questa config del pc potesse "impallare" il router e bloccare la connessione internet ogni altro dispositivo????
certo che si

blackhole00
18-05-2014, 18:54
Qualcuno di voi potrebbe indicare l'ultimo openwrt stabile e funzionante (assieme ai driver adsl/vdsl)?

Oppure elencare pregi e difetti delle varie versioni, nonchè allegare i file di configurazione di OpenWrt (anche senza extroot)?

Rispetto ai firmware originali Tp-Link come vi sembrano le prestazioni in termini di:
1) Stabilità adsl e aggancio portante
2) Ping
3) Throughput di rete (sia via cavo che wifi)
4) Copertura wireless

Grazie in anticipo ;)

nebbia88
18-05-2014, 19:11
è possibile che questa config del pc potesse "impallare" il router e bloccare la connessione internet ogni altro dispositivo????

direi di no! semplicemente al pc mancava il gateway quindi non usciva.. ma agli altri dispositivi non cambia nulla!

danytrevy
18-05-2014, 20:20
direi di no! semplicemente al pc mancava il gateway quindi non usciva.. ma agli altri dispositivi non cambia nulla!

è quello che penso anche io, ma evidentemente il router andava in palla, perchè con il tablet agganciato alla wi fi non navigava finchè non ho sbloccato il pc!
boh mistero....