Torna indietro   Hardware Upgrade Forum > Software > Linux, Unix, OS alternativi

Apple Watch 7 e Fitness+: connubio perfetto per la palestra in casa. La recensione
Apple Watch 7 e Fitness+: connubio perfetto per la palestra in casa. La recensione
Abbiamo provato Apple Watch serie 7 e Fitness+ insieme per capire se è possibile ricreare una palestra in casa per allenarsi. Da una parte c’è un sistema di lezioni completamente nuovo sul panorama mondiale. Dall’altra uno smartwatch che ha un’esperienza pluriennale in seno al fitness. Vi raccontiamo com'è andata la prova. 
Fujinon XF33mmF1.4R LM WR, standard di nuova generazione per il sistema Fujifilm X
Fujinon XF33mmF1.4R LM WR, standard di nuova generazione per il sistema Fujifilm X
Il nuovo standard "next-gen" Fujifilm si affianca allo storico 35mm, offrendo maggior risoluzione a tutta apertura, tropicalizzazione, maggior velocità e silenziosità nella messa a fuoco, a fronte di ingombri più elevati e prezzo di listino che sfiora gli 850 Euro.
Intel Core i9-12900K, prestazioni con Windows 11 e Windows 10 a confronto
Intel Core i9-12900K, prestazioni con Windows 11 e Windows 10 a confronto
Intel e Microsoft hanno lavorato gomito a gomito per far sì che le nuove CPU Alder Lake basate su architettura ibrida funzionino al meglio su Windows 11. Cosa succede se installiamo Windows 10? Abbiamo svolto di nuovo la nostra suite di test sul 12900K per vedere se le prestazioni cambiano in base al sistema operativo.
Tutti gli articoli Tutte le news

Vai al Forum
Rispondi
 
Strumenti
Old 13-08-2021, 20:04   #1
Opteranium
Senior Member
 
Iscritto dal: Feb 2004
Messaggi: 4135
firefox e CNS

salve, ho linux mint 20.2 e sto provando a far funzionare la tessera sanitaria.

Ho scaricato il driver da qui https://sistemats1.sanita.finanze.it...dalita-accesso, selezionando questo libbit4xpki-idemia-amd64.1.4.10-622.deb perché la carta è vecchia

Ho installato il pacchetto assieme agli altri richiesti.

Quindi sono andato in dispositivi di sicurezza su firefox e creato un nuovo dispositivo, mettendo come file /usr/lib/bit4id/libbit4xpki.so

Provo ad accedere e succede questo: mi chiede il pin, però non appare la finestra di conferma del certificato e quindi in pratica non accedo.

Su un altro pc configurato diversi mesi fa, con un file diverso scaricato da quel sito ma che ora non c'è più, funziona tutto. Il file per il dispositivo è libasep11.so, ma non saprei da dove rimediarlo

Chi ne sa qualcosa? Grazie
Opteranium è offline   Rispondi citando il messaggio o parte di esso
Old 14-08-2021, 17:23   #2
sacarde
Senior Member
 
Iscritto dal: Apr 2004
Messaggi: 9427
di che regione?

https://wiki.ubuntu-it.org/Hardware/...sseraSanitaria




p.s.
io dalla toscana ho il file: libaseCnsP11.so


p.s.
https://wiki.golem.linux.it/Carta_Na...Firma_Digitale

Ultima modifica di sacarde : 14-08-2021 alle 17:29.
sacarde è offline   Rispondi citando il messaggio o parte di esso
Old 15-08-2021, 10:44   #3
Opteranium
Senior Member
 
Iscritto dal: Feb 2004
Messaggi: 4135
grazie per la risposta. Alla fine ho trovato questo sito https://tscns.regione.sardegna.it/it/articoli/linux

e installato quel pacchetto, che ha scaricato una montagna di roba, fra cui anche la mitica libasep11.so
Opteranium è offline   Rispondi citando il messaggio o parte di esso
Old 15-08-2021, 12:15   #4
Perseverance
Senior Member
 
L'Avatar di Perseverance
 
Iscritto dal: Jul 2008
Messaggi: 7179
Butta via tutto quello che hai installato, linux include già il software opensource necessario. Segui questa guida: https://www.rigacci.org/wiki/doku.ph...sera_sanitaria

In riepilogo, pacchetti da installare:
sudo apt-get install pcscd libpcsclite1 pcsc-tools libccid libnss3-tools opensc-pkcs11

Poi in firefox aggiungi all'elenco dei dispositivi di sicurezza dandogli un nome a piacere questo:
/usr/lib/x86_64-linux-gnu/pkcs11/opensc-pkcs11.so

-edit-
Dopodiché devi solo riavviare firefox. Sappi che il portale del fascicolo sanitario elettronico di molte regioni è implementato male ed a volte lascia cookie o memorizza "tracce" e spesso cambiando carta rientri nell'account precedente, mi pare ci siano degli errori nella gestione dei cookie che scadono solo alla chiusura del browser, perciò dovrai chiudere e riaprire il browser, a volte cancellare la cache dell'ultim'ora o scheda anonima. Mica si può pretendere che funzioni a dovere dopo aver speso quasi 150 milioni di euro per metterlo sù
__________________
System Failure

Ultima modifica di Perseverance : 15-08-2021 alle 12:20.
Perseverance è online   Rispondi citando il messaggio o parte di esso
Old 15-08-2021, 18:22   #5
Opteranium
Senior Member
 
Iscritto dal: Feb 2004
Messaggi: 4135
Quote:
Originariamente inviato da Perseverance Guarda i messaggi
Butta via tutto quello che hai installato, linux include già il software opensource necessario. Segui questa guida: https://www.rigacci.org/wiki/doku.ph...sera_sanitaria

In riepilogo, pacchetti da installare:
sudo apt-get install pcscd libpcsclite1 pcsc-tools libccid libnss3-tools opensc-pkcs11

Poi in firefox aggiungi all'elenco dei dispositivi di sicurezza dandogli un nome a piacere questo:
/usr/lib/x86_64-linux-gnu/pkcs11/opensc-pkcs11.so
Mah, guarda avevo già provato in quel modo, selezionando proprio quel file, però non mi riconosceva nemmeno il lettore. Cioè neanche il pin mi arrivava a chiedere, banalmente la pagina di accesso restituiva un errore tipo cns assente.

Forse ho sbagliato qualcosa, magari riprovo, ma non vorrei sciupare tutto ora che funziona
Opteranium è offline   Rispondi citando il messaggio o parte di esso
Old 15-08-2021, 23:45   #6
Perseverance
Senior Member
 
L'Avatar di Perseverance
 
Iscritto dal: Jul 2008
Messaggi: 7179
Ok, io invece ebbi il problema inverso. Non sapevo ancora nulla che linux avesse già tutto il necessario come scritto prima, perciò scaricai il driver proprietario che davano a quel tempo per la vecchia actalis 2014 che funzionò su firefox fino ad una certa versione dopodiché venne messo un blocco al loading di quel modulo proprietario ".so", di cui ora mi sfugge il nome, xkè ritenuto insicuro e prono a problemi di sicurezza vari e documentati. A quel punto dopo qualche giorno scoprì quella guida e che non era necessario alcun software proprietario.

Il mio lettore è un banalissimo bit4id minilector da cinque euro riconosciuto senza installare nulla.
__________________
System Failure
Perseverance è online   Rispondi citando il messaggio o parte di esso
Old 07-10-2021, 13:43   #7
antcos
Senior Member
 
Iscritto dal: Jul 2010
Messaggi: 872
Qualcuno con linux ha la tessera ST 2021 e riesce a farla funzionare? Perchè con Open SC non va, per i driver ci vuole java...
__________________
utenti affidabili con cui ho trattato :
Quote:
biase,Amd4ever,matchless,gattobestiale,krocca,djfolle27,semmy83,oldfield,BarBagiaMan,Peach1200,X3n0
antcos è offline   Rispondi citando il messaggio o parte di esso
Old 07-10-2021, 14:43   #8
Perseverance
Senior Member
 
L'Avatar di Perseverance
 
Iscritto dal: Jul 2008
Messaggi: 7179
Se usi un lettore Bit4ID và eventualmente aggiornato il firmware del dispositivo (se l'hanno rilasciato) xkè in alcuni lettori era presente un bug che impediva alle nuove tessere di funzionare richiedendo di attendere la digitazione del PIN sul tastierino del lettore, tastierino di cui il lettore non è dotato ma che nel firmware è stato abilitato, ed è questo che blocca e manda in panico tutto.

Il fix temporaneo ruota attorno al software opensc, se lo usi e forzi dalla configurazione (opensc.conf) il parametro enable_pinpad = false; poi ti funziona quella nuova, ma puodarsi che smettono di funzionare le altre vecchie.

Bit4ID è stata informata del problema del bug ed ha risposto che rilascerà un firmware nuovo per tutti i lettori coinvolti. Se usi un'altra marca non saprei aiutarti. Il problema si può verificare anche su windows e macos.
__________________
System Failure

Ultima modifica di Perseverance : 07-10-2021 alle 14:54.
Perseverance è online   Rispondi citando il messaggio o parte di esso
Old 28-10-2021, 09:19   #9
sacarde
Senior Member
 
Iscritto dal: Apr 2004
Messaggi: 9427
ma vi e' riuscito a installare i driver per il chip "ST 2021"? (presente sulla tessera nuova)

dal file "SafeDive2020.zip"


https://sistemats1.sanita.finanze.it...dalita-accesso

Ultima modifica di sacarde : 28-10-2021 alle 09:23.
sacarde è offline   Rispondi citando il messaggio o parte di esso
Old 28-10-2021, 09:35   #10
antcos
Senior Member
 
Iscritto dal: Jul 2010
Messaggi: 872
Con linux non ci sono riuscito, purtroppo il PIN manager presente non mi si apre Secondo me c'è qualche problema proprio nel pacchetto.
Per quanto riguarda windows questo va in conflitto con le "vecchie" tessere, c'è bisogno del PIN manager di Safedive altrimenti dà errore. Quindi bisogna disinstallare tutto e mettere SafeDive2020...
__________________
utenti affidabili con cui ho trattato :
Quote:
biase,Amd4ever,matchless,gattobestiale,krocca,djfolle27,semmy83,oldfield,BarBagiaMan,Peach1200,X3n0
antcos è offline   Rispondi citando il messaggio o parte di esso
Old 28-10-2021, 10:04   #11
sacarde
Senior Member
 
Iscritto dal: Apr 2004
Messaggi: 9427
quindi , se non hai necessita di gestire il pin, la tessera ST2021 ti funziona?
sacarde è offline   Rispondi citando il messaggio o parte di esso
Old 28-10-2021, 11:51   #12
antcos
Senior Member
 
Iscritto dal: Jul 2010
Messaggi: 872
Quote:
Originariamente inviato da sacarde Guarda i messaggi
quindi , se non hai necessita di gestire il pin, la tessera ST2021 ti funziona?
Chiarisco meglio:
per far funzionare la tessera ST2021 c'è bisogno del PIN manager a prescindere dal fatto che devi cambiare PIN. Se utilizzi un altro software con suo PIN manager (è quella finestra che ti esce quando devi inserire il PIN) dà errore...
Comunque il mio problema è che linux è sul computer principale, e non poter utilizzare lì la tessera per me è un casino...
__________________
utenti affidabili con cui ho trattato :
Quote:
biase,Amd4ever,matchless,gattobestiale,krocca,djfolle27,semmy83,oldfield,BarBagiaMan,Peach1200,X3n0
antcos è offline   Rispondi citando il messaggio o parte di esso
Old 28-10-2021, 11:58   #13
Perseverance
Senior Member
 
L'Avatar di Perseverance
 
Iscritto dal: Jul 2008
Messaggi: 7179
Questi sono i tread da leggere per capire il problema, che dipende esclusivamente da un bug firmware dei lettori Bit4id

https://github.com/OpenSC/OpenSC/issues/2313
https://github.com/OpenSC/OpenSC/pull/2371
__________________
System Failure
Perseverance è online   Rispondi citando il messaggio o parte di esso
Old 28-10-2021, 14:12   #14
sacarde
Senior Member
 
Iscritto dal: Apr 2004
Messaggi: 9427
eseguendo "pkcs11-tool --test --login" con la nuova "carta sanitaria"
mi da: PIN locked
error: PKCS11 function C_Login failed: rv = CKR_PIN_LOCKED (0xa4)


e per sbloccarlo, col puk, dovrei usare l'applicazione "pin manager" no?

ma i driver per il chip ST2021 "SafeDive2020" (non mi si installano)



p.s.
in /etc/opensc/opensc.conf ho aggiunto:
Codice:
enable_pinpad = false;

Ultima modifica di sacarde : 28-10-2021 alle 14:19.
sacarde è offline   Rispondi citando il messaggio o parte di esso
Old 28-10-2021, 15:29   #15
Perseverance
Senior Member
 
L'Avatar di Perseverance
 
Iscritto dal: Jul 2008
Messaggi: 7179
Purtroppo non posso dire di più di quanto si può leggere non avendo personalmente alcuna carta ST2021, quando mi capiterà a tiro la nuova probabilmente avrò gli stessi vostri problemi ma potrò indagare di persona.

Il fatto è che mi par di capire che nessuno utilizzi il driver proprietario ma opensc e che firefox sia impostato per quello. Te cosa hai impostato nel percorso come dispositivo di sicurezza in firefox?
Questo? /usr/lib/x86_64-linux-gnu/pkcs11/opensc-pkcs11.so
__________________
System Failure
Perseverance è online   Rispondi citando il messaggio o parte di esso
Old 28-10-2021, 15:37   #16
sacarde
Senior Member
 
Iscritto dal: Apr 2004
Messaggi: 9427
ho impostato: /usr/lib/x86_64-linux-gnu/opensc-pkcs11.so




p.s.
su un'altra discussione dicono di installare java con:

sudo apt install openjdk-11-jdk
sacarde è offline   Rispondi citando il messaggio o parte di esso
Old 28-10-2021, 16:11   #17
Perseverance
Senior Member
 
L'Avatar di Perseverance
 
Iscritto dal: Jul 2008
Messaggi: 7179
md5sum ?
11eadae22cb9dbf32eb2eae6cb1702f5 /usr/lib/x86_64-linux-gnu/opensc-pkcs11.so

-edit-
Disgraziatamente i repository di ubuntu 20.04LTS sono fermi alla verisone opensc/focal 0.20.0-3 amd64 mentre i bugfix dalla pagina di github arrivano fino all'odierna OpenSC-0.22.0. Github segna 779 commits di differenza, quindi chissà quanto codice è stato scritto in più rispetto alla versione che puoi installare da ubuntu.
__________________
System Failure

Ultima modifica di Perseverance : 28-10-2021 alle 16:19.
Perseverance è online   Rispondi citando il messaggio o parte di esso
Old 28-10-2021, 16:23   #18
sacarde
Senior Member
 
Iscritto dal: Apr 2004
Messaggi: 9427
io ho:

Codice:
md5sum /usr/lib/x86_64-linux-gnu/opensc-pkcs11.so
63270cd0cb8ce0c569b06fcae68a4c9d  /usr/lib/x86_64-linux-gnu/opensc-pkcs11.so

Codice:
dpkg -l|grep opensc
ii  opensc                                          0.17.0-3                                    amd64        Smart card utilities with support for PKCS#15 compatible cards
ii  opensc-pkcs11:amd64                             0.17.0-3                                    amd64        Smart card utilities with support for PKCS#15 compatible cards


p.s.
mi consigli di installare quel pacchetto per java? (piu di 200mb di download)

o installare openjdk-11-jre

Ultima modifica di sacarde : 28-10-2021 alle 16:29.
sacarde è offline   Rispondi citando il messaggio o parte di esso
Old 28-10-2021, 16:34   #19
Perseverance
Senior Member
 
L'Avatar di Perseverance
 
Iscritto dal: Jul 2008
Messaggi: 7179
Li hai ancora più vecchi di quelli che ho io con ubuntu 20.04 LTS. Lascia perdere JAVA, mi par di capire che non sia la soluzione. Semmai bisogna scaricare il *.tar.gz https://github.com/OpenSC/OpenSC/releases/tag/0.22.0 cercare bene tutte le dipendenze e gli header che mancano eppoi dare i classici comandi ./configure , make , sudo make install
__________________
System Failure
Perseverance è online   Rispondi citando il messaggio o parte di esso
Old 28-10-2021, 16:57   #20
sacarde
Senior Member
 
Iscritto dal: Apr 2004
Messaggi: 9427
il problema "java" e' che quando lancio:

./PIN\ Manager mi ritorna:

Codice:
./go.sh: 1: ./go.sh: ./jre/bin/java: Permission denied
dentro go.sh:

Codice:
cat ./go.sh 
./jre/bin/java -Dsun.security.smartcardio.library=/usr/lib/x86_64-linux-gnu/libpcsclite.so.1 -cp ./plugin/safediveui2.jar:./lib/* -Djava.library.path=./outerlibs it.incard.icil.view.Launcher
e dentro la dir c'e' la sottodir: ./jre/bin/java
sacarde è offline   Rispondi citando il messaggio o parte di esso
 Rispondi


Apple Watch 7 e Fitness+: connubio perfetto per la palestra in casa. La recensione Apple Watch 7 e Fitness+: connubio perfetto per ...
Fujinon XF33mmF1.4R LM WR, standard di nuova generazione per il sistema Fujifilm X Fujinon XF33mmF1.4R LM WR, standard di nuova gen...
Intel Core i9-12900K, prestazioni con Windows 11 e Windows 10 a confronto Intel Core i9-12900K, prestazioni con Windows 11...
Forza Horizon 5: perché è il simcade perfetto Forza Horizon 5: perché è il simca...
Gestire le spese dei dipendenti è facile e veloce con Qonto Gestire le spese dei dipendenti è facile ...
OPPO pensa ad un Natale tech! Ecco tanti...
Squid Game arriva su Netflix in lingua i...
Rocket League arriva su iOS e Android: o...
Il computer quantistico di Google non ha...
Le auto elettriche Stellantis ricevono p...
Non è del Galaxy S21 Ultra la fot...
MacBook Pro 16: segnalato qualche proble...
Clarity Boost per Microsoft Edge miglior...
FIFA 22: Sony presenta la nuova stagione...
Tesla, ora gli upgrade si possono compra...
SanDisk Extreme microSD da 128GB a 19€, ...
Rinnovo patente per gli anziani? Decider...
Come disattivare il suono di avvio su Wi...
Il Black Friday è finito, ma Amaz...
Da SAP nuovi strumenti per accelerare la...
SmartFTP
LibreOffice 7.2.3
7-Zip
Chromium
OCCT
K-Lite Codec Pack Update
K-Lite Mega Codec Pack
K-Lite Codec Pack Full
K-Lite Codec Pack Standard
K-Lite Codec Pack Basic
Opera Portable
Opera 81
Firefox Portable
NTLite
SiSoftware Sandra Lite
Tutti gli articoli Tutte le news Tutti i download

Strumenti

Regole
Non Puoi aprire nuove discussioni
Non Puoi rispondere ai messaggi
Non Puoi allegare file
Non Puoi modificare i tuoi messaggi

Il codice vB è On
Le Faccine sono On
Il codice [IMG] è On
Il codice HTML è Off
Vai al Forum


Tutti gli orari sono GMT +1. Ora sono le: 22:35.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Served by www2v