PDA

View Full Version : [Thread Ufficiale] Preparazione CCNA autodidatta


Pagine : [1] 2 3 4 5 6 7

The_ouroboros
25-09-2012, 15:46
Salve a tutti,

Come mi è stato consigliato, apro un 3d per domande, esercizi, dubbi e approfondimenti sulla preparazione della certificazione Cisco CCNA (e oltre) per cui mi sto preparando da audodidatta.

Sperando che serva anche a qualcun'altro cercherò di mettere in questo primo post le info utili (così da non dover leggere pagine su pagine).

Ed ecco una lista di post interessanti (aggiornata spesso):

Una conversazione arp (http://www.hwupgrade.it/forum/showpost.php?p=38294601&postcount=343)
Una delle differenze tra wired e wireless I (http://www.hwupgrade.it/forum/showpost.php?p=38258602&postcount=281)
Una delle differenze tra wired e wireless II (http://www.hwupgrade.it/forum/showpost.php?p=38323763&postcount=357)
Domande e soluzioni di subnetting (e post successivi) (http://www.hwupgrade.it/forum/showpost.php?p=38226738&postcount=135)
Esempi pratici di supernetting (manual summary) (http://www.hwupgrade.it/forum/showpost.php?p=38214582&postcount=54)
OSPF (post domande) (http://www.hwupgrade.it/forum/showpost.php?p=38269265&postcount=312)
EIGRP (post domande) (http://www.hwupgrade.it/forum/showpost.php?p=38267762&postcount=311)
Indirizzi Ipv6 una intro sulle varie parti (http://www.hwupgrade.it/forum/showpost.php?p=38243579&postcount=231)
Indirizzi Ipv6 una intro sulle varie parti II (http://www.hwupgrade.it/forum/showpost.php?p=38243655&postcount=234)
Indirizzo multicast Ipv6 (http://www.hwupgrade.it/forum/showpost.php?p=38243743&postcount=237)
Multicast EIGRP in Ipv6 (http://www.hwupgrade.it/forum/showpost.php?p=38243800&postcount=241)
Altri importanti multicast Ipv6 (http://www.hwupgrade.it/forum/showpost.php?p=38243832&postcount=242)
I multicast "link-local scope" Ipv6 (http://www.hwupgrade.it/forum/showpost.php?p=38243838&postcount=243)
Autoconfig IPv6 (http://www.hwupgrade.it/forum/showpost.php?p=38240414&postcount=203)
Domanda su STP (http://www.hwupgrade.it/forum/showpost.php?p=38237091&postcount=183)
Domanda EIGRP (http://www.hwupgrade.it/forum/showpost.php?p=38237225&postcount=186)
IPv4 Multicast addresses (http://www.hwupgrade.it/forum/showpost.php?p=38249049&postcount=256)
Schemi riassuntivi EIGRP (http://www.hwupgrade.it/forum/showpost.php?p=38571805&postcount=426)
Programma CCNP Route in Mappe concettuali per ripassi e apprendimento rapido (http://www.hwupgrade.it/forum/showpost.php?p=40350318&postcount=725)
CCIE Routing & Switching Mappe concettuali MPLS (http://www.hwupgrade.it/forum/showpost.php?p=40353395&postcount=727)
Public Route Servers (per esercitarsi con gli show commands di BGP sui router di dorsale reali) (http://www.hwupgrade.it/forum/showpost.php?p=40353395&postcount=727)




Collegamenti esterni:


Nozione di base sul subnetting (http://mynewroadtolife.blogspot.it/2012/10/le-regole-dei-giochi-diamo-i-numeri.html)
Il primo gioco: subnetting for dummies (http://mynewroadtolife.blogspot.it/2012/10/il-gioco-delle-sottoreti.html)
Guida Linux per connettersi a devices Cisco (http://mynewroadtolife.blogspot.it/2012/10/minicom-come-connettersi-device-cisco.html)
Ipv6 Subnetting (Cisco forums) (https://supportforums.cisco.com/docs/DOC-17232)
Schede riassuntive (http://packetlife.net/library/cheat-sheets/)
Blog CCNA di Wendell Odom (http://www.ccnaskills.com/)
Tanenbaum, Wetherall Computer Networks 5e Video Set (http://media.pearsoncmg.com/ph/streaming/esm/tanenbaum5e_videonotes/tanenbaum_videoNotes.html)
Cisco ASA 8.4 on GNS3 (http://www.xerunetworks.com/2012/02/cisco-asa-84-on-gns3/)
Lab per la CCNA free (per PT) (http://freeccnalab.com/)



-+-+-+ Programma CCNP Route in Mappe concettuali per ripassi e apprendimento rapido. (by Wolfhwk)

Qui sotto trovate i link gdrive delle mappe concettuali che io uso abitualmente per i miei studenti. Sono molto fedeli alla guida certificazione ufficiale.
Sono dei jpeg enormi che fanno la loro porca figura sui mega schermoni dell' aula dove insegno. Nel vostro caso dovete zoomare molto.
Per il download non è richiesta la mia autorizzazione. E' pubblico.
Ouroboros, segnala in prima pagina.
E' tutto in italiano.

ADVANCED IGP REDISTRIBUTION
https://drive.google.com/file/d/0BwNT_t67hCahdHpoWmNReHAyVTQ/view?usp=sharing



OSPF ROUTE SUMMARIZATION FILTERING DEFAULT ROUTING
https://drive.google.com/file/d/0BwNT_t67hCahcFh2Q2tFLXd0U0U/view?usp=sharing



IPV4 AND IPV6 COEXISTENCE
https://drive.google.com/file/d/0BwNT_t67hCahc1JNOHY2c291YUk/view?usp=sharing





OSPF NEIGHBORSHIPS
https://drive.google.com/file/d/0BwNT_t67hCahYWJqQjBsaVk5QzQ/view?usp=sharing




BASIC IGP REDISTRIBUTION
https://drive.google.com/file/d/0BwNT_t67hCahY0NiSW1qLU5LWGc/view?usp=sharing



EIGRP TOPOLOGY ROUTES CONVERGENCE
https://drive.google.com/file/d/0BwNT_t67hCahWmNMcEI2RTJFOEE/view?usp=sharing



IPV6 ADDRESSING
https://drive.google.com/file/d/0BwNT_t67hCahQzdQc0ROSmtXbUk/view?usp=sharing



INTERNAL BGP AND BGP ROUTE FILTERING
https://drive.google.com/file/d/0BwNT_t67hCahUGFFQnI1SmFJZU0/view?usp=sharing



EIGRP NEIGHBORSHIPS
https://drive.google.com/file/d/0BwNT_t67hCahU1ZCdGFad0ZvQUE/view?usp=sharing



EIGRP ROUTE SUMMARIZATION AND FILTERING
https://drive.google.com/file/d/0BwNT_t67hCahU0J3dWlLU0hnMW8/view?usp=sharing


IPV6 ROUTING PROTOCOLS AND REDISTRIBUTION
https://drive.google.com/file/d/0BwNT_t67hCahSHZwOURya1RSZjA/view?usp=sharing




OSPF VIRTUAL LINKS AND FRAME-RELAY OPERATIONS
https://drive.google.com/file/d/0BwNT_t67hCahSGEySVl3aXBzSFU/view?usp=sharing



ROUTING OVER BRANCH INTERNET CONNECTIONS
https://drive.google.com/file/d/0BwNT_t67hCahRmZRbFZweVlPaUU/view?usp=sharing




INTERNET CONNECTIVITY AND BGP
https://drive.google.com/file/d/0BwNT_t67hCahR1JENWgwTk83RTg/view?usp=sharing



BGP PATH CONTROL
https://drive.google.com/file/d/0BwNT_t67hCahQUlHdXZCMDkyLW8/view?usp=sharing



POLICY BASED ROUTING AND IP SERVICE LEVEL AGREEMENT
https://drive.google.com/file/d/0BwNT_t67hCahMmVaWC1sNUhNVEk/view?usp=sharing



EXTERNAL BGP
https://drive.google.com/file/d/0BwNT_t67hCahMTdqNG9MbzU4S0U/view?usp=sharing



OSPF TOPOLOGY ROUTES CONVERGENCE
https://drive.google.com/file/d/0BwNT_t67hCahLTVtY1NhWVpVQ28/view?usp=sharing[/QUOTE]

___________________________________________________________

Il contenuto di questo post è rilasciato con licenza Creative Commons
Attribution-Noncommercial-Share Alike 2.5

http://creativecommons.org/images/public/somerights20.png (http://creativecommons.org/licenses/by-nc-sa/2.5/it/)

The_ouroboros
25-09-2012, 15:58
mi è venuto un piccolo dubbio (curiosità invero).
Ma per collegamente p2p (router-router ad esempio) c'è qualche regola?
Nei testi, in linea di massima, si usa sempre un collegamento seriale. (io nei lab virtuali uso sempre un RJ45 cross, di solito FastEthernet)

Wolfhwk
25-09-2012, 16:00
Ottimo. :)

Wolfhwk
25-09-2012, 16:07
mi è venuto un piccolo dubbio (curiosità invero).
Ma per collegamente p2p (router-router ad esempio) c'è qualche regola?
Nei testi, in linea di massima, si usa sempre un collegamento seriale. (io nei lab virtuali uso sempre un RJ45 cross, di solito FastEthernet)

Mah, dipende dal servizio wan. Nel frame-relay userai il seriale, nel Metro Ethernet avrai un fast o gigabit ethernet con trunking.
Generalmente in linea teorica il clock ci viene dato da un csu/dsu collegato con seriale al router. Il csu/dsu a sua volta è collegato al provider con un cavo che ha lo spinotto rj45 (esempio ccna).
Diciamo che fondamentalmente la porta fastethernet è per la LAN.
In laboratorio monterai due router. Uno con un cavo seriale DTE e l'altro DCE collegati insieme. Il DCE fornisce il clock.

The_ouroboros
25-09-2012, 16:13
Capisco.

The_ouroboros
25-09-2012, 16:29
Quindi è come se fosse che il DCE è il nostro "ISP" e il DTE e il "modem".
Passami i termini, sto cercando di capire

Wolfhwk
25-09-2012, 16:32
Il DTE è il nostro router, il DCE è il dispositivo del provider che dà il clock.
Attenzione però che molti router hanno il dce integrato (una scheda/modulo), oppure può essere un dispositivo esterno delle dimensioni di un modem, oppure uno switch frame-relay.

The_ouroboros
25-09-2012, 16:34
parli dei moduli WIC?

Wolfhwk
25-09-2012, 16:46
Yes.

The_ouroboros
25-09-2012, 16:52
comincio a capire.
Ora però ritorno alle mie care NAT e PAT :cool:

The_ouroboros
27-09-2012, 13:26
domanda su routing... ma RIPv2 conviene veramente su reti SOHO o piccole?
O un EIGRP è meglio e più funzionale?

Wolfhwk
27-09-2012, 13:48
EIGRP richiede una discreta potenza di calcolo (e consumo di banda), perchè generalmente la metrica viene calcolata in base alla banda e al ritardo cumulativo (il delay).

In reti piccole, in cui non vi sono molti link con banda differente, conviene utilizzare ripv2, se non addirittura route statiche.

Pensa che su interfacce(o subint) frame-relay punto punto conviene persino impostare il 30% di banda dedicata a eigrp per il suo ottimale funzionamento (per curiosità, il comando è "ip bandwidth-percent eigrp <as num> <percentuale>").

The_ouroboros
27-09-2012, 16:02
Pensa che su interfacce(o subint) frame-relay punto punto conviene persino impostare il 30% di banda dedicata a eigrp per il suo ottimale funzionamento (per curiosità, il comando è "ip bandwidth-percent eigrp <as num> <percentuale>").

Interessante :D

E OSPF, come è messo a occupazione banda?

Wolfhwk
27-09-2012, 17:14
Mah, ospf deve vedersela con il calcolo dell' algoritmo spf. Pertanto si tendono a creare delle aree per non sovraccaricare i router. In quanto a occupazione banda siamo ai livelli di eigrp.
Uno dei punti forti dell' eigrp è la possibilità di sfruttare la varianza per inserire route non uguali per una subnet come successor nella tabella di routing, consentendo convergenza istantanea in caso di problemi e load balancing proporzionale (ovver per valore metrica).
E con offset-list mi posso modificare pure la feasible distance e quindi anche la reported distance per una subnet, per crearmi route idonee all' utilizzo con la varianza.

The_ouroboros
27-09-2012, 17:41
L'algoritmo di Dijkstra, già. :stordita:

Quindi...
Per una soho è meglio una bella static route.
Piccolo ufficio Ripv2
Grande EIGRP/OSPF.

Il tutto, ovviamente, cum grano salis e in base alla situazione. (mai generalizzare troppo, mi insegna l'esperienza)

Cmq oggi mi sono dato un occhio a nat e pat e ho ritrovato le ACL.. sono ovunque (o quasi :D )

Wolfhwk
28-09-2012, 08:08
Bravo, usare eigrp/ospf in reti piccole è come cercare di uccidere una mosca con un lanciamissili.

Per quanto riguarda le access-list stai particolarmente attento a questi punti:

- usano la first-match logic
- vanno dalla più specifica alla più generica (num di sequenza crescenti)
- negano tutto il traffico in modo implicito a meno che non gli si configuri alla fine un bel
permit ip any any (extended) o permit any (standard).

The_ouroboros
28-09-2012, 14:43
:

- usano la first-match logic
- vanno dalla più specifica alla più generica (num di sequenza crescenti)
- negano tutto il traffico in modo implicito a meno che non gli si configuri alla fine un bel
permit ip any any (extended) o permit any (standard).

Non ho ben presente il concetto in neretto (o magari lo conosco come altro)... potresti chiarirlo?

Thanks come sempre

Wolfhwk
28-09-2012, 15:37
Praticamente cerco la prima corrispondenza e poi esco dal processo di verifica delle condizioni della access-list.
Per questo è importante la regola "dalla più specifica alla più generica".

Se metti come prima sequenza <deny ip any any>, non passerà nessuno, anche se nella sequenza successiva ci sono regole che permettono il transito di eventuale traffico.

La sequenza viene decisa con le extended e standard nell' ordine in cui si inseriscono le regole. Nella named access-list si può specificare il numero di sequenza e inserire la regola dove si vuole nella lista (sempre rispettando il criterio specifica-generica).

Sono stato chiaro? :)

The_ouroboros
28-09-2012, 15:58
ora si.
Una altra piccola domandina, poi per oggi, che non sto benissimo, mi rilasso un poco.
Le interfacce di Loopback.. a parte l'evidente plus di essere always on tranne problemi fisici del router...che utilità hanno?

Wolfhwk
28-09-2012, 16:19
Ad esempio nell' elezione del designated router e backup designated router con ospf (le int loopback sono stabili) nel caso in cui non si sia definito il RID con il comando <router-id>, oppure per propagare una default-network tramite eigrp.
Il caso di eigrp è particolarmente interessante.

Il router che ha diretto accesso a internet propaga una rete virtuale/logica presa dall' interfaccia di loopback. Gli altri router vedranno come default-network la rete del loopback e come GW of last resort il next-hop router come di norma.
Ovviamente il router che propaga questa default-network instrada correttamente il traffico verso l' interfaccia affacciata su internet e non ha un GW of last resort.

The_ouroboros
28-09-2012, 16:24
una spece di "finto" router pre router vero (dentro il router edge) da usare per motivi di routing protocol insomma?

Wolfhwk
28-09-2012, 16:27
Yes. Una sorta di pubblicità ingannevole a fin di bene :D
Il loopback, come detto sopra, ha il vantaggio di essere estremamente affidabile e stabile, a differenza delle interfacce fisiche.
Infine solo l' edge router deve conoscere la subnet che si affaccia su internet.

The_ouroboros
28-09-2012, 16:30
molto cool!
Non so se sia negli obiettivi CCNA ma adoro imparare cose nuove (e utili) :D

The_ouroboros
28-09-2012, 16:30
Infine solo l' edge router deve conoscere la subnet che si affaccia su internet.
Maggiore sicurezza :eek:

Wolfhwk
28-09-2012, 16:35
molto cool!
Non so se sia negli obiettivi CCNA ma adoro imparare cose nuove (e utili) :D

Ehm, se non erro è roba da ccnp. :stordita:

Wolfhwk
28-09-2012, 16:36
Maggiore sicurezza :eek:

Eh, eh, vedrai con gli switch. Lì si arriva alla vera paranoia :D

The_ouroboros
28-09-2012, 16:37
Ehm, se non erro è roba da ccnp. :stordita:

odiavo alle superiori e anche all'uni la categorizzazione stretta dell sapere.
Le delimitazioni sono utili ma gli unici limiti che abbiamo sono quelli che ci inventiamo noi.
Ovviamente se cerchi di capire cose che vanno molto oltre a quello che sai senza prima farti le basi è folle ma cmq... :D

The_ouroboros
28-09-2012, 16:38
Eh, eh, vedrai con gli switch. Lì si arriva alla vera paranoia :D

Auch :stordita:

Wolfhwk
28-09-2012, 16:44
odiavo alle superiori e anche all'uni la categorizzazione stretta dell sapere.
Le delimitazioni sono utili ma gli unici limiti che abbiamo sono quelli che ci inventiamo noi.
Ovviamente se cerchi di capire cose che vanno molto oltre a quello che sai senza prima farti le basi è folle ma cmq... :D

D' accordissimo ;)

Wolfhwk
28-09-2012, 16:46
Auch :stordita:

Vedrai che sarà divertente. :)

The_ouroboros
28-09-2012, 16:51
Vedrai che sarà divertente. :)
altrimenti non sceglievo questo lavoro :D
Cmq la sicurezza è un altro argomento che non mi spiace (adoro informarmi di crittografia e crittoanalisi)
Unica cosa che mi lascia un po sull'astratto sono le cable WAN..
Qui in italy non penso di averle mai viste o sentito parlare.
Da quando ho cominciato a vedere l'ambito WAN, ho capito i parametri VCI/VPI dell mio router(moolto interessante come funziona dalla casa alla DSLAM e oltre).
xDSL posso dire di averle "viste"..
Sarà che la tv via cavo qui non ha mai preso come negle USA?

Wolfhwk
28-09-2012, 17:00
Può darsi. Gli arriva tutto tramite cavo coassiale.

Per il discorso sicurezza c'è la ccna security e la ccsp.
La ccna security la puoi fare solo se hai conseguito la ccna.
Il mio consiglio è di fare la ccna -> ccnp e poi la security.
Con una solida base quale è la ccna e le skill derivanti dalla ccnp, le security saranno ancora più divertenti da studiare e approfondire.
Potrai studiare l' argomento con maggiore consapevolezza (passami il termine :D )

The_ouroboros
28-09-2012, 17:03
Per il discorso sicurezza c'è la ccna security e la ccsp.
La ccna security la puoi fare solo se hai conseguito la ccna.
Il mio consiglio è di fare la ccna -> ccnp e poi la security.
Con una solida base quale è la ccna e le skill derivanti dalla ccnp, le security saranno ancora più divertenti da studiare e approfondire.

Potrai studiare l' argomento con maggiore consapevolezza (passami il termine :D )

Interessante percorso... quindi uno può fare la ccnp e poi "scendere" alla ccna security?

P.S: la ccsp è retired. Consigliano la CCNP Security (pare conforme alla regolamentazione NSA)

Wolfhwk
28-09-2012, 17:09
Yes. Nella ccnp si trattano prevalentemente argomenti di routing, switching e relativo troubleshooting. In modo approfondito.

Conviene certamente scendere alla ccna security, dato che tratta argomenti sostanzialmente incentrati sulla sicurezza e sulla famosa self-defense network di cisco :D

Wolfhwk
28-09-2012, 17:13
Consigliano la CCNP Security (pare conforme alla regolamentazione NSA)

Ah, già. Me ne ero dimenticato.

The_ouroboros
28-09-2012, 17:13
ach so.. una CCNA advanced è complementare quindi ;)
Direi di cominciare con la CCNA, trovarmi un lavoro attinente, fare esperienza e poi prendermi la CCNP (che applicando per un po ciò che ho imparato) dovrebbe essere più liscia come percorso ( non come difficoltà degli argoemnti ovvio).

Wolfhwk
28-09-2012, 17:19
Puoi anche provare la ccnp da autodidatta. E' fattibile.
L' unico ostacolo potrebbero essere gli switch, dato che gns3 non li emula.

The_ouroboros
28-09-2012, 17:21
Puoi anche provare la ccnp da autodidatta. E' fattibile.
L' unico ostacolo potrebbero essere gli switch, dato che gns3 non li emula.
direi che alla fine farò così.
Anche se GNS3 ha quel piccolo problema (in realtà gli ASA degli switch non credo siano cosi semplici da virtualizzare)
Solo che prima di farla voglio mettermi all'opera e acquisire esperienza con la mia (pensiero positivo) CCNA.
Dato che nulla sostituisce l'esperienza

Wolfhwk
28-09-2012, 17:28
Bene, non avere paura a rileggere i capitoli meno chiari anche 10 volte.
La ccna va saputa dettagliatamente e piuttosto bene. :)
Ci devono essere delle fondamenta estremamente solide.

The_ouroboros
28-09-2012, 17:32
Bene, non avere paura a rileggere i capitoli meno chiari anche 10 volte.
La ccna va saputa dettagliatamente e piuttosto bene. :)
Ci devono essere delle fondamenta estremamente solide.

Sto cercando di unire una lettura approfondita a dei lab virtuali (da me inventati o trovati in giro).

Tanto anche se rileggo la stessa cosa 4 volte non fa che bene, no? :stordita:

I miei fidi McQuerry(+ teorico) e Lammle (più discorsivo e diretto) non me li toglie nessuno.

Wolfhwk
28-09-2012, 17:34
Fa tutto bene. :D
Io consiglio Lammle per il subnetting e Odom Wendell per il resto.

The_ouroboros
28-09-2012, 17:44
Fa tutto bene. :D
Io consiglio Lammle per il subnetting e Odom Wendell per il resto.

Oramai penso per blocchi, potenze di 2 e aritmetica 256 grazie al "metodo veloce" di Lammle :cool:
L'Odom, purtroppo, non l'ho preso dato che per 40€ su amazon.com ho trovato i 2 McQuerry (sono cosi male?)

Wolfhwk
28-09-2012, 21:37
Mi piace molto Odom per la ricchezza di dettagli che i suoi libri contengono. Inoltre trovo eccezionale la parte sul troubleshooting. Pero' se ti trovi bene con McQuerry procedi pure con quello.

The_ouroboros
29-09-2012, 23:32
Ho trovato un interessante link (http://billatnapier.com/security/IP/routesum) sulla Route Summarization.
Quindi prendo l'ip + piccolo dopo aver trasformato il tutto in bit e come maschera uso i bits comuni :D

The_ouroboros
30-09-2012, 15:56
Ho trovato un altro uso per le loopback.
Diffondere un pool di indirizzi usato in una nat (dinamica). :fagiano:

Wolfhwk
01-10-2012, 07:53
Ho trovato un interessante link (http://billatnapier.com/security/IP/routesum) sulla Route Summarization.
Quindi prendo l'ip + piccolo dopo aver trasformato il tutto in bit e come maschera uso i bits comuni :D

Il metodo di Wendell è ancora più semplice. Parti dalla subnet mask più bassa e sottrai via via 1 alla mask fino a includere tutto.
E' la manual summarization, attenzione con i termini.

Wolfhwk
01-10-2012, 07:57
Ho trovato un altro uso per le loopback.
Diffondere un pool di indirizzi usato in una nat (dinamica). :fagiano:

Uhm, utilizzo di certo poco comune. Prova un po' a spiegare la faccenda.


PS. Venerdì parlavo con un mio collega riguardo al percorso di certificazione. Se intendi lavorare con la ccna, è raccomandata fortemente anche la ccna security. Questo perchè la sicurezza è fondamentale ed è richiestissima, mentre la ccna security dopo lo sforzo della ccna dovrebbe essere quasi una passeggiata.

The_ouroboros
01-10-2012, 08:30
Uhm, utilizzo di certo poco comune. Prova un po' a spiegare la faccenda.


PS. Venerdì parlavo con un mio collega riguardo al percorso di certificazione. Se intendi lavorare con la ccna, è raccomandata fortemente anche la ccna security. Questo perchè la sicurezza è fondamentale ed è richiestissima, mentre la ccna security dopo lo sforzo della ccna dovrebbe essere quasi una passeggiata.

Mi sono fatto una NAT dinamica che da 192.168.0.2 andava al range 190.10.0.0-190.10.0.5 per l'esterno.
Solo che non riuscivo a pingare dall'esterno al pc con ip nattato.
Ho allora creato una loopback 190.10.10.6 255.255.255.0 e così EIGRP ha potuto diffondere la rete e ho risolto.
Lo so che è un po inusuale ma era una delle soluzioni che ho pensato.


!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R4
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
!
!
!
!
interface Loopback1
ip address 190.10.10.6 255.255.255.0
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.252
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
ip address 10.1.0.1 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface Ethernet0/0/0
ip address 192.168.0.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router eigrp 10
network 10.0.0.0
network 192.168.0.0
network 192.169.0.0
network 190.10.0.0
network 190.0.0.0
network 190.10.0.0 0.0.0.255
auto-summary
!
router rip
version 2
network 10.0.0.0
network 192.168.0.0
network 192.169.0.0
!
ip nat pool Off 190.10.0.0 190.10.0.5 netmask 255.255.255.0
ip nat inside source list 10 pool Off
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
!
access-list 10 permit host 192.168.0.2
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end


Lo so che la conf non è bellissima(ripv2+eigrp)ma puntavo a risolvere il problema non alla perfezione :stordita:
E oltretutto la sto usando per vedere un po come si debuggano i vari protocolli.

P.s: interessante...

The_ouroboros
01-10-2012, 08:41
in effetti non è una soluzione incredibile...ma è stato un attimo di estro e follia a suggerirla.
Cmq se hai una soluzione più elegante, sono tutto orecchi :D :D

Wolfhwk
01-10-2012, 09:06
Mi sono fatto una NAT dinamica che da 192.168.0.2 andava al range 190.10.0.0-190.10.0.5 per l'esterno.
Solo che non riuscivo a pingare dall'esterno al pc con ip nattato.
Ho allora creato una loopback 190.10.10.6 255.255.255.0 e così EIGRP ha potuto diffondere la rete e ho risolto.
Lo so che è un po inusuale ma era una delle soluzioni che ho pensato.


Molto bravissimo (cit.) :D
Ti ho fatto la domanda perchè generalmente l' ip nat outside avrà l'ip pubblico senza dover richiamare la loopback.

Wolfhwk
01-10-2012, 09:09
in effetti non è una soluzione incredibile...ma è stato un attimo di estro e follia a suggerirla.
Cmq se hai una soluzione più elegante, sono tutto orecchi :D :D

Postami per favore qualche manual summary da fare come esercizio e ti mostro la tecnica.

The_ouroboros
01-10-2012, 09:23
172.16.50.0 172.16.60.0 172.16.70.0 172.16.80.0 172.16.90.0 172.16.100.0 172.16.110.0 172.16.120.0 sm 255.255.255.240

192.168.98.0 192.168.99.0 192.168.100.0 192.168.101.0 192.168.102.0 192.168.105.0 sm 255.255.255.128

10.1.0.0 10.1.1.0 10.1.2.0 10.1.3.0 10.1.4.0 10.1.5.0 10.1.6.0 10.1.7.0 sm 255.248.0.0

The_ouroboros
01-10-2012, 09:25
Molto bravissimo (cit.) :D


grasie :)

Wolfhwk
01-10-2012, 09:31
Mettici le subnet mask.
Così la dimostrazione sarà ancora più intuitiva.


172.16.50.0
172.16.60.0
172.16.70.0
172.16.80.0
172.16.90.0
172.16.100.0
172.16.110.0
172.16.120.0
sm 255.255.255.240


Osserva i range. 50.0 e 127.255

128-50= 78

0-128 ci rientro.

Quindi la summary è 172.16.0.0 /17 (includo tutto)

Ti torna questo esempio?

The_ouroboros
01-10-2012, 09:46
mmm comincio a capire.
Se me ne usi un altro cosi sono sicuro :)

Wolfhwk
01-10-2012, 09:47
192.168.98.0
192.168.99.0
192.168.100.0
192.168.101.0
192.168.102.0
192.168.105.0
sm 255.255.255.128

Ottetto interessante, il terzo.

105-98=7

/21 No

/20 (16) Ok

16x6=96

96+16= 112

Range 98-105 OK

Summary

192.168.96.0 /20

The_ouroboros
01-10-2012, 09:50
questo è molto più illuminante.
Ho avuto un momento "haah" (come dice Lammle) :eek:

Wolfhwk
01-10-2012, 09:50
***errato***


10.1.0.0
10.1.1.0
10.1.2.0
10.1.3.0
10.1.4.0
10.1.5.0
10.1.6.0
10.1.7.0
sm 255.248.0.0

0-7 range terzo ottetto

Quindi provo con /21 (8)

Summary

10.1.0.0 /21

Range 10.1.0.1-10.1.7.255 (block size 8)

The_ouroboros
01-10-2012, 09:52
in pratica prendo il block size che prende tutto il range, no?

Wolfhwk
01-10-2012, 09:54
Certainly.

Wolfhwk
01-10-2012, 09:55
Ho avuto un momento "haah" (come dice Lammle) :eek:

:asd:

The_ouroboros
01-10-2012, 09:56
ottimo.
Mi tornerà utile anche per le VLSM :D
Cmq devo dire che non ho mai dato i numeri(binari, aritmetica 256, tabellina 16) come da quando ho cominciato networking.
E, oltretutto, con ipv6 queste cose saranno "obsolete"
L'unico neo è che l'ipv6 non lo vedo proprio vicinissimo come adozione.
Più dual-stack che puro:stordita:

Wolfhwk
01-10-2012, 10:01
Azzo, non ho guardato bene la subnet nel primo esempio. Correggo subito :asd:

The_ouroboros
01-10-2012, 10:01
Azzo, non ho guardato bene la subnet nel primo esempio. Correggo subito :asd:

non mi tornava nemmeno a me, ma ho capito il metodo :P

Wolfhwk
01-10-2012, 10:05
non mi tornava nemmeno a me, ma ho capito il metodo :P

Corretto. Ok. :D

Praticamente avevo fatto 172.16.120.0 /20

The_ouroboros
01-10-2012, 10:08
alla fine è un "giochino": trova il block size :asd:

The_ouroboros
01-10-2012, 10:09
Corretto. Ok. :D

Praticamente avevo fatto 172.16.120.0 /20

a me infatti i conti non tornavano... il momento haah è venuto al secondo esempio :fagiano:

Wolfhwk
01-10-2012, 10:09
ottimo.
Mi tornerà utile anche per le VLSM :D
Cmq devo dire che non ho mai dato i numeri(binari, aritmetica 256, tabellina 16) come da quando ho cominciato networking.
E, oltretutto, con ipv6 queste cose saranno "obsolete"
L'unico neo è che l'ipv6 non lo vedo proprio vicinissimo come adozione.
Più dual-stack che puro:stordita:

Considera che la cisco ha cominciato a premere molto di più sull' ipv6. Lo vedrai specialmente nei capitoli della ccnp.

Wolfhwk
01-10-2012, 10:10
alla fine è un "giochino": trova il block size :asd:

Bravo. Guardare sempre il range e trovare il block size per includerlo, abbassando la subnet mask.

The_ouroboros
01-10-2012, 10:12
Considera che la cisco ha cominciato a premere molto di più sull' ipv6. Lo vedrai specialmente nei capitoli della ccnp.

Il che non è male. Ipv6 è molto + lineare e meno intricato.
E' per forza, l'ipv4 è nato scarno e l'hanno poi pompato di steroidi(CIDR, NAT,PAT..) negli anni.

Ma a livello pratico, non mi sembra che la sua diffusione sia incredibile (almeno in italy)

The_ouroboros
01-10-2012, 10:14
Bravo. Guardare sempre il range e trovare il block size per includerlo, abbassando la subnet mask.

lo stesso funziona per le VLSM alla fine.
Quindi viva i giochini di subnetting :D (sottotitolati: come renderti la vita più semplice)

Wolfhwk
01-10-2012, 10:14
Nell' ultimo esempio che ho fatto vedo un altro errore, di disattenzione :muro:
Prova a correggerlo. :)

Wolfhwk
01-10-2012, 10:16
Il che non è male. Ipv6 è molto + lineare e meno intricato.
E' per forza, l'ipv4 è nato scarno e l'hanno poi pompato di steroidi(CIDR, NAT,PAT..) negli anni.

Ma a livello pratico, non mi sembra che la sua diffusione sia incredibile (almeno in italy)

Sono d'accordo.

The_ouroboros
01-10-2012, 10:20
10.1.0.0
10.1.1.0
10.1.2.0
10.1.3.0
10.1.4.0
10.1.5.0
10.1.6.0
10.1.7.0
sm 255.248.0.0 (/13)

7-0 range terzo ottetto

Quindi provo con /21 (b.s 8) (255.255.248.0)

Summary

10.1.0.0 /21

Range 10.1.0.1-10.1.7.254 (block size 8) x errore qui x


Non prendere l'indirizzo di broadcast.

Wolfhwk
01-10-2012, 10:29
No, non ci sono errori. :D

Era per inchiodare ancora di più il concetto.

10.1.0.0 ha subnet nel secondo ottetto (di 8)
Ma il range che ci interessa si mantiene stabile su 10.1 (255.255.0.0)

Terzo range variabile da 0 a 7 (quindi 8 block size)

10.1.0.1 - 10.1.7.254

Io voglio includere il quarto ottetto (tutto) e il terzo da 0 a 7.

La summary me la devo fare lavorando sul terzo ottetto, che considera la subnet 10.1.0.0
La prossima subnet in caso sarebbe la 10.1.8.0

Quindi la summary è giusta.

Spero di aver chiarito meglio il concetto :)

Wolfhwk
01-10-2012, 10:30
Non prendere l'indirizzo di broadcast.

Va preso come parte della subnet obbligatoriamente.

The_ouroboros
01-10-2012, 10:31
giusto, mea culpa.
Pensavo agli host validi :muro:

The_ouroboros
01-10-2012, 10:34
Giusto per curiosità...
Wireshark l'ho usacchiato per capire un po com'è il flusso di rete... altri programmi interessanti che potrei usare a livello pratico?

Wolfhwk
01-10-2012, 10:34
La manual summarization è molto importante. Pensa a quando dovrai implementarla per eigrp e sui ASBR e ABR di ospf.

ASBR= autonomous system boundary router
ABR = area boarder router

Wolfhwk
01-10-2012, 10:35
Giusto per curiosità...
Wireshark l'ho usacchiato per capire un po com'è il flusso di rete... altri programmi interessanti che potrei usare a livello pratico?

Uhm...ip traf, ethereal.

Anche se wireshark mi sembra ottimo. Consiglio di saperlo abbastanza benino.

The_ouroboros
01-10-2012, 10:36
La manual summarization è molto importante. Pensa a quando dovrai implementarla per eigrp e sui ASBR e ABR di ospf.

ASBR= autonomous system boundary router
ABR = area boarder router

Per risolvere il problema delle network diffuse male... si, sto leggendo in questi giorni le basi di questo ( ma mi sembra che il libro parli di CCNP per queste cose e quindi non approfondisce molto rimandando più in la.. )

The_ouroboros
01-10-2012, 10:36
Uhm...ip traf, ethereal.

Anche se wireshark mi sembra ottimo. Consiglio di saperlo abbastanza benino.

mi sa che ethereal => wireshark (hanno cambiato nome da qualche tempo).
Il primo nome da te citato non lo conosco però

Wolfhwk
01-10-2012, 10:37
mi sa che ethereal => wireshark (hanno cambiato nome da qualche tempo).
Il primo nome da te citato non lo conosco però

Ah,ok.

The_ouroboros
01-10-2012, 10:40
l'ho usato per capire in modo "fisico" pacchetti e frame e devo dire che dropbox va un sacco di traffico, ma anche windows 7 non scherza (intendo senza browser o altro aperti).
Linux, anche se in modo minore, crea un lieve flusso a macchina appena accesa..

Wolfhwk
01-10-2012, 10:41
Per risolvere il problema delle network diffuse male... si, sto leggendo in questi giorni le basi di questo ( ma mi sembra che il libro parli di CCNP per queste cose e quindi non approfondisce molto rimandando più in la.. )

Sì, la diffusione delle subnet è fuori dal ccna. Meglio così, perchè dovrebbero aggiungere almeno altri 2 capitoli per protocollo di routing :D

Wolfhwk
01-10-2012, 10:42
l'ho usato per capire in modo "fisico" pacchetti e frame e devo dire che dropbox va un sacco di traffico, ma anche windows 7 non scherza (intendo senza browser o altro aperti).
Linux, anche se in modo minore, crea un lieve flusso a macchina appena accesa..

Uhm, interessante.

The_ouroboros
01-10-2012, 10:43
Sì, la diffusione delle subnet è fuori dal ccna. Meglio così, perchè dovrebbero aggiungere almeno altri 2 capitoli per protocollo di routing :D

cmq 2/3 cose me le hai accennate tu e quancosa l'ho capita in questi giorni... :D
Non sarà molto ma è sempre una knoledge in più :)

The_ouroboros
01-10-2012, 10:46
Uhm, interessante.

ero curioso.
Soprattutto win7 e gnu/linux sono dual-stack di default.

Wolfhwk
01-10-2012, 10:48
Puoi stare certo che ne sai già più di tanti altri presunti sistemisti di rete. :)

The_ouroboros
01-10-2012, 10:50
Puoi stare certo che ne sai già più di tanti altri presunti sistemisti di rete. :)

sempre stato il bambino curioso di capire il perchè delle cose.
Per farti ridere... quando compro un sugo o un alimento nuovo, mi leggo l'etichetta con ingredienti e modo di conservazione. :stordita: :stordita:

Wolfhwk
01-10-2012, 10:52
Wow, nice :asd:

Bravo, atteggiamento giusto. :)

The_ouroboros
01-10-2012, 10:55
Oggi mi metterò sotto con le ACL cmq.. sono molto interessanti ma un poco sfuggenti a volte...

P.S: ho scoperto con il mio netgear dgn1000 (http://www.gruppocomet.it/webapp/wcs/stores/servlet/it/comet/router+adsl+wireless) wifi preso 2 anni fà supporta ripv1 e ripv2 e supporto vpn :O

Wolfhwk
01-10-2012, 10:59
ripv1? Micidiale :asd:

Sì, in effetti le acl sono cazzute. :stordita:

Guarda questa acl qui:

ip access-list extended test permit ip host 172.16.0.0 host 255.255.252.0

Ti giuro che la prima volta mi ha fatto ammattire :asd:

The_ouroboros
01-10-2012, 11:01
ripv1? Micidiale :asd:


per un routerino pagato all'incirca 35€ ripv2 + vpn non è male :stordita:

The_ouroboros
01-10-2012, 11:01
ip access-list extended test permit ip host 172.16.0.0 host 255.255.252.0


omg!
Una acl per una p2p?

Wolfhwk
01-10-2012, 11:03
per un routerino da 40€ ripv2 + vpn non p male :stordita:

Sì, sì, mi sembra molto buono (stavo guardando le specifiche sul web).

Wolfhwk
01-10-2012, 11:03
omg!
Una acl per una p2p?

acqua.

Prova ancora che è interessante questa. :asd:
La prima volta mi è imploso il cervello in un buco nero. :asd:

The_ouroboros
01-10-2012, 11:04
Sì, sì, mi sembra molto buono (stavo guardando le specifiche sul web).

all'epoca non sapevo nulla ma leggendo la scheda di riferimento mi era semprato abbastanza buono :)

The_ouroboros
01-10-2012, 11:10
acqua.

Prova ancora che è interessante questa. :asd:
La prima volta mi è imploso il cervello in un buco nero. :asd:


mi sono perso un attimo... è bastardissima :muro:

Wolfhwk
01-10-2012, 11:11
all'epoca non sapevo nulla ma leggendo la scheda di riferimento mi era semprato abbastanza buono :)

C' hai azzeccato allora :cool:
Interessante la presenza della vpn.

Wolfhwk
01-10-2012, 11:13
mi sono perso un attimo... è bastardissima :muro:

E' abominevole. Difatti uso altre funzionalità per sfuggirle :fagiano:

The_ouroboros
01-10-2012, 11:13
permette le due sottoreti 172.16.0.0 e 172.16.1.0 ? :cry:

P.S: non impalarmi per questa risposta

The_ouroboros
01-10-2012, 11:14
C' hai azzeccato allora :cool:
Interessante la presenza della vpn.

devo vedermela con calma in effetti.

Wolfhwk
01-10-2012, 11:16
permette le due sottoreti 172.16.0.0 e 172.16.1.0 ? :cry:

P.S: non impalarmi per questa risposta

:eek:

fuoco

The_ouroboros
01-10-2012, 11:18
permette solo a tali reti di connettersi e droppa le altre? Una spece di "tunnel privato"?

Wolfhwk
01-10-2012, 11:18
Se ci fai caso è bastarda perchè il primo host è la sorgente e il secondo una destinazione.

In realtà è un range.

The_ouroboros
01-10-2012, 11:20
starda!
:mbe:

Wolfhwk
01-10-2012, 11:21
permette solo a tali reti di connettersi e droppa le altre? Una spece di "tunnel privato"?

Più semplicemente permette il traffico di questo range: 172.16.0.0 - 172.16.3.255 (data la mask di 252, block size 4)

Ma se la guardi con l'ottica di una extended acl è intrippante :mc:

The_ouroboros
01-10-2012, 11:21
io chiederei l'ergastolo per chi ne fa uso :fagiano:

Wolfhwk
01-10-2012, 11:22
:asd: :asd: :asd:

The_ouroboros
01-10-2012, 11:23
però ci stavo, moolto lentamente, arrivando.
La cosa mi rincuora.
Ma l'hai trovata veramente? Le hanno ritrovate le ossa di chi l'aveva immessa alla fine? :stordita:

Wolfhwk
01-10-2012, 11:31
però ci stavo, moolto lentamente, arrivando.
La cosa mi rincuora.
Ma l'hai trovata veramente? Le hanno ritrovate le ossa di chi l'aveva immessa alla fine? :stordita:

No, ci eri arrivato subito :D
Bastava solo considerare il range giusto.

Qualcuno l'ha usata davvero...altrochè :eek: :asd:

Alchè ho cercato invano nel CED una "luser bat" per punire il marrano :asd:

The_ouroboros
01-10-2012, 11:34
No, ci eri arrivato subito :D
Bastava solo considerare il range giusto.

Qualcuno l'ha usata davvero...altrochè :eek: :asd:

Alchè ho cercato invano nel CED una "luser bat" per punire il marrano :asd:

la prossima volta (spero non arrivi) non mi fregherà più la acl (che se fosse numbered ci scommetto sarebbe 666)

Io ne terrei una a portata di mano just in case

Wolfhwk
01-10-2012, 11:40
Comunque molto bravo, hai capito/intuito una acl che mi ha fatto impazzire non poco. :)

Per il resto, portarsi sempre la luser bat (il LART) per punire i manigoldi. :asd:

The_ouroboros
01-10-2012, 11:45
Comunque molto bravo, hai capito/intuito una acl che mi ha fatto impazzire non poco. :)

Per il resto, portarsi sempre la luser bat (il LART) per punire i manigoldi. :asd:

vuol dire che non sono braccia rubate all'agricoltura :cool:
A parte quello, adoro imparare da casi reali e strambi per me è molto più utile dei casi standard... ovviamente anche quelli servono)

Wolfhwk
01-10-2012, 13:43
Stai attento alle extended acl.

C'è la possibilità di avere i seguenti protocolli: ip, icmp, tcp, udp.

Quando lavori sul ping usa icmp. E' tutto "ip" tranne i casi in cui lavori al livello 4 (le porte tcp-udp).

The_ouroboros
01-10-2012, 13:49
Stai attento alle extended acl.

C'è la possibilità di avere i seguenti protocolli: ip, icmp, tcp, udp.

Quando lavori sul ping usa icmp. E' tutto "ip" tranne i casi in cui lavori al livello 4 (le porte tcp-udp).

lavorare su ping... interessanti prospettive :eek:

Wolfhwk
01-10-2012, 13:55
Sì, tipo access-list 101 deny icmp host 192.168.1.2 172.16.0.0 0.0.255.255

Se pingo (come 192.168.1.2) un pc (echo request) dentro la 172.16.0.0 /16 mi fallisce.

The_ouroboros
01-10-2012, 14:10
ottimo esempio del concetto che wildcard e subnet mask sono una il riflesso dell'altra :D
Con la tua acl "nascondo" una subnet :fagiano:

Wolfhwk
01-10-2012, 14:46
Altra cosa a cui prestare attenzione.

Le acl standard vanno messe il più possibile vicino alla destinazione, mentre viceversa per le extended.
Attenzione anche all' "in" e "out" (riferimento a ip access-group <nome o num acl> in/out). Con "in" i pacchetti negati non vengono esaminati dal protocollo di routing, con "out" invece sì.

The_ouroboros
01-10-2012, 14:49
Altra cosa a cui prestare attenzione.

Le acl standard vanno messe il più possibile vicino alla destinazione, mentre viceversa per le extended.
Attenzione anche all' "in" e "out" (riferimento a ip access-group <nome o num acl> in/out). Con "in" i pacchetti negati non vengono esaminati dal protocollo di routing, con "out" invece sì.


"in" li droppa subito quindi, ok

Wolfhwk
02-10-2012, 07:52
Come procede?

The_ouroboros
02-10-2012, 14:17
ho forse trovato una lavoro come sis admin/ net admin per una piccola azienda... stamani ho dato una ripassata a tcpdump e wpa_supplicant.
Sapevo che la cli (cash line interface, alla lammle) era molto + utile della GUI ma nn ricordavo quanto.
Oggi pomeriggio, do una rilettura ai processi arp e dns(che sono molto simili alla fine... fisico->ip ip->nome) e a come viaggiano frame e pacchetti

Wolfhwk
02-10-2012, 15:02
Eccellente.
Prima dell' esame ti farò un po' di domande per controllare che i concetti siano chiari e ben assimilati.

The_ouroboros
02-10-2012, 15:13
Eccellente.
Prima dell' esame ti farò un po' di domande per controllare che i concetti siano chiari e ben assimilati.

a natale ti mando una bottiglia di vino se l'esame mi va bene (o cmq una Corona Extra come ringraziamenti) :stordita: :stordita:

Intanto, approfitto ancora della tua gentilezza.. Non avresti qualche info "di prima mano" sulle VPN ?

Wolfhwk
02-10-2012, 16:09
:D

Fammi sapere quando hai fissato per l'esame. Che poi devo scriverti tutta una serie di raccomandazioni al fine di passarlo.

Ti dico solo che io l'ho fallito 2 volte. Sono stato troppo disattento, mi sono fatto prendere dal panico per il tempo e ho fatto poco troubleshooting.

Per quanto riguarda le VPN sono poco informato. Però prevedo di studiare per la ccna security nel 2013.

The_ouroboros
02-10-2012, 16:34
:D

Fammi sapere quando hai fissato per l'esame. Che poi devo scriverti tutta una serie di raccomandazioni al fine di passarlo.

Ti dico solo che io l'ho fallito 2 volte. Sono stato troppo disattento, mi sono fatto prendere dal panico per il tempo e ho fatto poco troubleshooting.

Per quanto riguarda le VPN sono poco informato. Però prevedo di studiare per la ccna security nel 2013.

Mi sono fissato la prima settimana di gennaio ( lo so che è lontanina ma prima volevo trovarmi i soldi ed esser pronto bene).
Al momento, dopo un mese, ritengo di essere ad un livello relativamente buono :stordita:

Se poi il lavoro va in porto mi faccio anche un po di esperienza :D

Troubleshooting, croce e delizia... in effetti un po di tempo lo dedicherò ai sh/debug :)

Wolfhwk
02-10-2012, 16:46
Allora appena sei pronto ti comincerò a fare un po' di domande da qui a gennaio. :D

Però devi rispondere senza guardare il libro o internet.

The_ouroboros
02-10-2012, 17:01
Allora appena sei pronto ti comincerò a fare un po' di domande da qui a gennaio. :D

Però devi rispondere senza guardare il libro o internet.

ok.
La cosa mi sconfinfera (che parolone... mi piace troppo :D )

Wolfhwk
02-10-2012, 17:04
:asd:

The_ouroboros
02-10-2012, 17:23
poi magari nel 3d mettiamo qualche tabellina o magari qualche riassunto dei giochini(trova la subnet, acchiappa la manual summary, io te e le VLSM) per gli altri utenti che sano magari interessati :D

Wolfhwk
02-10-2012, 17:30
Bravo. Proceed! :O

Ah, lo noto solo ora... Ciao, collega linuxaro :cincin:

The_ouroboros
02-10-2012, 18:23
Bravo. Proceed! :O

Ah, lo noto solo ora... Ciao, collega linuxaro :cincin:


Domattina butto giù qualche appunto che poi magari espandiamo, ok?

P.S: linuxaro dal 2003 ;)

Wolfhwk
02-10-2012, 21:39
Ok.

Wolfhwk
03-10-2012, 07:46
Ecco qui una serie di domande e relative spiegazioni.

Domanda 1.

Come si ottiene il formato cidr es. /12, /28, /32 etc?


Osservare che /8 corrisponde a 8 "1".

11111111.00000000.00000000.00000000

255.0.0.0

8 bit a "1" = /8

Gli "1" li troverò sulla sinistra e gli "0" sulla destra.

es. 11111111.10000000.00000000.00000000 OK

11111111.00000000.00000000.00000000 OK

11111111.01000000.00000000.00000000 ERRORE


Quindi /24 sono 24 bit "1" e quindi 3x8 = 24

es. 11111111.11111111.11111111.00000000


Ovviamente in tutto sono 8x4 = 32 bit


Quindi a mente mi trovo un /26.

Penso a /24 (3x8) e aggiungo 2

Dunque 1111111.11111111.11111111.11000000


Se ho un /19

Penso a /16 (2x8) e aggiungo 3

11111111.11111111.11100000.00000000

Wolfhwk
03-10-2012, 07:47
Domanda 2.

Quali sono le subnet di 10.0.0.0 /29?

Prima di tutto è necessario utilizzare la memoria per imparare questi numerie la loro sequenza:

128 -> 192 -> 224 -> 240 ------------------------------ -> 248 -> 252 -> 254 -> 255

Meglio ricordarsi 240 e 248 perché sono proprio in mezzo e rende più rapido il calcolo.

---------------------------------

Perfetto, dopo questa premessa passo con l'identificazione della classe ip

10.0.0.0 classe A quindi 11111111.00000000.00000000.00000000

La notazione cidr è /29 e dunque facciamo 3x8 = 24 + 5 ------il quinto bit a partire da sinistra è 248 (ricordatevi del quarto, il 240, secondo come fatto vedere sopra)

Banale insomma, infatti /29 è 11111111.11111111.11111111.11111000

Adesso sappiamo che 10.0.0.0 255.255.255.248

Facciamo velocemente a mente 256-248 = 8 e teniamo conto di 256-255=1 (operazione semplice no? Altrimenti imparare a memoria :asd: )

Quindi ip di classe A e block size 8.

Ecco gli esempi:

subnet id 10.0.0.0
Primo host 10.0.0.1
Ultimo host 10.0.0.6
Broadcast 10.0.0.7

subnet id 10.0.0.8
Primo host 10.0.0.9
Ultimo host 10.0.0.14
Broadcast 10.0.0.15

..................................................
..................................................

subnet id 10.0.1.0
Primo host 10.0.1.1
Ultimo host 10.0.1.6
Broadcast 10.0.1.7

..................................................
................................................


subnet id 10.1.255.0
Primo host 10.1.255.1
Ultimo host 10.1.255.6
Broadcast 10.1.255.7

..................................................
..................................................

subnet id 10.255.255.248
Primo host 10.255.255.249
Ultimo host 10.255.255.254
Broadcast 10.255.255.255

Wolfhwk
03-10-2012, 07:48
Domanda 3.

Ho bisogno di 500 subnets con almeno 100 host/subnet.


Bene, qui entrano in gioco le potenze del due.

2^10= 1024 (numero di riferimento)

Quindi dato che nelle potenze di due si raddoppia, la metà di 1024 è 512, dunque 2^9. (9 bit a "1")

100 host, direi di utilizzare 2^7=128 (7 bit a "0")

Quindi prendiamo la classe A per esempio : 8 + 9 + 7 = 24

32-24= 8 rimasti

Ok ci potrebbe stare...

Ricordo che network + subnet + host :

> 32 ---------------------- INVALID
= 32 ---------------------- 1 subnet mask
< 32 ---------------------- subnet mask multiple

Potremmo anche provare a questo punto la classe B per evitare lo sbattimento di cercare il range delle subnet mask.

Quindi avremo 2x8=16 + 9 (di subnet) + 7 (di host)

Dunque 11111111.11111111.11111111.10000000

Quindi in cidr è un /25

Per avere 500 subnets e 100 host/subnet basta avere 172.16.0.0/25 (128)


Infatti 16 + 9 + 7 = 32 ovvero 1 subnet mask


------------------------------------------------------------

Proviamo invece con classe A.

Allora eravamo a 8 + 9 + 7 < 32

Dunque 11111111.11111111.10000000.00000000

Quante mask potremmo usare? Tante

11111111.11111111.10000000.00000000
11111111.11111111.11111111.10000000 (lascio i soliti 7 bit per gli host, dato che 2^7=128)

Quindi contiamo le mask: /17 -> /18 -> /19 -> /20 -> /21 -> /22 -> /23 -> /24 -> /25



Abbiamo delle scelte da fare in questo caso:

Voglio più subnet o più host?

Con /17 ho 2^17= 131072 subnets e 2^15-2= 32766 hosts (-2 perché tolgo subnet id e broadcast)

Con /25 ho 2^25= 33554432 subnets e 2^7-2 = 126 hosts

Wolfhwk
03-10-2012, 07:49
Domanda 4.

172.16.10.33 /27

Trovami il subnet id e il broadcast.




Allora, classe B 172.16.0.0 (16 bit a "1") e /27 (3x8 =24 + 3) è 224.

256-224= 32

Quarto ottetto interessante.


Partiamo da 0 di 32 in 32

subnet id 172.16.10.0

subnet id 172.16.10.32



Trovato!!!!

Quindi 172.16.10.33 ha come subnet id 172.16.10.32 e come broadcast 172.16.10.63


172.16.10.64 è il prossimo subnet id.

The_ouroboros
03-10-2012, 08:06
Cominciamo una piccola serie di trucchi utili per risolvere velocemente alcuni problemi che possono comparire
nella preparazione alla CCNA (e, soprattutto, nella vita reale [vedi i post sopra]).
I due "giochi" si chiamano

1) trova la subnet
2) acchiappa la manual summary
[che, volendo, si può anche declinare in 3) due cuori e una VLSM]

Prima di descrivere i giochi, diciamo due parole preliminari sulle regole (diamo un po' i numeri)

[Le potenze di due]

Importantissimo, e non solo per i nostri giochi, è sapere le potenze di 2


2^ 0 = 1
2^ 1 = 2
2^ 2 = 4
2^ 3 = 8
2^ 4 = 16
2^ 5 = 32
2^ 6 = 64
2^ 7 = 128
2^ 8 = 256
2^ 9 = 512
2^ 10 = 1024
2^ 11 = 2048
2^ 12 = 4096
2^ 13 = 8192
2^ 14 = 16384

[Contare per sedici]

Altri numeri importanti da conoscere sono i multipli di 16


16 x 0 = 0
16 x 1 = 16
16 x 2 = 32
16 x 3 = 48
16 x 4 = 64
16 x 5 = 80
16 x 6 = 96
16 x 7 = 112
16 x 8 = 128
16 x 9 = 144
16 x 10 = 160
16 x 11 = 176
16 x 12 = 192
16 x 13 = 208
16 x 14 = 224
16 x 15 = 240
16 x 16 = 256



[I block size]

Altri numeri utili sono i block size:


128
64
32
16
8
4
2

[Valori per la mask]

E infine gli ultimi valori importanti:

128
192
224
240
248
252
254
255

Noterete, ad una seconda lettura, che non sono del tutto scollegati tra loro (hint: potenze di 2)

The_ouroboros
03-10-2012, 08:10
Ricordiamo inoltre che RIPv1 non supporta il subnetting classless* mentre RIPv2, EIGRP, OSPF sì.


* Classless = altre mask oltre /8, /16, /24. E' alla base della manual summary e delle VLSM.

Wolfhwk
03-10-2012, 10:34
Geniale il fatto di renderlo come un gioco. Non esiste tecnica migliore per imparare.

The_ouroboros
03-10-2012, 10:42
Geniale il fatto di renderlo come un gioco. Non esiste tecnica migliore per imparare.

ci provo :D
Oggi pome butto giu un seguito e qualche esempio.
In caso mi correggi :stordita:

P.S: sia semprel lodato CTRL-SHIFT-6 (detto da un ateo :sofico: )

Wolfhwk
03-10-2012, 10:45
Yes.

Crtl-Shift-6 e poi x. :sofico:

Quando avrai a disposizione un router reale, studiati la connessione via ssh con le chiavi pubblica/privata. Nel ccna non importa, ma per lavoro è essenziale.

The_ouroboros
03-10-2012, 10:52
Yes.

Crtl-Shift-6 e poi x. :sofico:

Quando avrai a disposizione un router reale, studiati la connessione via ssh con le chiavi pubblica/privata. Nel ccna non importa, ma per lavoro è essenziale.

ho sul mio tavolino un 2621 da una settimana e ssh(e telnet cassato via acl) operante :D

Wolfhwk
03-10-2012, 10:58
Excellent.

Sarebbe interessante se facessi una guida di come configurare il tutto (compresa la connessione da client linux).

The_ouroboros
03-10-2012, 11:07
Excellent.

Sarebbe interessante se facessi una guida di come configurare il tutto (compresa la connessione da client linux).

mmm... interessante... quasi quasi :stordita:

P.S: cmq uso putty (e minicom per la console [con cavo rollato rj45 a rs232 e convertitore rs232-usb])

Wolfhwk
03-10-2012, 11:20
Vai vai tranquillo.

The_ouroboros
03-10-2012, 11:21
Guida Linux per connettersi a devices Cisco (http://mynewroadtolife.blogspot.it/2012/10/minicom-come-connettersi-device-cisco.html)

Wolfhwk
03-10-2012, 11:28
Per minicom ok. Magari forse era meglio riportare la cosa per intero qui con riferimento al link. :)

The_ouroboros
03-10-2012, 11:53
Per minicom ok. Magari forse era meglio riportare la cosa per intero qui con riferimento al link. :)

lo metto in prima pagina per bene :)

Wolfhwk
03-10-2012, 13:36
Ottimo.

The_ouroboros
03-10-2012, 13:39
La prima pagina è un poco modificata ora

Inviato dal mio YP-G50 con Tapatalk 2

The_ouroboros
04-10-2012, 08:26
domanda magari fuori CCNA.
Come si redistribbuisce OSPF su 2 AS diversi? :fagiano:

Wolfhwk
04-10-2012, 10:16
Ti riferisci alla redistribuzione di route tra due domini di routing (ad esempio eigrp e ospf o rip) tramite un ASBR?
Nel senso "take routes from" <altro protocollo di routing>?

The_ouroboros
04-10-2012, 10:23
Si. Diciamo che è una curiosità che mi è venuta leggendo in giro.

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 10:30
Ehm, ok. Però la spiegazione sarà un poco criptica, dato che per la comprensione completa si deve approfondire l' ospf (tanta roba).

Bene, lo scrivo con calma e posto.

The_ouroboros
04-10-2012, 10:34
Ehm, ok. Però la spiegazione sarà un poco criptica, dato che per la comprensione completa si deve approfondire l' ospf (tanta roba).

Bene, lo scrivo con calma e posto.

Grazie

Almeno qualcosa la capiro spero. E cmq almeno so cosa mi aspetta in futuro :-)

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 11:43
Bomba in arrivo :asd:

Allora sostanzialmente la redistribuzione si fa per poter instradare del traffico in ASs che sono sotto diversi domini di routing.

Mettiamo il caso si abbia un ASBR router tra due as: eigrp e ospf.

Questo router dovrà prendere le route da eigrp con adeguata metrica e consegnarle all' ospf. Ovviamente anche viceversa.
Nel caso di ospf distinguiamo tra route esterne di tipo 1 e 2.
Il tipo 2 ha una metrica di default (20) per i link-state advertisements type 5 (route esterne senza nssa area e senza considerare il bgp o altro processo ospf in altro AS) mentre il tipo 1 somma la metrica di default a quella che serve per raggiungere internamente o esternamente un ASBR (esternamente nel caso in cui debba passare da un ABR, quindi cambiare area). Dunque un router ospf interno vede nel suo database questi LSA type 5 (identificati dalla subnet con mask e metrica, dal RID dell' ASBR) e usa una logica "distance vector" per raggiungerle( dato che l'spf viene processato solo dentro l'area sui LSA tipo 1 e 2 con logica link-state [il 2 è per reti con DR e BDR]). Attenzione, quel tipo di logica permette di fare le manual summary e route filter sui border router.
ASBR si trova quindi con le route di tutti da distribuire adeguatamente (avrà due protocolli di routing che lavorano in contemporanea con i loro database topologici e una tabella di routing che raccoglie ovviamente i percorsi migliori).

Il comando è il seguente sotto ospf:

router ospf 2
redistribute eigrp 1 subnets

Applica la external route tipo 2 con costo di default 20.

Sotto eigrp:

router eigrp 1
redistribute ospf 2 metric 1000 200 255 1 1500

Tradotto: prendi le route dal processo ospf 2 e applicagli la metrica eigrp bandwidth (1000), cumulative delay (200), reliability (255), load (1), mtu (1500).

Quando ti trovi invece con più ASs da redistribuire la complessità aumenta parecchio (i domain loop).


E' abbastanza capibile?

The_ouroboros
04-10-2012, 11:53
Me lo leggo con calma e poi ti dico.
Grazie cmq :-)

Inviato dal mio YP-G50 con Tapatalk 2

The_ouroboros
04-10-2012, 15:13
Qualcosa l'ho capita. Interessante cmq. Come pensavo :)

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 15:21
La redistribuzione è argomento della ccnp e almeno nel libro di Wendell è solo dopo le due sezioni che trattano eigrp e ospf.

Per farti capire meglio, nella ccna i due suddetti protocolli di routing vengono trattati piuttosto superficialmente (e deve essere così, altrimenti non sarebbe "associate").
Devo dire però che nel tempo la ccna è diventata più complessa e difficile, fino addirittura a considerare come certificazione da apprendista la nuova ccent (icnd1).

The_ouroboros
04-10-2012, 15:29
Quindi é a un buon livello alla fine.. =)
Questa era solo una curiosità x il momento cmq...

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 15:35
Anzi a dire il vero, la ccna è già troppa roba per un associato. Questo deve essere il ragionamento che hanno fatto quando hanno creato la ccent. :D

The_ouroboros
04-10-2012, 15:43
E io che mi imparo pure cose al dì là.. :p

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 15:45
Meglio, meglio :cool:

Molti dicono che le parti più complicate riguardano stp e trunking.

The_ouroboros
04-10-2012, 15:51
Il secondo mi sembra relativamente facile..

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 16:04
Domanda test.

Ho un duplex mismatch sullo switch. Voglio un comando che mi dia il resoconto breve di tutte le interfacce.

The_ouroboros
04-10-2012, 16:16
La butto lì..
Una cosa tipo

sh int | include dupex

Inviato dal mio YP-G50 con Tapatalk 2

The_ouroboros
04-10-2012, 16:18
Sarebbe duplex.. stupido cell


Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 16:22
Non va bene perchè con "sh int" devo specificare l' interfaccia e non mi fa vedere un riepilogo.
Immagina uno switch da 48 porte, ci stai una mattinata.

Utilissimo invece è il seguente comando:

sh interfaces status

Mostra questo:

Port Name Status Vlan Duplex Speed Type


Fa0/1 notconnect 1 auto auto 10/100BaseTX
Fa0/2 notconnect 1 auto auto 10/100BaseTX
Fa0/3 notconnect 1 auto auto 10/100BaseTX
Fa0/4 connected 1 a-full a-100 10/100BaseTX
Fa0/5 connected 1 a-full a-100 10/100BaseTX

etc....



a- vuol dire autonegotiation. Senza "a" l'impostazione è manuale.

full è duplex, 100 è speed.

ok? :)

The_ouroboros
04-10-2012, 16:25
Pratico... Ma mi da lo stato dì tutte le interfacce?

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 16:26
Yes.

Wolfhwk
04-10-2012, 16:28
Domanda test.

OSPF.

Due router non riescono a diventare neighbors per problemi di autenticazione.
Che comando devo usare per la verifica?

The_ouroboros
04-10-2012, 16:32
debug ip ospf adj

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 16:33
Eccellente.

Infatti:

R1-2503# debug ip ospf adj
00:51:23: OSPF: Rcv pkt from 192.16.64.2, Serial0 : Mismatch
Authentication type.

R1-2503# debug ip ospf adj
00:51:33: OSPF: Rcv pkt from 192.16.64.2, Serial0 : Mismatch
Authentication Key - Clear Text

The_ouroboros
04-10-2012, 16:35
grazie abba

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 16:36
Domanda test.

EIGRP

Per i neighbors, i timer hello-interval e hold-time devono essere uguali su entrambi i router come con ospf?

The_ouroboros
04-10-2012, 16:38
Si

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 16:41
No. Un neighbor eigrp può adattarsi ad un altro con timer diversi senza compromettere la neighborship.

The_ouroboros
04-10-2012, 16:47
Ok. Incamerato.
Stasera mi devi vedere bene le parti più inusuali di questi protocolli mi sa.. :(

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 17:01
Nessun problema. L' importante è imparare. ;)

The_ouroboros
04-10-2012, 17:04
Imparo più dal errore che dall' esattezza :-)
Molto Confucio lo so..

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 17:12
Domanda test.

STP

Come faccio a sapere se un mac address è più grande di un altro?
Riferimento a Lammle.

The_ouroboros
04-10-2012, 17:32
Confrontando gli esadecimali dei Mac da sinistra a destra?

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
04-10-2012, 17:34
Molto bravissimo.

Wolfhwk
04-10-2012, 17:36
Domanda test.

EIGRP

In quale situazione è essenziale usare "no auto-summary"?

The_ouroboros
04-10-2012, 17:37
Network discontinui

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
05-10-2012, 07:40
Meglio, reti discontigue.


Domanda test.

Come viene composto un indirizzo ipv6 con autoconfiguration (eui-64)?
Invece la procedura per ottenere il prefisso (la subnet)?

The_ouroboros
05-10-2012, 09:30
Meglio, reti discontigue.


Domanda test.

Come viene composto un indirizzo ipv6 con autoconfiguration (eui-64)?
Invece la procedura per ottenere il prefisso (la subnet)?

Indirizzi da 2000::/3 a E000::/3 sono per eui-64.
I lower 64bits sono derivati dal MAC( 0xFFFE messo tra i 3 bytes superiori e i 3 bytes inferiori)
La subnet viene data con un cidr (es. /64)

Wolfhwk
05-10-2012, 09:36
Uhm, non è completo.

Indizio per la subnet:

Router solicitation message.

Indizio per l' ipv6:

Oltre a FFFE in mezzo al mac address, manca qualcosa...

The_ouroboros
05-10-2012, 09:38
Uhm, non è completo.

Indizio per la subnet:

Router solicitation message.

Indizio per l' ipv6:

Oltre a FFFE in mezzo al mac address, manca qualcosa...


Il Mcquerry non è molto preciso in questo punto e il Lammle all'incirca un pelo di più :stordita:
Mo provo a vedere da un merge cosa ci cavo..

Wolfhwk
05-10-2012, 09:39
Possono sembrare domande su particolari, in realtà sono mirate nell' interesse della ccna e del lavoro. E' per fare delle solide fondamenta come detto nel post di qualche pagina indietro.

The_ouroboros
05-10-2012, 09:40
Oltre a FFFE in mezzo al mac address, manca qualcosa...

Inverto il bit 7 [universal/local (U/L)] nella parte OUI per farlo considerare un Pv6 interface ID

Wolfhwk
05-10-2012, 09:40
Il Mcquerry non è molto preciso in questo punto e il Lammle all'incirca un pelo di più :stordita:
Mo provo a vedere da un merge cosa ci cavo..

Ahi ahi. :(

E' per questo che consiglio Wendell. :D

Wolfhwk
05-10-2012, 09:41
Inverto il bit 7 [universal/local (U/L)] nella parte OUI per farlo considerare un Pv6 interface ID

Lo inverto a 1 o 0?
Partendo da dove?

The_ouroboros
05-10-2012, 09:43
Se uso

ipv6 address 2001:db8::/64 eui-64

Vedo che la sottorete è 2001:DB8::/64 [EUI/TEN] con

Router(config-if)# do show ipv6 interface f0/0
FastEthernet0/0 is up, line protocol is down
IPv6 is enabled, link-local address is FE80::212:7FFF:FEEB:6B40 [TEN]
No Virtual link-local address(es):
Global unicast address(es):
2001:DB8::212:7FFF:FEEB:6B40, subnet is 2001:DB8::/64 [EUI/TEN]
...

The_ouroboros
05-10-2012, 09:44
Lo inverto a 1 o 0?
Partendo da dove?

Partendo da sinistra lo porto a 1 (o a 0 se era 1)

Wolfhwk
05-10-2012, 09:45
Se uso

ipv6 address 2001:db8::/64 eui-64

Vedo che la sottorete è 2001:DB8::/64 [EUI/TEN] con

Router(config-if)# do show ipv6 interface f0/0
FastEthernet0/0 is up, line protocol is down
IPv6 is enabled, link-local address is FE80::212:7FFF:FEEB:6B40 [TEN]
No Virtual link-local address(es):
Global unicast address(es):
2001:DB8::212:7FFF:FEEB:6B40, subnet is 2001:DB8::/64 [EUI/TEN]
...



La domanda è: Come fa un host a sapere che subnet viene utilizzata?

Wolfhwk
05-10-2012, 09:45
Partendo da sinistra lo porto a 1

Benissimo.

Wolfhwk
05-10-2012, 09:47
Partendo da sinistra lo porto a 1 (o a 0 se era 1)

No, deve essere a 1.

The_ouroboros
05-10-2012, 09:47
La domanda è: Come fa un host a sapere che subnet viene utilizzata?
la parte da /48 a /64 è la subnet prefix seguita dall' interface id composta con il MAC come abbiamo detto.
Questo sono riuscito ad estrapolare dalla poco roba che ci sta scritta :cry:

The_ouroboros
05-10-2012, 09:50
No, deve essere a 1.

ok ho rivisto il perchè :D

Wolfhwk
05-10-2012, 09:54
la parte da /48 a /64 è la subnet prefix seguita dall' interface id composta con il MAC come abbiamo detto.
Questo sono riuscito ad estrapolare dalla poco roba che ci sta scritta :cry:

Quoto la buona wiki:

Allora dice che:

IPv6 hosts can configure themselves automatically when connected to a routed IPv6 network using the Neighbor Discovery Protocol via Internet Control Message Protocol version 6 (ICMPv6) router discovery messages. When first connected to a network, a host sends a link-local router solicitation multicast request for its configuration parameters; if configured suitably, routers respond to such a request with a router advertisement packet that contains network-layer configuration parameters.

E io aggiungo che i router mandano un messaggio RA (multicast router advertisement) con la subnet a tutti i nodi della rete.

Wolfhwk
05-10-2012, 09:57
Domanda test.


ipv6

Che tipo di indirizzi usano i routing protocols per propagare gli update?

The_ouroboros
05-10-2012, 09:57
Questo si trova sul wiki..? :fagiano:

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
05-10-2012, 10:01
Questo si trova sul wiki..? :fagiano:

Inviato dal mio YP-G50 con Tapatalk 2

Cosa? L' ultima domanda?

Wolfhwk
05-10-2012, 10:13
Vuoi che dia la soluzione? :stordita:

The_ouroboros
05-10-2012, 10:20
Ho riletto il Lammle e dice solo quello che abbiamo già detto... :-o

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
05-10-2012, 10:22
Risposta:

Router(config-if)# do show ipv6 interface f0/0
FastEthernet0/0 is up, line protocol is down
IPv6 is enabled, link-local address is FE80::212:7FFF:FEEB:6B40
No Virtual link-local address(es):
Global unicast address(es):
...


Link-local.

Wolfhwk
05-10-2012, 10:25
Ho riletto il Lammle e dice solo quello che abbiamo già detto... :-o

Inviato dal mio YP-G50 con Tapatalk 2

Se per la ccnp mi compri il Lammle potrei dover rispolverare il LART (luser attitude readjustment tool)?! :asd:

Vediamo se ti fornisco io del materiale di qualità. Dammi solo un po' di tempo.

The_ouroboros
05-10-2012, 10:25
Non l'avevo gia' detto più sopra io? :stordita:

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
05-10-2012, 10:27
Non l'avevo gia' detto più sopra io? :stordita:

Inviato dal mio YP-G50 con Tapatalk 2

Ho quotato il tuo comando "do sh".

The_ouroboros
05-10-2012, 10:28
Risposta:




Link-local.

Ah ok

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
05-10-2012, 10:29
L'avevo scritta qualche Post sopra io... :P

Inviato dal mio YP-G50 con Tapatalk 2

Trovalo. :O

The_ouroboros
05-10-2012, 10:30
Cmq ipv6 su lammle o mcquerry e spiegato troppo sommaria mente imho...

Inviato dal mio YP-G50 con Tapatalk 2

The_ouroboros
05-10-2012, 10:31
Se uso

ipv6 address 2001:db8::/64 eui-64

Vedo che la sottorete è 2001:DB8::/64 [EUI/TEN] con

Router(config-if)# do show ipv6 interface f0/0
FastEthernet0/0 is up, line protocol is down
IPv6 is enabled, link-local address is FE80::212:7FFF:FEEB:6B40 [TEN]
No Virtual link-local address(es):
Global unicast address(es):
2001:DB8::212:7FFF:FEEB:6B40, subnet is 2001:DB8::/64 [EUI/TEN]
...


Eccilo

Inviato dal mio YP-G50 con Tapatalk 2

Wolfhwk
05-10-2012, 10:32
Rif. a Lammle e all' altro.


Infatti è inaccettabile. :banned:

pvt in arrivo.

Wolfhwk
05-10-2012, 10:32
Eccilo

Inviato dal mio YP-G50 con Tapatalk 2

Ok, ma non risponde alla domanda. :D

The_ouroboros
05-10-2012, 13:54
Qui (http://www.cisco.com/web/about/ac123/ac147/archived_issues/ipj_7-2/ipv6_autoconfig.html) ho trovato qualche info in più.

Wolfhwk
05-10-2012, 14:04
Il sito cisco non fa distinzione tra le varie categorie di certificati...
Conoscenze sparse e/o troppo specialistiche in quella maniera, senza un adeguato background, possono causare ulteriore confusione.
Se guardi la guida ccnp di Wendell, ha ancora più info del suddetto sito. :D

The_ouroboros
05-10-2012, 14:15
anche quello è vero. :stordita:
Sul forum learning di Cisco (https://supportforums.cisco.com/docs/DOC-17232) info un po più terra terra cmq

The_ouroboros
05-10-2012, 14:22
prendendo ad esempio: 2001:db8:abcd:3f0d::1/64
quindi

2001:db8 è costante
abcd sottorete
3f0d::1 i vari host

O sbaglio (molto probabilmente sì)

Wolfhwk
05-10-2012, 14:46
prendendo ad esempio: 2001:db8:abcd:3f0d::1/64
quindi

2001:db8 è costante
abcd sottorete
3f0d::1 i vari host

O sbaglio (molto probabilmente sì)

/64 delimita il prefisso (2001:db8:abcd:3f0d [16x4 =64]). Il resto è host (altri 64 per includere mac address + FFFE).
2000::/3 prefisso dei global unicast.

Quindi abbiamo il site prefix 48 bits + subnet 16 bits + 64 host bits

The_ouroboros
05-10-2012, 14:50
ora è meglio.
Qualche altro esempio estemporaneo che ti viene in mente?

Wolfhwk
05-10-2012, 14:58
Uhm, leggiti la sezione ipv6 dell' ebook. Sarà tutto più chiaro.

The_ouroboros
05-10-2012, 14:59
Uhm, leggiti la sezione ipv6 dell' ebook. Sarà tutto più chiaro.

ok. Ho solo avuto qualche problema per leggerlo. Ma ora è tutto risolto ;)

Wolfhwk
05-10-2012, 15:00
Guarda carino questo.

::1

:D

Wolfhwk
05-10-2012, 15:01
ok. Ho solo avuto qualche problema per leggerlo. Ma ora è tutto risolto ;)

Ottimo. Leggilo molto attentamente, vedrai che dopo sarà chiaro l' argomento.

The_ouroboros
05-10-2012, 15:05
Guarda carino questo.

::1

:D

loopback(uno solo, non come ipv4)? è :: mi pare sia il vecchio 0.0.0.0

Wolfhwk
05-10-2012, 15:07
127.0.0.1 = ::1

The_ouroboros
05-10-2012, 16:35
quindi (ad esempio)



2340::/12 viene dato dall'ICANN all'ente regionale [2^116 indirizzi]
2340:1111::/32 viene dato dall'ente continentale all'ISP[2^96 indirizzi]
2340:1111:AAAA::/48 viene dato dall'ISP ad un customer[2^80 indirizzi]

The_ouroboros
05-10-2012, 16:41
dopo sopra ho che i successivi 16bits sono la subnet e i restanti 64 l'host(con gli accorgimenti di cui parlavam più sopra con il MAC).

Fin qui ci sono?

Wolfhwk
05-10-2012, 16:43
Sì, ok.

The_ouroboros
05-10-2012, 16:46
e poi da li comincio a lavorarmi


2340:1111:AAAA:001::/64
2340:1111:AAAA:002::/64
2340:1111:AAAA:003::/64
..


con /64 che mi dice la subnet ed è importantissimo :stordita:

The_ouroboros
05-10-2012, 16:47
e da li mi "gioco" l'ultimo quartetto

Wolfhwk
05-10-2012, 16:49
Ok.

The_ouroboros
05-10-2012, 16:59
Just for the record: FF00::/8 prefiso per i multicast Ipv6.

Wolfhwk
05-10-2012, 17:04
E i multicast che usano i routing protocol per gli update?

The_ouroboros
05-10-2012, 17:05
E i multicast che usano i routing protocol per gli update?

mi sembra di ricordare che ricalchino i 224.0.0.x dell'ipv4

Wolfhwk
05-10-2012, 17:06
Fammi l'esempio di eigrp.

The_ouroboros
05-10-2012, 17:09
224.0.0.10 => ff02::A (dove A=10 in base 16)

The_ouroboros
05-10-2012, 17:15
FF02::2 riservato ai soli Ipv6 routers
FF02::1 all host in una determinata subnet

Wolfhwk
05-10-2012, 17:16
Ok. I multicast "link-local scope" sono tutti con FF02::/16

Wolfhwk
05-10-2012, 17:18
FF02::2 riservato ai soli Ipv6 routers
FF02::1 all host in un determinato link

Un determinato link?

The_ouroboros
05-10-2012, 17:18
prima o poi si dovrà fare un po di ordine.
Cmq mi sembra che le info scambiate siano interessanti e utili.
E, come plus, sto imparando l'ipv6 per chunks di info (siam tanti piccoli frammentin... :stordita: )

The_ouroboros
05-10-2012, 17:19
Un determinato link?

yup.
Così l'informazione mandata con RS viene "imparata" da tutti gli altri host sullo stesso segmento

Wolfhwk
05-10-2012, 17:20
yup.
Così l'informazione mandata con RS viene "imparata" da tutti gli altri host sullo stesso link.

Semmai subnet...

Wolfhwk
05-10-2012, 17:22
prima o poi si dovrà fare un po di ordine.
Cmq mi sembra che le info scambiate siano interessanti e utili.
E, come plus, sto imparando l'ipv6 per chunks di info (siam tanti piccoli frammentin... :stordita: )

Bene, bene. :)

Wolfhwk
05-10-2012, 17:23
yup.
Così l'informazione mandata con RS viene "imparata" da tutti gli altri host sullo stesso segmento

Come RS?

LART?

The_ouroboros
05-10-2012, 17:24
RA... stupido me :doh: