Torna indietro   Hardware Upgrade Forum > Networking e sicurezza > Networking > Networking in generale

Psychonauts 2: la psicologia incontra il gaming
Psychonauts 2: la psicologia incontra il gaming
Dopo anni di attesa e di infiniti posticipi, l'attesissimo titolo di Tim Schafer è finalmente disponibile. Ed è stato accolto a braccia aperte dalla community dei giocatori con una valutazione "Estremamente positiva" su Steam
Samsung Galaxy Watch4: è lui il miglior smartwatch per gli Android! La recensione
Samsung Galaxy Watch4: è lui il miglior smartwatch per gli Android! La recensione
Il mondo degli smartwatch è capitanato dagli Apple Watch che non mollano la presa del primo posto nelle vendite. Samsung però sa il fatto suo e il nuovo Galaxy Watch4 si conferma ancora la migliore alternativa al watch di Apple. Ecco il motivo nella nostra recensione. 
Un viaggio in Tesla dal nord alla Sicilia, senza Supercharger e spendendo 50 euro
Un viaggio in Tesla dal nord alla Sicilia, senza Supercharger e spendendo 50 euro
Percorrere l'Italia da nord a sud in 11 giorni, usando una Tesla Model 3 Long Range senza mai ricaricare ad un Supercharger? E' possibile, nonostante la diffusione delle soluzioni di ricarica pubbliche non così capillari come vorremmo. Ecco il racconto delle mie vacanze: 4.000km in elettrico
Tutti gli articoli Tutte le news

Vai al Forum
Rispondi
 
Strumenti
Old 22-07-2021, 18:36   #1
bilanciamist
Member
 
Iscritto dal: Jun 2007
Messaggi: 125
Wake on wan, router a cascata e magic packet

Ciao a tutti,
da circa un paio di settimane sto cercando di accendere il mio pc dal lavoro tramite wake on lan / wan.

Ho il mio router Fastweb che preferisco non toccare, a cui ho collegato in cascata un altro router Fastweb comprato apposta (un dga4131), rootato e a cui ho aggiunto tramite SSH un valore fisso nella ARP table. Tutto sembra funzionare, anche dopo ore, se invio il magic pocket da dentro la la lan (prima funzionava solo per pochi minuti dopo lo spegnimento del pc) ma non funziona da fuori della rete, nonostante abbia aperto le porte su entrambi i router. Sembra che il router principale non lasci passare il magic pocket fino al secondario.

Qualcuno sa se e come è risolvibile? Potrei scambiare i due router, ma preferirei evitarlo al momento. Li uso entrambi anche per aumentare il segnale WiFi.

Grazie
Alessandro
__________________
Pc assemblato Case Fractal Design Meshify C AMD Ryzen 7 2700x - Nvidia GTX 1070 - 32GB Ram Hyper X Predator 3200MHz cl16 - Windows 10 Pro 64 bit - 500GB SSD Sabrent Rocket

Portatile Sony Vaio VPCF12S1E/B - 16,4" - intel i7 740q 1,73GHz - 8 GB ram - 250GB SSD Samsung 860 Evo e 500 GB HDD 7200 rpm - Windows 10 Pro 64 bit
bilanciamist è offline   Rispondi citando il messaggio o parte di esso
Old 23-07-2021, 01:57   #2
rejavi
Member
 
Iscritto dal: Jun 2020
Messaggi: 119
Quote:
Originariamente inviato da rejavi Guarda i messaggi
  • compri un DGA4131 di fastweb su ebay a ~20 euro, gli fai root e puoi giocare su arp table a piacimento, lo usi come modem/router primario e risolvi il problema wol, il tuo attuale lo usi come semplice access point per aumentare la copertura,
il suggerimento di comprare il dga era per usarlo come primario, cosi' dovrebbe andare visto che sarebbe il router principale a gestire il magic packet come dovrebbe essere. detto questo se hai collegato il dga come secondario lan <--> lan con il primario questo fa si che il dga non funga piu' da router ma diventa semplice client con uno switch che fa passare il traffico senza regole, diventa quindi ininfluente che tu apra le porte o faccia forward da gui perche' quello riguarda il traffico wan che in questo caso hai smesso di usare perche' sei collegato in lan ed essendo traffico lan qualsiasi regola eventualmente imposti nella firewall viene ignorata (smette di passare dalla cpu del router). detto questo volendo puoi intervenire nella configurazione del dga e fare magheggi che openwrt ti permette sicuramente di fare (es. creare un interfaccia aggiuntiva per poi fare redirect sulla lan via iptables) ma ti stai solo complicando la vita e la rete per nulla.. puoi verificare tutto con tcpdump installandolo sul dga e capire che il magic packet arriva e non sa dove andare. detto questo (ultima volta promesso) non ti rimane che scambiare i due fastgate mettendo il dga (con modifica arp) come primario ed il secondo fastgate collegato lan <--> lan, oppure lasciare il tuo attuale fastgate come primario ma usare il dga (sempre con modicica arp) collegato lan <--> wan (porta 4 del dga) in questo modo avresti doppio nat (ricoda di cambiare ip lan del dga se fai cosi' ad 192.168.2.x per esempio) ma le regole che imposti da gui funzionerebbero, quindi devi aprire le porte ed impostare il forward ad il client finale.. quest'ultima opzione e' da provare mai fatto personalmente, quella di usare il dga come primario so' per esperienza personale che funziona..
rejavi è offline   Rispondi citando il messaggio o parte di esso
Old 23-07-2021, 07:29   #3
bilanciamist
Member
 
Iscritto dal: Jun 2007
Messaggi: 125
Grazie di nuovo,

si hai ragione, il tuo suggerimento era di metterlo come primario e mettere "l'originale" come secondario, ma volevo vedere se c'era un modo di usarli al contrario. L'idea di mettere quello rootato "lato Fastweb" non mi convince molto, anche cambiando il mac adress (che devo anche capire come fare), non vorrei che avessero qualcosa da ridire, o che attuassero un aggiornamento o un reboot a distanza cancellando il root. Per questo pensavo di tenerlo come ultima risorsa.
Inoltre stavo pensando di aggiungere la Ansuel Gui per vedere se riesco a modificare la password della rete ospiti (che ora è decisa in automatico dal router) e non vorrei che anche questa modifica saltasse all'occhio di Fastweb.

grazie per il suggerimento di tcpdump, devo vedere se riesco a capire come funziona.

Ho capito che il secondario funzioni come switch, ma se io mi collego al wifi del secondario (quindi dentro la lan) e gli mando un magic packet il sistema funziona, quindi vuol dire che non è un mero switch, ma la regola se la ricorda e la applica. Il problema penso sia il primario, se gli arriva il magic pocket con il mac adress del pc lui non sa a chi darlo (se non per pochi minuti dallo spegnimento), se il magic packet ha il mac adress del router secondario poi questo non sa cosa farci. Dovrei creare una regola che se arriva un magic packet al router secondario lui lo indirizzi al pc, ma qui stiamo complicando la cosa e non saprei come farlo.

Nel weekend faccio alcune prove, se proprio non funziona inverto i due router e vediamo.
__________________
Pc assemblato Case Fractal Design Meshify C AMD Ryzen 7 2700x - Nvidia GTX 1070 - 32GB Ram Hyper X Predator 3200MHz cl16 - Windows 10 Pro 64 bit - 500GB SSD Sabrent Rocket

Portatile Sony Vaio VPCF12S1E/B - 16,4" - intel i7 740q 1,73GHz - 8 GB ram - 250GB SSD Samsung 860 Evo e 500 GB HDD 7200 rpm - Windows 10 Pro 64 bit
bilanciamist è offline   Rispondi citando il messaggio o parte di esso
Old 23-07-2021, 08:09   #4
rejavi
Member
 
Iscritto dal: Jun 2020
Messaggi: 119
Quote:
Originariamente inviato da bilanciamist Guarda i messaggi
L'idea di mettere quello rootato "lato Fastweb" non mi convince molto, anche cambiando il mac adress (che devo anche capire come fare), non vorrei che avessero qualcosa da ridire, o che attuassero un aggiornamento o un reboot a distanza cancellando il root. Per questo pensavo di tenerlo come ultima risorsa.
se metti il dga come primario puoi anche non cambiare il mac, una volta collegato vai su registrazione.fastweb.it ed il nuovo mac address si associa (ti viene chiesto codice fiscale della persona che ha stipulato il contratto). per quanto riguarda perdere il root se disbiliti CWMP e blocchi telnet ed ssh da wan come da guida fastweb non ha piu' potere di fare nulla

Quote:
Inoltre stavo pensando di aggiungere la Ansuel Gui per vedere se riesco a modificare la password della rete ospiti (che ora è decisa in automatico dal router) e non vorrei che anche questa modifica saltasse all'occhio di Fastweb.
lo puoi fare modificando /etc/config/wireless, della gui ansuel non sono pratico..

Quote:
grazie per il suggerimento di tcpdump, devo vedere se riesco a capire come funziona.
e' l'unico strumento che hai per capire esattamente cosa sta' succedendo..

Quote:
Ho capito che il secondario funzioni come switch, ma se io mi collego al wifi del secondario (quindi dentro la lan) e gli mando un magic packet il sistema funziona, quindi vuol dire che non è un mero switch, ma la regola se la ricorda e la applica.
tu aggiungi un arp entry allo switch del dga e lui se la ricorda.. non e' un regola ma solo un informazione.. e' una cosa che puoi fare anche su switch manged.. cosa che e' diventata nel tuo caso.. edit: openwrt fa' bridge tra lan e wifi, quindi anche il wifi fa parte dello switch come una normale porta eth sul retro.

Quote:
Il problema penso sia il primario, se gli arriva il magic pocket con il mac adress del pc lui non sa a chi darlo (se non per pochi minuti dallo spegnimento), se il magic packet ha il mac adress del router secondario poi questo non sa cosa farci. Dovrei creare una regola che se arriva un magic packet al router secondario lui lo indirizzi al pc, ma qui stiamo complicando la cosa e non saprei come farlo.
puoi provare a mettere un regola in /etc/config/firewall ma non so dirti se funzioni.. potrebbe essere ignorata.. oppure usare comandi iptables direttamente per prova..

Codice:
config redirect
        option name 'wake'
        option target 'DNAT'
        option src 'lan'
        option src_dport '9' <-- non ricordo se porta 8 o 9
        option dest 'lan'
        option dest_ip '192.168.x.x' <-- ip da svegliare
        option dest_port '9'
Quote:
Nel weekend faccio alcune prove, se proprio non funziona inverto i due router e vediamo.
cmq finche' paghi la bolletta e non fai cose illegali su internet a fastweb proprio non gli frega nulla di che apparecchio usi per stabilire una connessione

edit: e cmq mettere il dga con openwrt (anche se un po modificata da tecnicolor) come router primario rimane la cosa migliore tecnicamente, e' la cosa giusta da fare per come devono essere fatte le reti e ti semplifica la vita

Ultima modifica di rejavi : 23-07-2021 alle 08:27. Motivo: lol + info
rejavi è offline   Rispondi citando il messaggio o parte di esso
Old 23-07-2021, 20:39   #5
bilanciamist
Member
 
Iscritto dal: Jun 2007
Messaggi: 125
mi sono accorto di aver saltato un pezzo di guida, ora recupero, ma devo dire che le cose si complicano. Ti ringrazio nuovamente per i tuoi consigli, ma mi mancano le basi per seguirli.

Per esempio la guida riporta: vi conviene modificare il file /etc/inittab rimuovendo il carattere '#' all'inizio dell'ultima riga ::askconsole:/bin/login

ma non ho idea di come fare, non essendo pratico di linux ne tanto meno di openwrt. Non so come navigare nei file ne come aprirli o leggerli per modificarli, e la guida non mi sembra lo spieghi. Hai qualche altra guida con le nozioni di base da consigliarmi? Ho cercato online ma se hai qualche indicazione...

Al momento vorrei concentrarmi su due cose, completare la guida sul root e cambiare la password del wifi ospiti, prima di invertire i due router, perchè le altre soluzioni che mi indichi penso che al momento siano fuori dalla mia portata. Visto che l'hai realizzata posso provare a inserire la regola nel firewall, ma di nuovo no so come fare (e il firewall è disinserito in entrambi i router)

Grazie
__________________
Pc assemblato Case Fractal Design Meshify C AMD Ryzen 7 2700x - Nvidia GTX 1070 - 32GB Ram Hyper X Predator 3200MHz cl16 - Windows 10 Pro 64 bit - 500GB SSD Sabrent Rocket

Portatile Sony Vaio VPCF12S1E/B - 16,4" - intel i7 740q 1,73GHz - 8 GB ram - 250GB SSD Samsung 860 Evo e 500 GB HDD 7200 rpm - Windows 10 Pro 64 bit
bilanciamist è offline   Rispondi citando il messaggio o parte di esso
Old 23-07-2021, 21:57   #6
bilanciamist
Member
 
Iscritto dal: Jun 2007
Messaggi: 125
Sono riuscito ad aprire i vari file e a modificarli con winscp. Ho completato la guida e ho modificato la password della rete ospiti. Ho anche aggiunto la regola al firewall del secondario, vediamo se cambia qualcosa.

Un'ultima cosa:

Quote:
Originariamente inviato da rejavi Guarda i messaggi
per quanto riguarda perdere il root se disbiliti CWMP e blocchi telnet ed ssh da wan come da guida
Ho cercato di capire i vari passaggi della guida, ma un paio ammetto di averli seguiti sulla fiducia. Mi sapresti indicare quale punto riguarda la procedura che descrivi? c'è un modo per controllare che effettivamente abbia disattivato il controllo remoto?

Di CWMP se ne parla nei commenti, ma non so se sono corretti.
__________________
Pc assemblato Case Fractal Design Meshify C AMD Ryzen 7 2700x - Nvidia GTX 1070 - 32GB Ram Hyper X Predator 3200MHz cl16 - Windows 10 Pro 64 bit - 500GB SSD Sabrent Rocket

Portatile Sony Vaio VPCF12S1E/B - 16,4" - intel i7 740q 1,73GHz - 8 GB ram - 250GB SSD Samsung 860 Evo e 500 GB HDD 7200 rpm - Windows 10 Pro 64 bit

Ultima modifica di bilanciamist : 23-07-2021 alle 22:50.
bilanciamist è offline   Rispondi citando il messaggio o parte di esso
Old 24-07-2021, 01:43   #7
rejavi
Member
 
Iscritto dal: Jun 2020
Messaggi: 119
Quote:
Originariamente inviato da bilanciamist Guarda i messaggi
Ho anche aggiunto la regola al firewall del secondario, vediamo se cambia qualcosa.
ovviamente serve regola a monte sul primario che invia al secondario.. poi non sono certo che la regola sul secondario possa funzionare.. ricorda di riavviare la firewall ad ogni modifica.. /etc/init.d/firewall reload..

Quote:
Ho cercato di capire i vari passaggi della guida, ma un paio ammetto di averli seguiti sulla fiducia. Mi sapresti indicare quale punto riguarda la procedura che descrivi? c'è un modo per controllare che effettivamente abbia disattivato il controllo remoto?

Di CWMP se ne parla nei commenti, ma non so se sono corretti.
https://hack-technicolor.readthedocs...ble/Hardening/ (la parte Telstra non ti riguarda)

cambia la password di root con "passwd"

verifica che /"etc/dropbear/authorized_keys" sia vuoto o contenga solo le tue chiavi (consiglio creare tue chiavi e disabilitare login con password!)

verifica che "/etc/config/dropbear" non abbia istanze che girano su wan, se fosse option enabled '0', se crei le tue chiavi metti anche "PasswordAuth" e "RootPasswordAuth" a 'off' (prova bene il login con chiavi non chiuderti fuori sal router )

verifica che "/etc/config/telnet" sia disabilitato option enabled '0' e spegni il servizio "/etc/init.d/telenet stop && /etc/init.d/telnet disabale"

verifica che "/etc/init.d/cwmpd status" risulti spento/disabilitato

verifica per esempio con "netstat -lenp" cosa sta ascoltando e dove (lan/wan) sul dga una volta fatto tutto..

evita per tua sicurezza di lasciare ssh e/o qualsiasi gui raggiungibile da esterno..

dovresti essere ok

edit: dimenticavo per accesso e dare comandi putty, per modifica file winscp e' quello che ti serve (volendo basta putty e fai tutto da riga di comando ma fa lo stesso). la wiki di openwrt e' molto completa su queste procedure di base e anche sul resto..

Ultima modifica di rejavi : 24-07-2021 alle 01:51. Motivo: dho!
rejavi è offline   Rispondi citando il messaggio o parte di esso
Old 24-07-2021, 04:59   #8
rejavi
Member
 
Iscritto dal: Jun 2020
Messaggi: 119
e per clonare il mac address leggi il mac dietro sull'etichetta del tuo attuale fastgate ed inseriscilo nel dga in /etc/config/network, dove leggi config interface 'wan' aggiungi option macaddr 'xx:xx:xx:xx:xx:xx' riavvia e verifica con "ifconfig" che le interfacce abbiano il mac clonato... non le ricordo tutte, alcune sono vlan, ptm0.. dipende anche tipo di linea, se hai problemi aggiungi la voce macaddr anche alle altre interfacce.. e da un po' che non ci metto mano non ricordo tutto
rejavi è offline   Rispondi citando il messaggio o parte di esso
Old 24-07-2021, 10:01   #9
bilanciamist
Member
 
Iscritto dal: Jun 2007
Messaggi: 125
quindi uso i comandi indicati nella guida e poi proseguo con quelli che mi hai indicato (se riesco).

la password di root l'ho già cambiata.

La regola nel firmware del secondario non ha avuto effetto, nel primario posso inserire regole solo da interfaccia Fastweb, e comunque li ho aperto le porte e il firewall è disattivato.

Ma ormai opto per lo scambio di router, cerchiamo di semplificare dove possibile.

Tra clonare il mac adress o fare la procedura con Fastweb che mi indicavi ieri cosa è meglio fare? mi sembra che clonarlo non sia proprio semplice.

Un'altra cosa. nel router con il root ho cambiato la password del wifi guest in etc/config/wireless:

Codice:
config wifi-ap 'ap6'
	option iface 'wl0_2'
	option state '1'
	option public '1'
	option ap_isolation '1'
	option station_history '1'
	option max_assoc '0'
	option security_mode 'wpa2-psk'
	option supported_security_modes 'none wep wpa2-psk wpa-wpa2-psk wpa2 wpa-wpa2'
	option pmf 'disabled'
	option pmksa_cache '1'
	option wps_state '0'
	option wps_w7pbc '1'
	option wsc_state 'configured'
	option wps_ap_setup_locked '0'
	option acl_mode 'unlock'
	option acl_registration_time '60'
	option trace_modules ' '
	option trace_level 'some'
	option bandsteer_id 'off'
	option wep_key '881FD32C75'
	option wps_ap_pin '92468016'
	option wpa_psk_key 'w6C2kZJs'
ho cambiato solo la parte in rosso e ora il guest non va più, ci si può connettere alla rete ma non c'è collegamento internet (internet assente). Non ho la certezza che prima funzionasse, ma mi sembra di si. Non funziona neanche se faccio generare la password al router o se lo riavvio.

nei due router ho messo stesso SSID e password, e pensavo di fare la stessa cosa anche con la Guest, ma anche usando la guest del router rootato da sola non funziona.
__________________
Pc assemblato Case Fractal Design Meshify C AMD Ryzen 7 2700x - Nvidia GTX 1070 - 32GB Ram Hyper X Predator 3200MHz cl16 - Windows 10 Pro 64 bit - 500GB SSD Sabrent Rocket

Portatile Sony Vaio VPCF12S1E/B - 16,4" - intel i7 740q 1,73GHz - 8 GB ram - 250GB SSD Samsung 860 Evo e 500 GB HDD 7200 rpm - Windows 10 Pro 64 bit
bilanciamist è offline   Rispondi citando il messaggio o parte di esso
Old 24-07-2021, 11:41   #10
rejavi
Member
 
Iscritto dal: Jun 2020
Messaggi: 119
Quote:
Originariamente inviato da bilanciamist Guarda i messaggi
La regola nel firmware del secondario non ha avuto effetto, nel primario posso inserire regole solo da interfaccia Fastweb, e comunque li ho aperto le porte e il firewall è disattivato.
la regola che ho scritto non ero sicuro funzionasse per i motivi spiegati in precedenza, lo stesso vale per le regole inserite da gui fastweb.. riguardano il traffico wan<-->lan. il firewall e' si messo su disattivato ma non vuol dire che e' spento.. ci dovrebbe essere una piccola spiegazione.. in sostanza consente solo il traffico in uscita e le relative risposte in entrata.

Quote:
Ma ormai opto per lo scambio di router, cerchiamo di semplificare dove possibile.

Tra clonare il mac adress o fare la procedura con Fastweb che mi indicavi ieri cosa è meglio fare? mi sembra che clonarlo non sia proprio semplice.
suppongo tu abbia richiesto ip statico per usare servizi da esterno, preferirei clonare il mac address.. non ho idea se la procedura di registrazione poi tenga conto dell'associazione ad ip statico.

Quote:
Un'altra cosa. nel router con il root ho cambiato la password del wifi guest in etc/config/wireless:

...

ho cambiato solo la parte in rosso e ora il guest non va più, ci si può connettere alla rete ma non c'è collegamento internet (internet assente). Non ho la certezza che prima funzionasse, ma mi sembra di si. Non funziona neanche se faccio generare la password al router o se lo riavvio.

nei due router ho messo stesso SSID e password, e pensavo di fare la stessa cosa anche con la Guest, ma anche usando la guest del router rootato da sola non funziona.
da quello che vedo hai fatto correttamente.. sicuro prima andasse?? spendo il server dhcp?? collegato lan<->lan?? la teoria per estendere il segnale e' quella che hai appena scritto, basta usare canali differenti..

non e' magari il caso che prima di procedere di dare un occhio anche alla gui di ansuel, non l'ho mai usata personalmente ma ho sempre letto che e' parecchio completa (spegnere gestione remota, root permanente, etc, etc) magari ti puo' aiutare, e di molto, in questi passaggi.. io non ho grosse difficolta' a muovermi dentro i concetti di openwrt ma lo uso da parecchio.. capisco le complessita' iniziali.. sono passato da tanti reset prima di arrivare ad un dunque
rejavi è offline   Rispondi citando il messaggio o parte di esso
Old 24-07-2021, 13:02   #11
bilanciamist
Member
 
Iscritto dal: Jun 2007
Messaggi: 125
in realtà non ho chiesto l'ip statico, ho seguito una guida che usava duckdns e uno script che lo aggiorna continuamente. Immagino che se il router si riavvia con il pc spento l'associazione non viene effettuata e in quel caso il sistema non funzionerebbe fino a che non avvio di persona il pc, ma se questo non succede il sistema dovrebbe funzionare (e almeno per i primi tre minuti funziona, finché il router non si dimentica il mac adress del pc).

per il wifi è tutto impostato come hai scritto, ora ho messo il wifi ospiti attivo solo sul "secondario", ma non funziona. DHCP spento sul secondario e acceso sul primario. collegati LAN-LAN, la rete principale funziona ma quella guest no. Non sono certo funzionasse, nel caso dovrei resettare il router e ricominciare da capo.

Ora provo a installare la GUI.
__________________
Pc assemblato Case Fractal Design Meshify C AMD Ryzen 7 2700x - Nvidia GTX 1070 - 32GB Ram Hyper X Predator 3200MHz cl16 - Windows 10 Pro 64 bit - 500GB SSD Sabrent Rocket

Portatile Sony Vaio VPCF12S1E/B - 16,4" - intel i7 740q 1,73GHz - 8 GB ram - 250GB SSD Samsung 860 Evo e 500 GB HDD 7200 rpm - Windows 10 Pro 64 bit
bilanciamist è offline   Rispondi citando il messaggio o parte di esso
Old 24-07-2021, 13:39   #12
rejavi
Member
 
Iscritto dal: Jun 2020
Messaggi: 119
Quote:
Originariamente inviato da bilanciamist Guarda i messaggi
in realtà non ho chiesto l'ip statico
se e' cosi' pui treanqullamente usare il link per la registrazione in autonomia, a me nn ha mai dato problemi.
Quote:
Immagino che se il router si riavvia con il pc spento l'associazione non viene effettuata e in quel caso il sistema non funzionerebbe fino a che non avvio di persona il pc, ma se questo non succede il sistema dovrebbe funzionare (e almeno per i primi tre minuti funziona, finché il router non si dimentica il mac adress del pc).
in caso puoi aggiungere il comando arp in /etc/rc.local e si esegue ad ogni riavvio.

Quote:
per il wifi è tutto impostato come hai scritto, ora ho messo il wifi ospiti attivo solo sul "secondario", ma non funziona. DHCP spento sul secondario e acceso sul primario. collegati LAN-LAN, la rete principale funziona ma quella guest no. Non sono certo funzionasse, nel caso dovrei resettare il router e ricominciare da capo.
a memoria la rete guest e' associata ad un'altra interfaccia lan e zona firewall piu' vincolata per tenerle ben divise.. potrebbe essere quello il problema.. mancata comunicazione con router/gw/dhcp primario a monte.

Ultima modifica di rejavi : 24-07-2021 alle 13:51. Motivo: info+typos ;)
rejavi è offline   Rispondi citando il messaggio o parte di esso
Old 25-07-2021, 05:09   #13
rejavi
Member
 
Iscritto dal: Jun 2020
Messaggi: 119
Quote:
Originariamente inviato da rejavi Guarda i messaggi
a memoria la rete guest e' associata ad un'altra interfaccia lan e zona firewall piu' vincolata per tenerle ben divise.. potrebbe essere quello il problema.. mancata comunicazione con router/gw/dhcp primario a monte.
ho verificato senza un'interfaccia wan attiva dubito possa andare la rete guest, bisogna intervenire e modificare questa parte nel firewall.. o ricreare una rete guest da zero in base a quello che ti serve effettivamente.. lo troverei piu' semplice..

Codice:
config zone 'Guest'
	option name 'Guest'
	list network 'Guest'
	option input 'DROP' <-- dal dga, dhcp dns etc.
	option output 'ACCEPT'
	option forward 'ACCEPT' magari reject! xD
	option mtu_fix '1'
	option wan '0'

config forwarding 'Guest_wan'
	option src 'Guest'
	option dest 'wan' <-- non usiamo wan

config rule 'Deny_Guest_lan_gateway' <-- superfluo?!?
	option name 'Deny-Guest-lan-gateway'
	option src 'Guest'
	option proto 'all'
	option dest_ip '192.168.1.254'
	option family 'any'
	option target 'DROP'

config rule 'Deny_lan_2_Guest' <-- superfluo?!?
	option name 'Deny-lan-2-Guest'
	option src 'lan'
	option dest 'Guest'
	option proto 'all'
	option target 'DROP'

config rule 'Deny_Guest_2_lan' <-- superfluo?!?
	option name 'Deny-Guest-2-lan'
	option src 'Guest'
	option dest 'lan'
	option proto 'all'
	option target 'DROP'
tutto cmq abbastanza inutile visto che il dga lo metterai come primario con wan per la questione wol ed anche la rete guest funzionera' di suo.. ma ormai ho verificato e questo lo lascio come appunto

Ultima modifica di rejavi : 25-07-2021 alle 05:15.
rejavi è offline   Rispondi citando il messaggio o parte di esso
Old 25-07-2021, 08:14   #14
bilanciamist
Member
 
Iscritto dal: Jun 2007
Messaggi: 125
Grazie per il lavoro extra, mi piacerebbe che i due router ampliassero anche la guest, ma cercherò di risolvere il problema in futuro.

Ieri sera molto tardi ho fatto lo scambio dei due router. Ho copiato tutte le impostazioni del principale sul secondario e l'ho messo al posto del principale. Purtroppo mi da linea assente. Pensavo potesse essere colpa della registrazione mancante, ma da dentro la LAN, se vado su registrazione.Fastweb.it non riesce a connettersi (non è possibile contattare il server).

Da connessione tramite smartphone mi dice che "al momento non è possibile procedere alla registrazione dei dati".

probabilmente dovrei telefonare a fastweb per associare il mac address alla linea.

Potrei provare a clonare il mac adress, ma se poi il principale lo usassi a cascata i due mac uguali non creerebbero problemi?

La ansuel GUI l'ho installata, ha molte opzioni, anche troppe, ma per fare lo scambio tra i router ho preferito ritornare all'interfaccia Fastweb in nodo da copiare facilmente le impostazioni.

EDIT: ho provato a clonare il mac address. Ho inserito la stringa in etc/config/network

Codice:
config interface 'wan'
option proto dhcp''
option reqopts 'xxx'
option vendorid 'xxx'
...
option macaddr '94:xx:xx:xx:xx:xx'

In wan è presente anche una option notused 'xx:xx:xx:xx:xx:xx' (dovrei cambiarlo anche qui?)

Ho riavviato il router e dato il comando ifconfig

Bcmsw HWaddr 10:xx:xx:xx:xx:xx

Br-lan HWaddr 10:xx:xx:xx:xx:xx

Eth da 0 a 4 HWaddr 10:xx:xx:xx:xx:xx

Lo (senza indirizzo)

Vlan-eth4 HWaddr 10:xx:xx:xx:xx:xx

W10 da 0 a 3 HWaddr 10:xx:xx:xx:xx:xx

W11 da 0 a 3 HWaddr 12:xx:xx:xx:xx:xx


Uno di questi non dovrebbe avere il nuovo indirizzo? invece hanno tutti mantenuto il mac originale.

EDIT2:

Ho aggiunto la stessa stringa in LAN e ora da ifconfig la br-lan ha il nuovo mac address. Ma gli altri no. leggendo online mi sembra di aver capito che è un problema comune, ma non ho trovato soluzione.

Ho aggiunto la stringa ad ogni singola voce del file network, ma tutte le ETH le wan 10 e le wan 11 hanno ancora il loro mac address originale. (Cambiano solo br-lan, eth4, VLAN-eth4, w10-2)
__________________
Pc assemblato Case Fractal Design Meshify C AMD Ryzen 7 2700x - Nvidia GTX 1070 - 32GB Ram Hyper X Predator 3200MHz cl16 - Windows 10 Pro 64 bit - 500GB SSD Sabrent Rocket

Portatile Sony Vaio VPCF12S1E/B - 16,4" - intel i7 740q 1,73GHz - 8 GB ram - 250GB SSD Samsung 860 Evo e 500 GB HDD 7200 rpm - Windows 10 Pro 64 bit

Ultima modifica di bilanciamist : 25-07-2021 alle 12:18.
bilanciamist è offline   Rispondi citando il messaggio o parte di esso
Old 26-07-2021, 01:19   #15
rejavi
Member
 
Iscritto dal: Jun 2020
Messaggi: 119
per la questione clonare mac sono in difficolta' a provare comandi direttamente perche' attualmente sto usando il dga come modem puro in bridge e non posso metterci troppo mano (cmq le interfacce w* sono wireless e non serve toccarle). nella mia zona tutto passa da cabinet tim con vlan100, da te potrebbe essere diverso e la registrazione funzionare in altro modo, ma almeno la portante ci deve essere.. puoi verificare cosa sta succedendo da "logread" per vedere i log e "xdslctl info --show" per stato dsl. una prova che farei e' collegare il dga alla dsl appena "rootato" senza nessuna altra modifica, con telegestione attiva, e lasciarlo collegato 10min (magari un paio di reboot) per vedere se si registra sulla rete (luce verde, non naviga, o ti fa navigare solo su registrazoine). se proprio non risolvi l'unica e' chiamare fastweb come hai detto tu, dicendo magari che il tuo fastgate ti da qualche problema con il wifi e ne stai provando uno di un amico per vedere se risolvi
rejavi è offline   Rispondi citando il messaggio o parte di esso
Old 26-07-2021, 10:40   #16
bilanciamist
Member
 
Iscritto dal: Jun 2007
Messaggi: 125
Grazie, hai già fatto molto per aiutarmi. Al momento ho rimesso quello vecchio, in modo da avere la connessione internet.

Dato che posso accedere al dga4131, farò delle prove per cercare di clonare il mac address, anche se non sono certo che sia l'unica cosa che Fastweb controlla.

Se non funziona resetto il router come hai suggerito e provo a collegarlo con il solo root.

Non so come è collegata a casa mia, so solo che ho una ADSL abbastanza lenta, e che a domanda diretta se è possibile mettere la fibra, il centralino Fastweb mi ha detto che decidono loro se e quando metterla per i vecchi abbonati. Dovrei proprio cambiare operatore...
__________________
Pc assemblato Case Fractal Design Meshify C AMD Ryzen 7 2700x - Nvidia GTX 1070 - 32GB Ram Hyper X Predator 3200MHz cl16 - Windows 10 Pro 64 bit - 500GB SSD Sabrent Rocket

Portatile Sony Vaio VPCF12S1E/B - 16,4" - intel i7 740q 1,73GHz - 8 GB ram - 250GB SSD Samsung 860 Evo e 500 GB HDD 7200 rpm - Windows 10 Pro 64 bit
bilanciamist è offline   Rispondi citando il messaggio o parte di esso
Old 01-08-2021, 20:22   #17
bilanciamist
Member
 
Iscritto dal: Jun 2007
Messaggi: 125
Piccolo aggiornamento.

Ho capito, leggendo questo post:

https://www.ilpuntotecnico.com/forum...html#msg250655

che utilizzare un modem diverso per fastweb è molto più complicato del previsto, inoltre al momento non posso fare tante prove avendo bisogno di internet e telefono.
In più non riesco a clonare il mac usando option macaddr, anche se mi sembra, da quanto ho letto, una situazione diffusa, ed esistono dei sistemi alternativi da provare:
http://jhshi.me/2015/01/19/fix-mac-a...l#.XCngAC5fiV4

In ogni caso, al momento ho rimesso il router con il root come secondario. Ho però provato, seppur andando a "caso", ad utilizzare tcpdump.

Se io do il comando
Codice:
tcpdump -i br-lan port 9
https://fabianlee.org/2019/06/03/ope...ump-from-opkg/

e invio il magic packet da wan (sia che inserisco come mac address quello del pc da svegliare, sia quello del router in cascata) ottengo:

Codice:
root@OpenWrt:~# tcpdump -i br-lan port 9
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on br-lan, link-type EN10MB (Ethernet), capture size 262144 bytes
18:13:49.036771 IP 94.35.15.11.36649 > OpenWrt.lan.discard: UDP, length 102
18:13:49.044237 IP 94.35.15.11.36651 > OpenWrt.lan.discard: UDP, length 102
18:13:49.051406 IP 94.35.15.11.36653 > OpenWrt.lan.discard: UDP, length 102
18:13:50.969259 IP 94.35.15.11.36657 > OpenWrt.lan.discard: UDP, length 102
18:13:50.976657 IP 94.35.15.11.36655 > OpenWrt.lan.discard: UDP, length 102
18:13:50.980858 IP 94.35.15.11.36650 > OpenWrt.lan.discard: UDP, length 102
6 packets captured
6 packets received by filter
0 packets dropped by kernel
3 packets sono per il comando inviato con il mac address del pc e 3 per il comando inviato con il mac address del router. I packets arrivano al router anche con il pc da accendere spento da ore.

Non so se la mia interpretazione è corretta, ma il magic packet sembrerebbe arrivare al secondo router, o mi sbaglio?
Se è così, servirebbe un modo per reindirizzare il magic pocket al pc. Ho trovato questo: https://github.com/mister-benjamin/etherwake-nfqueue

è un sistema che potrebbe funzionare? non so neanche se è utilizzabile in openwrt.
__________________
Pc assemblato Case Fractal Design Meshify C AMD Ryzen 7 2700x - Nvidia GTX 1070 - 32GB Ram Hyper X Predator 3200MHz cl16 - Windows 10 Pro 64 bit - 500GB SSD Sabrent Rocket

Portatile Sony Vaio VPCF12S1E/B - 16,4" - intel i7 740q 1,73GHz - 8 GB ram - 250GB SSD Samsung 860 Evo e 500 GB HDD 7200 rpm - Windows 10 Pro 64 bit
bilanciamist è offline   Rispondi citando il messaggio o parte di esso
Old 02-08-2021, 01:51   #18
rejavi
Member
 
Iscritto dal: Jun 2020
Messaggi: 119
@bilanciamist da quello che si vede con tcpdump arrivano pacchetti da ip wan alla lan del dga.. ora con iptables da shell puoi semplicemente rigirarli alla destinazione finale (magari spegnendo prima firewall sul dga cosi non hai conflitti.), non credo che impostando una regola da gui fastweb del dga venga presa in considerazione per il traffico lan.. oppure come prova puoi sul dga impostare dmz verso il pc che si deve svegliare.. probabilmente con gui ansuel+luci gestire le regole sarebbe piu' semplice ma non ho esperienza diretta.. capisco le problematiche date della necessita' di avere internet/telefono funzionante ma qui stiamo parlando di scambiare un router fastweb con un altro fastweb mi chiedo cosa abbiano da dire a riguardo.. ma nulla mi stupisce visto che non rispettano neanche le basi dell'ipv6 e al cliente finale danno una /64 che non ti permette di dividere le reti, ma questo e' solo un mio problema e sfogo personale

edit: e se sei in cerca di soluzioni alternative puoi installare openvpn sul dga per accedere a ssh in sicurezza ed installare/usare etherwake da shell.. entrambi i pacchetti sono disponibili.. altre soluzioni tipo monitor/log firewall per attivare script sono fattibili ma mi pare di stare degenerando/esagerando.

Ultima modifica di rejavi : 02-08-2021 alle 02:41. Motivo: info
rejavi è offline   Rispondi citando il messaggio o parte di esso
Old 02-08-2021, 13:55   #19
bilanciamist
Member
 
Iscritto dal: Jun 2007
Messaggi: 125
La tua risposta è gradita ma, per me, un po' ostica da capire.

iptables se non ho capito male dovrebbe essere il firwall di Openwrt e Linux. Cercherò di capire come modificare le regole per quello che mi serve, anche se non sarà semplice.

Da GUI fastweb , anche attivando il Firewall, non posso creare regole, ma solo agire sul livello (alto o medio). Se spento "Il Firewall in modalità spento permette tutte le connessioni in uscita senza restrizioni. In ingresso, le connessioni IPv4 sono regolamentate dalle sezioni di DMZ e Port Mapping, le connessioni IPv6 sono senza restrizioni."

La Ansuel Gui permette molte più modifiche e ha molte più impostazioni, talmente tante che faccio fatica a capire come impostarlo. E non so se l'Ansuel Gui mantiene le impostazioni del modem al momento del caricamento, anche se mi sembrerebbe sensato lo facesse. Comunque posso provare a rimetterla e smanettare un po'.

Per quanto riguarda usare il dga4131 come primario, dal link che ho messo, che rimanda ai commenti alla guida che mi hai indicato, si capisce che richiede alcune modifiche alle impostazioni del router. Inoltre ho mandato una pec a fastweb per provare a convincerli a passare finalmente da adsl a FTTC, e non vorrei che dessero la colpa al modem per la lentezza della linea. In più, usandolo come secondario potrebbe funzionare anche se cambiassi linea con Vodafone o TIM (sperando che loro siano in grado di attivare la FTTC nel caso non riuscisse Fastweb).

dell'edit ho capito il senso, ma lo vedo complicato. Anche solo usare un comando tipo
Codice:
opkg update
mi da un errore che non so risolvere, probabilmente perchè porta ad un link che non è corretto.

Codice:
root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx-tch/VBNTJ/packages/Packages.gz
wget: bad address 'downloads.openwrt.org'
*** Failed to download the package list from http://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx-tch/VBNTJ/packages/Packages.gz

Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx-tch/VBNTJ/packages/Packages.gz, wget returned 1.
Quindi al momento installare pacchetti lo vedo difficile.

Diciamo che mi concentrerò sul firwall per cercare di far passare questo benedetto magic packet.
__________________
Pc assemblato Case Fractal Design Meshify C AMD Ryzen 7 2700x - Nvidia GTX 1070 - 32GB Ram Hyper X Predator 3200MHz cl16 - Windows 10 Pro 64 bit - 500GB SSD Sabrent Rocket

Portatile Sony Vaio VPCF12S1E/B - 16,4" - intel i7 740q 1,73GHz - 8 GB ram - 250GB SSD Samsung 860 Evo e 500 GB HDD 7200 rpm - Windows 10 Pro 64 bit
bilanciamist è offline   Rispondi citando il messaggio o parte di esso
Old 02-08-2021, 14:51   #20
rejavi
Member
 
Iscritto dal: Jun 2020
Messaggi: 119
Quote:
Originariamente inviato da bilanciamist Guarda i messaggi
La tua risposta è gradita ma, per me, un po' ostica da capire
perdonami mi capita di rispondere in maniera troppo diretta a volte..
Quote:
iptables se non ho capito male dovrebbe essere il firwall di Openwrt e Linux. Cercherò di capire come modificare le regole per quello che mi serve, anche se non sarà semplice.

Da GUI fastweb , anche attivando il Firewall, non posso creare regole, ma solo agire sul livello (alto o medio). Se spento "Il Firewall in modalità spento permette tutte le connessioni in uscita senza restrizioni. In ingresso, le connessioni IPv4 sono regolamentate dalle sezioni di DMZ e Port Mapping, le connessioni IPv6 sono senza restrizioni."
puoi disattivere completamente il firewall da shell con /etc/init.d/firewall stop (vado a memoria, cmq per nn avere altre regole attive) per poi mettere sempre da shell una singola regola con iptables per muovere i pacchetti a tuo piacimento.. ci son parecchi esempi, tutorial in rete.. anche per conoscere tutte le regole attive.
Quote:
Inoltre ho mandato una pec a fastweb per provare a convincerli a passare finalmente da adsl a FTTC
ottima mossa direi
Quote:
Quindi al momento installare pacchetti lo vedo difficile.
https://www.macoers.com/blog/antonio...8_brcm63xx_tch
Quote:
Diciamo che mi concentrerò sul firwall per cercare di far passare questo benedetto magic packet.
puoi provare giusto per vedere a fare un collegamento a cascaca lan<->wandga (mettendo ip lan dga in classe diversa tipo 192.168.2.X) in modo da essere sicuro che le regole funzionano (visto che facendo cosi' hai sia wan che lan attiva e sta facendo effetivamnete routing).. io ricordo che port forward basilari si possono fare da gui dga, piu' tardi verifico.. o volendo attivi dmz verso host da svegliare.. almeno vedi se passando il pachetto sto benedetto pc si sveglia
rejavi è offline   Rispondi citando il messaggio o parte di esso
 Rispondi


Psychonauts 2: la psicologia incontra il gaming Psychonauts 2: la psicologia incontra il gaming
Samsung Galaxy Watch4: è lui il miglior smartwatch per gli Android! La recensione Samsung Galaxy Watch4: è lui il miglior s...
Un viaggio in Tesla dal nord alla Sicilia, senza Supercharger e spendendo 50 euro Un viaggio in Tesla dal nord alla Sicilia, senza...
Ghost of Tsushima: Director's Cut, le meraviglie di Iki su PS5 - Recensione Ghost of Tsushima: Director's Cut, le meraviglie...
Xiaomi 11T Pro, la ricarica da 120W è pazzesca ma non basta. La recensione Xiaomi 11T Pro, la ricarica da 120W è paz...
Far Cry 6 meglio su PC, niente ray traci...
Microsoft Italia e Reale Group insieme p...
Corsair M65 RGB Ultra disponibile anche ...
5G, dall'inizio della pandemia 288 attac...
Ilford ammicca verso i fotografi a pelli...
NASA Perseverance si scatta un selfie in...
Amazon ufficializza Kindle Paperwhite e ...
Giove colpito da un asteroide, l'avvista...
I conducenti di Tesla tendono a distrars...
Svelato il vero volto della Gioconda e d...
HP, ecco i nuovi desktop e notebook con ...
WRC, nel campionato 2022 debutteranno le...
PlayStation 5: il nuovo firmware miglior...
OPPO Reno6 in prima linea per la Red Bul...
Shortage CPU: per Intel produzione senza...
Opera Portable
Opera 79
Radeon Software Adrenalin 21.9.2 beta
Chromium
iTunes 12
PassMark BurnInTest Windows Edition
OCCT
Driver NVIDIA GeForce 472.12 WHQL
K-Lite Codec Pack Update
K-Lite Mega Codec Pack
K-Lite Codec Pack Full
K-Lite Codec Pack Standard
K-Lite Codec Pack Basic
LibreOffice 7.2.1
Avast! Free Antivirus
Tutti gli articoli Tutte le news Tutti i download

Strumenti

Regole
Non Puoi aprire nuove discussioni
Non Puoi rispondere ai messaggi
Non Puoi allegare file
Non Puoi modificare i tuoi messaggi

Il codice vB è On
Le Faccine sono On
Il codice [IMG] è On
Il codice HTML è Off
Vai al Forum


Tutti gli orari sono GMT +1. Ora sono le: 16:33.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Served by www1v