View Single Post
Old 09-02-2018, 20:24   #3942
fester40
Senior Member
 
Iscritto dal: Mar 2005
Città: West Liguria
Messaggi: 2060
4130, wifi mod dualchannel fisso

Ciao, posto a beneficio di coloro che sono insoddifatti del wifi 2.4 (siamo parecchi); da mesi cercavo di trovare un rimedio, anche parziale alla nota lentezza, nonostante alcuni esperti si mostrassero pessimisti. Avrete forse notato il suo comportamento odioso; parte veloce ma lentamente si 'siede', calando anche fino a 35Mbps. Suprattutto, (è questo il vero problema) parte a 40Mhz di larghezza di banda, ma dopo pochi minuti "stringe" a 20Mhz, con calo drastico della velocità. Poichè a livello HW è scarso, su un solo canale non supera i 60Mbps salvo, come detto, calare ulteriormente, fino a valori tragicomici . Le normative tecniche internazionali, allo scopo di ridurre la congestione della banda 2,4Mhz, impongono ai fabbricanti di limitare l'utilizzo del dual channel, sicché i router sono programmati per fare continue scansioni e, in caso 'vedano' altre reti su canali attigui passano da 40 a 20Mhz. Il problema è che le reti 2.4 sono piuttosto affollate e quindi i router viaggiano molto spesso/quasi sempre a 20Mhz, specialmente quelli più recenti, rispettosi delle ultime normative, peraltro sempre più restrittive. Credo che in questo campo TIM abbia deciso di dare l'esempio e così, il nostro, in modo iperreattivo, viaggia sempre a 20 Mhz. Il preambolo è finito, ora andiamo al sodo: se potete, resettate il modem mantenendo premuto il tastino posteriore durante almeno 10 secondi, rilasciate e attendete 80/90 secondi, tempo che tutti i led siano verdi:

con Winscp cercate ed aprite il file /etc/wireless_acs.conf



dovete togliere il commento (#) da profile.0 e metterlo davanti a profile.4: profile.0 deve essere modificato e riportare '0' su tutte le colonne e '0' anche ai valori indicati dalle frecce. Alla fine il file deve essere come in foto. Salvate, chiudete, cliccate dx sul file>proprietà>togliere la spunta da 'W'>OK> chiudere ma non uscite.

File /etc/config/wireless, aprite e inserite la voce >option htmode 'HT40'< grossomodo nei 2 punti indicati

config wifi 'global'
option station_history_persistent '0'
option station_history_save_delay '24'
option wfa_model_name 'AGEVO'
option wfa_friendly_name 'Modem TIM'
option wifi_analyzer_disable '0'

config wifi-device 'radio_2G'
option type 'broadcom'
option country 'EU'
option channelwidth 'auto'
option standard 'bgn'
option htmode 'HT40'
option rateset '1(b) 2(b) 5.5(b) 6 9 11(b) 12 18 24 36 48 54'
option ht_security_restriction '0'
option sgi '1'
option frame_bursting '0'

/////////////////////////////////////////

config wifi-ap 'ap0'
option iface 'wl0'
option public '1'
option ap_isolation '0'
option station_history '1'
option max_assoc '0'
option security_mode 'wpa2-psk'
option supported_security_modes 'none wep wpa2-psk wpa-wpa2-psk'
option pmf 'disabled'
option htmode 'HT40'
option pmksa_cache '1'
option wps_state '1'

Salvate, chiudete>click dx sul file>proprietà>togliere la spunta a 'W'>OK uscite. Aprite la GUI>wireless aprite la 2.4, opzioni avanzate, selezionate '20/40 auto', 802 b/g/n, canale, io scelgo il 13 perché qui è sempre libero e selezionate solo Intervallo breve. Chiudete, uscite e riavviate il modem. Quando ripartirà la modifica DOVREBBE esserci; se tutto è andato per il verso giusto, dovreste navigare a 110/115Mbps. Alcuni mi hanno detto che non hanno avuto alcun miglioramento, sicché non prometto nulla. Provate e raccontate!
__________________
.....sono solo un praticone che si arrangia.....

Ultima modifica di fester40 : 10-02-2018 alle 13:27.
fester40 è offline   Rispondi citando il messaggio o parte di esso