Hardware Upgrade Forum

Hardware Upgrade Forum (https://www.hwupgrade.it/forum/index.php)
-   DirectX, componenti, servizi e programmi integrati di Windows (https://www.hwupgrade.it/forum/forumdisplay.php?f=65)
-   -   Problemi con Windows Installer - Possibili soluzioni (https://www.hwupgrade.it/forum/showthread.php?t=2019518)


carminef95 15-07-2011 12:09

ho tentato di installare un programma e mi diceva che il programma msi.dll non era presente...l'ho scaricato e ho ftt copia e sostituisci con il vecchio e quando tento di installare qualcosa mi dice impossibile avviare correttamente l'applicazione (0xc000007b). fare clic su ok per chiudere l'applicazione...mentre se provo ad aprire photoshop ke ho gia installato sul pc mi dice ugualmente che il programma msi.dll non è presente

Blue_screen_of_death 15-07-2011 18:38

prova a ripristinare i file di sistema con il comando " sfc /scannow "

ti chiederà il cd originale di windows ;)

alexpinturicchio10 19-10-2011 11:13

spero che questo thread sia ancora vivo!!! ho un problema a windows installer, quando provo ad installare alcuni sw mi esce il messaggio "windows installer ha smesso di funzionare" ... sospetto che ciò sia avvenuto in seguito all'installazione sul mio win seven del software per la navigazione con la chiavetta internet della 3 ... tale installazione non è andata a buon fine e da quel momento windows installer si è incasinato ... se così fosse, come posso ripristinare il tutto?

ezio 19-10-2011 11:58

Non hai un punto di ripristino precedente all'installazione del software per la chiavetta?
PS: correggi la firma, max 3 righe ;)

Blue_screen_of_death 19-10-2011 13:54

dovresti risolvere reinstallando il servizio Windows Installer... :D

apri il prompt dei comandi e digita questi comandi:

cd \windows\system32
ren msi.dll msi.old
ren msihnd.dll msihnd.old
ren msiexec.exe msiexec.old
exit

poi scarica windows installer da qui e reinstallalo :D

alexpinturicchio10 19-10-2011 14:49

Quote:

Originariamente inviato da Blue_screen_of_death (Messaggio 36175772)
dovresti risolvere reinstallando il servizio Windows Installer... :D

apri il prompt dei comandi e digita questi comandi:

cd \windows\system32
ren msi.dll msi.old
ren msihnd.dll msihnd.old
ren msiexec.exe msiexec.old
exit

poi scarica windows installer da qui e reinstallalo :D

stasera provo ... se dovesse funzionare dammi il tuo indirizzo che ti mando una cassa di vino :)

alexpinturicchio10 20-10-2011 09:15

ha funzionato, con una piccola modifica che segnalo, perchè potrebbe essere utile ... in caso (come è successo a me) si abbiano problemi ad installare il nuovo windows installer si può fare così

1) stoppare il servizio windows installer
2) rinominare solo msi.dll in msi.old e msihnd.dll in msihnd.old
3) riavviare il servizio windows installer che ricreerà le due dll "pulite"

così per me è andato, perchè se rinominavo anche msiexec.exe in .old poi avevo problemi a reinstallarlo

grazie a tutti

Eress 20-10-2011 09:35

Quote:

Originariamente inviato da alexpinturicchio10 (Messaggio 36181148)
ha funzionato

Non dimenticare di spedirgli la cassa di vino! :D :p

misteron1 18-12-2011 12:50

a me dice accesso negato come faccio?

Blue_screen_of_death 18-12-2011 13:08

Maggiori dettagli??

Ti dice accesso negato in che occasione? :D

Th0reK 16-01-2012 12:34

Salve!

Ho da tempo problemi relativi a Windows Installer. A quanto pare il servizio è in qualche modo danneggiato. Provando a installare da capo WI ricevo l'errore "memoria insufficiente" (ho 5 gb di ram...).

Ho provato a seguire i suggerimenti proposti fino ad ora con scarsi risultati. In particolare, provando la soluzione postata da blue_screen ricevo il messaggio permesso negato direttamente nel prompt ( Digitando ren msi.dll msi.old e dando l'invio mi da permesso negato). Come risolvere?

Grazie mille :)

alexpinturicchio10 16-01-2012 15:25

Quote:

Originariamente inviato da Th0reK (Messaggio 36740083)
Salve!

Ho da tempo problemi relativi a Windows Installer. A quanto pare il servizio è in qualche modo danneggiato. Provando a installare da capo WI ricevo l'errore "memoria insufficiente" (ho 5 gb di ram...).

Ho provato a seguire i suggerimenti proposti fino ad ora con scarsi risultati. In particolare, provando la soluzione postata da blue_screen ricevo il messaggio permesso negato direttamente nel prompt ( Digitando ren msi.dll msi.old e dando l'invio mi da permesso negato). Come risolvere?

Grazie mille :)

guarda, i file li puoi rinominare anche a mano con permessi di amministratore

Dastan 07-02-2012 09:07

ciao a tutti, spero mi possiate aiutare.. da qualche giorno ad ogni avvio di windows 7 mi esce il seguente errore:

"Errore durante l'avvio di msizzd32.dll
Impossibile trovare il modulo specificato".

innanzitutto è un errore riferito al windows installer si? ho eseguito alcuni dei passi consigliati all'inizio, tranne l'ultimo non sapendo se fosse valido anche per win 7 (in tal caso è sufficiente il dvd di ripristino creato all'inizio? non ho il cd d'installazione) ma non funzionano.

ho anche provato il metodo consigliato da Blue_screen_of_death, ma quando inserisco i comandi (ad es. ren msi.dll msi.old) mi dice accesso negato.. sbaglio qualcosa nella sintassi?

grazie

edit: ho provato a rinominare manualmente le dll in old ma quando faccio partite l'installazione di WI mi dice memoria insufficiente per eseguire il comando.. :cry:

Eress 07-02-2012 18:16

Dovresti fare qualche scansione antivirus, inizia con MalwareBytes aggiornato

Dastan 07-02-2012 22:14

Quote:

Originariamente inviato da Eress (Messaggio 36878769)
Dovresti fare qualche scansione antivirus, inizia con MalwareBytes aggiornato

ti ringrazio di avermi risposto innanzitutto..
comunque niente, ho provato a fare una scansione completa sia con MalwareBytes che con Avira Premium che avevo già sul pc, ma tranne 2 falsi positivi (due keygen che ho comunque rimosso) non ha trovato nulla, e l'errore continua ad apparire ad ogni riavvio..
cosa potrebbe essere? ho notato inoltre che digitando da esegui services.msc per verificare il servizio di WI, dopo ogni riavvio risulta sempre non avviato, ma mi permette comunque di riavviarlo.. che devo fare?

ezio 08-02-2012 08:32

Se il nome della dll che hai postato è corretto, non fa parte di Windows Installer mi pare.
Scaricati Hijackthis, avvialo con privilegi elevati (tasto destro sull'eseguibile, esegui come amministratore), effettua una scansione (Do a system scan only) e tra le voci visualizzate cerca quella riferita alla dll in questione, selezionala e clicca su Fix checked, riavviando se richiesto.
PS: può darsi che la dll sia semplicemente eliminabile da msconfig, scheda Avvio.

Se riesci a risolvere il problema è probabile che si tratti di un residuo di qualche malware eliminato in passato dall'antivirus o da Malwarebytes, quindi ti conviene eseguire una scansione approfondita del sistema seguendo la guida in rilievo che trovi nella sezione antivirus del forum in modo da assicurarti che non ci siano ulteriori tracce dell'infezione.

Attenzione ad usare i comandi e i tool del primo post prima di essere certi che il problema sia relativo a Windows Installer, si tratta pur sempre di procedure che vanno a toccare file e voci di registro importanti, il rischio di creare ulteriori problemi è sempre dietro l'angolo ;)

Dastan 08-02-2012 10:14

Quote:

Originariamente inviato da ezio (Messaggio 36881339)
Se il nome della dll che hai postato è corretto, non fa parte di Windows Installer mi pare.
Scaricati Hijackthis, avvialo con privilegi elevati (tasto destro sull'eseguibile, esegui come amministratore), effettua una scansione (Do a system scan only) e tra le voci visualizzate cerca quella riferita alla dll in questione, selezionala e clicca su Fix checked, riavviando se richiesto.
PS: può darsi che la dll sia semplicemente eliminabile da msconfig, scheda Avvio.

Se riesci a risolvere il problema è probabile che si tratti di un residuo di qualche malware eliminato in passato dall'antivirus o da Malwarebytes, quindi ti conviene eseguire una scansione approfondita del sistema seguendo la guida in rilievo che trovi nella sezione antivirus del forum in modo da assicurarti che non ci siano ulteriori tracce dell'infezione.

Attenzione ad usare i comandi e i tool del primo post prima di essere certi che il problema sia relativo a Windows Installer, si tratta pur sempre di procedure che vanno a toccare file e voci di registro importanti, il rischio di creare ulteriori problemi è sempre dietro l'angolo ;)

ho pensato fosse una libreria di Windows Installer perché in msconfig tra le voci di avvio ne compare una, MSIDLL, e come comando ha questa stringa C:\Windows\SysWOW64\rundll32.exe msizzd32.dll,zMmVPcAekEV
quando poi ho visto nella lista dei servizi che WI non era avviato ho pensato fosse questo il problema.. se la disabilito da msconfig cosa comporta?
comunque ora proverò a fare una scansione con Hijackthis come mi hai consigliato, e poi quella approfondita.. più tardi ti faccio sapere.. grazie mille

edit: allora ho fatto la scansione con Hijackthis e mi ha trovato la stessa voce presente nella schermata di avvio in msconfig e ho fatto fix checked, eliminandomela.. ora all'avvio non compare più.. nella pagina dei servizi il WI risulta sempre non avviato, non dovrebbe avviarsi automaticamente? o va bene così? continua inoltre a non fare un aggiornamento con win update, quello del service pack 1 di office, dandomi l'errore 80070663.. pensavo fosse legato al problema principale, cosa può essere?
grazie ancora

ezio 14-02-2012 11:37

Bene per la voce eliminata (però ripeto, ti conviene eseguire comunque una scansione per rilevare eventuali malware residui ;) )
Il servizio Windows Installer è impostato su manuale? Se sì, scegliendo Avvia parte correttamente?

denver 26-07-2012 12:49

ciao non so se è la sezione giusta , ma non so dove scrivere

cmq è da un po di tempo che mi sono accoro di problemi inspiegabili con l'installazione di alcuni programmi, prima pensavo a qualche incompatibilità invece ora ho scoperto provando ad installare Kis 2012 trial che dopo aver lanciato il file exe per lo spacchettamento, i file nella cartella temporanea che si sono creatri si cancellano da soli e l'installazione non va avanti, qualcuno ha qualche idea in mente???


P.S il sistema operativo è windows 7 home premium

bladegpa 22-09-2012 23:12

Quote:

Originariamente inviato da alexpinturicchio10 (Messaggio 36181148)
ha funzionato, con una piccola modifica che segnalo, perchè potrebbe essere utile ... in caso (come è successo a me) si abbiano problemi ad installare il nuovo windows installer si può fare così

1) stoppare il servizio windows installer
2) rinominare solo msi.dll in msi.old e msihnd.dll in msihnd.old
3) riavviare il servizio windows installer che ricreerà le due dll "pulite"

così per me è andato, perchè se rinominavo anche msiexec.exe in .old poi avevo problemi a reinstallarlo

grazie a tutti

da qualche giorno ho tanti dannati problemi con questo windows installer
ho provato a seguire i tuoi consigli ovvero rinominare msi.dll e msihnd
nei servizi quello relativo a win installer (ovvero msiserver)
risulta interrotto
non sono solo riuscito a riattivarlo!
che devo fare?come faccio a reinstallarlo?
ho windows seven x64 e nessuno dei file nella pagina risulta compatibile!
quale devo scaricare!?!?!?


Tutti gli orari sono GMT +1. Ora sono le: 08:30.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Hardware Upgrade S.r.l.