View Full Version : Rete Wifi


ivand
21-10-2004, 16:39
Ciao a tutti, ho installato suse 9.1 su un portatile con la scheda wifi integrata(centrino), ho scaricato i driver con l'aggiornamento automatico di suse. Fin qui tutto bene ;) poi ho cercato di collegarmi alla mia rete locale configurata con dhcp, si connette ricevo l'ip però non riesco a navigare in internet cosa invece possibile collegando il portatile con il cavo alla rete. Devo configurare qualche parametro ? :confused: :confused:

Ciao
Ivan

ilsensine
21-10-2004, 16:43
Collegati col wifi e posta l'output di questi comandi:
ifconfig
route -n
cat /etc/resolv.conf

Fai la stessa cosa con il cavo di rete attaccato. Se la connessione wifi si aggancia (riesci a pingare gli altri computer locali?), sarà qualche fesseria legata al default route o al dns.

ivand
21-10-2004, 18:10
gli output richiesti sono:
con wifi(eth1):
eth0 Link encap:Ethernet HWaddr 00:C0:9F:2A:AF:A5
inet6 addr: fe80::2c0:9fff:fe2a:afa5/64 Scope:Link
UP BROADCAST NOTRAILERS MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:10
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:5940 (5.8 Kb)
Interrupt:5

eth1 Link encap:Ethernet HWaddr 00:04:23:4B:45:2C
inet addr:10.0.0.228 Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: fe80::204:23ff:fe4b:452c/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:81 errors:0 dropped:0 overruns:0 frame:0
TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:13458 (13.1 Kb) TX bytes:3309 (3.2 Kb)
Interrupt:11 Base address:0xb000 Memory:d0206000-d0206fff

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:196 errors:0 dropped:0 overruns:0 frame:0
TX packets:196 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12558 (12.2 Kb) TX bytes:12558 (12.2 Kb)
---------------
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.0.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
---------------
domain site
nameserver 10.0.0.1

con cavo (eth0):

eth0 Link encap:Ethernet HWaddr 00:C0:9F:2A:AF:A5
inet addr:10.0.0.226 Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:9fff:fe2a:afa5/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1357 errors:0 dropped:0 overruns:0 frame:0
TX packets:2526 errors:0 dropped:0 overruns:0 carrier:16
collisions:0 txqueuelen:1000
RX bytes:924564 (902.8 Kb) TX bytes:240616 (234.9 Kb)
Interrupt:5

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:463 errors:0 dropped:0 overruns:0 frame:0
TX packets:463 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:29607 (28.9 Kb) TX bytes:29607 (28.9 Kb)

---------------
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.0.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 10.0.0.1 0.0.0.0 UG 0 0 0 eth0
---------------
### BEGIN INFO
#
# Modified_by: dhcpcd
# Backup: /etc/resolv.conf.saved.by.dhcpcd
# Process: dhcpcd
# Process_id: 12657
# Script: /sbin/modify_resolvconf
# Saveto:
# Info: This is a temporary resolv.conf created by service dhcpcd.
# The previous file has been saved and will be restored later.
#
# If you don't like your resolv.conf to be changed, you
# can set MODIFY_{RESOLV,NAMED}_CONF_DYNAMICALLY=no. This
# variables are placed in /etc/sysconfig/network/config.
#
# You can also configure service dhcpcd not to modify it.
#
# If you don't like dhcpcd to change your nameserver
# settings
# then either set DHCLIENT_MODIFY_RESOLV_CONF=no
# in /etc/sysconfig/network/dhcp, or
# set MODIFY_RESOLV_CONF_DYNAMICALLY=no in
# /etc/sysconfig/network/config or (manually) use dhcpcd
# with -R. If you only want to keep your searchlist, set
# DHCLIENT_KEEP_SEARCHLIST=yes in /etc/sysconfig/network/dhcp or
# (manually) use the -K option.
#
### END INFO
search h @h @?
nameserver 10.0.0.1

Mezzelfo
21-10-2004, 23:09
Io credo di avere lo stesso problema. Però ho un'altra scheda wireless. Infatti i driver sembrano funzionare... L'output non da errori e dalla pagina di configurazione del router la scheda wireless risulta collegata, solo che se pingo (e il cavo di rete è collegato) pinga normalmente (faccio ping -I wlan0 INDIRIZZO) mentre se il cavo di rete è scollegato non pinga niente.

ifconfig


eth0 Link encap:Ethernet HWaddr 00:10:5A:B3:C8:7C
inet addr:192.168.123.102 Bcast:192.168.123.255 Mask:255.255.255.0
inet6 addr: fe80::210:5aff:feb3:c87c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:101647 errors:0 dropped:0 overruns:0 frame:0
TX packets:60705 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:107900000 (102.9 MiB) TX bytes:4111919 (3.9 MiB)
Interrupt:10 Base address:0xd000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:182 errors:0 dropped:0 overruns:0 frame:0
TX packets:182 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:9902 (9.6 KiB) TX bytes:9902 (9.6 KiB)

wlan0 Link encap:Ethernet HWaddr 00:C0:49:CB:D6:C0
inet addr:192.168.123.100 Bcast:192.168.123.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:49ff:fecb:d6c0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:378 (378.0 b)
Interrupt:10



route -n


Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.123.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.123.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
0.0.0.0 192.168.123.254 0.0.0.0 UG 0 0 0 wlan0
0.0.0.0 192.168.123.254 0.0.0.0 UG 0 0 0 eth0



cat /etc/resolv.conf


search realm
nameserver 192.168.123.254
domain realm

e-Tip
22-10-2004, 02:38
qua, ad un'occhiata molto veloce manca l'indicazione del gw...

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.0.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

route add default gw 10.0.0.1

_dovrebbe_ risolvere le cose

ivand
22-10-2004, 08:28
ho già provato...:mc:

ilsensine
22-10-2004, 09:28
Originariamente inviato da ivand
ho già provato...:mc:
Il gw comunque manca. Gli IP della subnet sono gli stessi anche accedendo tramite wifi? (ad es. il gw è sempre 10.0.0.1? non dovresti inserire l'IP dell'AP in questo caso?)
Inoltre, riesci a pingare gli IP degli altri computer in rete?

ilsensine
22-10-2004, 09:31
Originariamente inviato da Mezzelfo
Io credo di avere lo stesso problema. Però ho un'altra scheda wireless. Infatti i driver sembrano funzionare... L'output non da errori e dalla pagina di configurazione del router la scheda wireless risulta collegata, solo che se pingo (e il cavo di rete è collegato) pinga normalmente (faccio ping -I wlan0 INDIRIZZO) mentre se il cavo di rete è scollegato non pinga niente.
Se butti giù l'interfaccia ethernet (ifconfig eth0 down) ti funziona?

ilsensine
22-10-2004, 09:33
Originariamente inviato da ivand
con wifi(eth1):
eth1 Link encap:Ethernet HWaddr 00:04:23:4B:45:2C

RX packets:81 errors:0 dropped:0 overruns:0 frame:0
TX packets:44 errors:0 dropped:0 overruns:0 carrier:0


L'interfaccia di per se sembra funzionare.

ilsensine
22-10-2004, 09:35
Originariamente inviato da ivand
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.0.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1

169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1

127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

A che serve questa bizzarra regola per 169.254.x.x?

ivand
22-10-2004, 09:49
Ho risolto facendo:
1) route add default gw 10.0.0.1
2) ho scritto in /etc/resolv.conf solo la seguente riga:
nameserver 10.0.0.1.

ora funzia!

Come posso cancellare la regola di routing:
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1

Ciao

ilsensine
22-10-2004, 09:54
Originariamente inviato da ivand
Come posso cancellare la regola di routing:
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1

Boh sapendo come e perché è stata messa.
Comunque non ti preoccupare, è innocua (a meno che non cerchi di contattare un sito con quella stessa subnet).

ivand
22-10-2004, 10:09
Originariamente inviato da ilsensine
Boh sapendo come e perché è stata messa.
Comunque non ti preoccupare, è innocua (a meno che non cerchi di contattare un sito con quella stessa subnet).

si è creata da sola...
è possibile non far caricare eth0 all'avvio del sistema?

ilsensine
22-10-2004, 10:29
Oh boh, non so che tipo di script usa la Suse. Sulla Mandrake basta impostare il valore ONBOOT a no nel file /etc/sysconfig/network-scripts/ifcfg-eth0, ma sulla Suse potrebbe essere diverso.

Mezzelfo
24-10-2004, 14:11
Originariamente inviato da ilsensine
Se butti giù l'interfaccia ethernet (ifconfig eth0 down) ti funziona?

Funziona!

Quindi ora devo solo impostare di far paritre wlan0 e non eth0 all'avvio?

ilsensine
25-10-2004, 09:55
Esatto. Strano che ping -l non ti ha beccato l'interfaccia giusta. In ogni caso, nessun programma avrebbe potuto sfruttare la wlan, in quanto nella tabella di routing la prima regola andava su eth0. Non andrebbero usate più interfacce di rete con la stessa subnet, proprio per questi problemi.