View Full Version : [Debian]: non funziona l'utente root


Alex_80
10-04-2010, 23:18
Dopo l'installazione di Debian 5.0.4 mi connetto in Gnome come utente e quando un'operazione richiede privilegi di root viene mostrata una finestra per inserire la password di root, però dopo averla inserita e premuto OK, la finestra si chiude e non succede nulla.
Ho verificato che la password di root fosse corretta, infatti con [Ctrl]+[Alt]+[F1] la password di root funziona; ho anche provato a reinstallare Debian, ma non è cambiato niente.

In Terminal con il comando "su", dopo aver inserito la password, viene visualizzato il messaggio:
Autentificazione fallita

Invece in Terminal con il comando "gksu gedit", dopo aver inserito la password, la finestra si chiude e non succede niente e Terminal non mostra nessun messaggio.

Con Debian 4 funzionava tutto.

C'è qualcosa da abilitato con Debian 5?
Come posso risolvere il problema?

Chiancheri
10-04-2010, 23:38
da un pò non uso debian, cmq se non ricordo male non c'è sudo di default. se su un'altra tty riesci a diventare root prova ad installare e configurare sudo.

Alex_80
11-04-2010, 00:20
Come faccio a verificare se ho "sudo" installato ed eventualmente a installarlo?

WebWolf
11-04-2010, 12:19
Apri un terminale e digiti

sudo [comando]

tipo

sudo vi
o
sudo gedit

P.S:
Il comportamento è strano. Non è che hai un layout della keybord diverso quando sei in gnome ?

Alex_80
12-04-2010, 14:02
sudo vi
e
sudo gedit
dopo l'inserimento della password dell'utente mostrano:
User is not in the sudoers file
Quindi sembrerebbe che "sudo" sia installato.

La tastiera dovrebbe essere configurata correttamente, in ogni caso la password è formata soltanto da caratteri numerici e alfabetici (minuscoli e maiuscoli).

Chiancheri
12-04-2010, 14:09
se riesci a dare:

su root

(e metti la passw di root), dopo puoi anche aggiungere il tuo utente ai sudoers.

Alex_80
12-04-2010, 18:05
In sudoers ho inserito "user ALL=(ALL) ALL" (dove al posto di user ovviamente ho messo il nome utente reale), però non è cambiato nulla.

Comunque adesso provo anche a vedere se funziona "su root" anche se non mi serve per la modifica di sudoers.

Chiancheri
12-04-2010, 18:12
In sudoers ho inserito "user ALL=(ALL) ALL" (dove al posto di user ovviamente ho messo il nome utente reale), però non è cambiato nulla.

Comunque adesso provo anche a vedere se funziona "su root" anche se non mi serve per la modifica di sudoers.

scusami, come hai fatto a modificare il file sudoers senza essere root??????????????????????????

devi mettere anche qualcosa del genere (se non c'è già):


%sudo ALL=(ALL) ALL

Alex_80
14-04-2010, 00:53
Con [Ctrl]+[Alt]+[F1], infatti come ho già detto così riesco a fare il login come root.

Ho provato su Gnome anche il comando "su root", però dopo l'inserimento della password il messaggio è sempre: Autenticazione fallita.

%sudo ALL=(ALL) ALL non è presente in sudoers, a cosa serve questa aggiunta?

Chiancheri
14-04-2010, 02:03
Con [Ctrl]+[Alt]+[F1], infatti come ho già detto così riesco a fare il login come root.

Ho provato su Gnome anche il comando "su root", però dopo l'inserimento della password il messaggio è sempre: Autenticazione fallita.

%sudo ALL=(ALL) ALL non è presente in sudoers, a cosa serve questa aggiunta?

credo che serva a permettere a tutti di usare il comando sudo. c'è sul mio sudoers.

Alex_80
16-04-2010, 20:38
%sudo ALL=(ALL) ALL
in sudoers dove devo metterlo oppure non ha importanza la posizione rispetto alle altre righe?

Alex_80
26-04-2010, 15:50
Per riportare la discussione in prima pagina...

davp
26-04-2010, 21:08
Potrebbe essere una questione di layout della tastiera diverso per l'interfaccia grafica. Prova a scrivere la password in chiaro sotto Gnome e verifica che sia uguale a quella che funziona nell'altra tty.

Alex_80
27-04-2010, 15:01
Ho provato a scrivere in chiaro la password sul terminale e poi con il tasto destro del mouse ho fatto copia-incolla quando viene chiesta la password, però il risultato non è cambiato.


Ho provato anche con "gksu -d gedit", dopo l'inserimento della password, viene visualizzato:


no password on keyring
DEBUG (run:after-pass) buf: -Password: -
DEBUG (run:post-after-pass) buf: -
ssword: -
DEBUG (run:post-after-pass) buf: -su: authentication failed
-
DEBUG (auth_failed) buf: -su: autentication failed
-


Nota: "ssword" non è un mio errore nello scrivere password, viene riportato proprio ssword.

davp
27-04-2010, 16:51
Se hai copia-incollato la password col mouse allora eri ancora sotto xserver nel tty7, era soltanto un terminale virtuale sotto Gnome. La mia teoria era che la tastiera fosse impostata diversamente nel sistema base rispetto a quella impostata sotto xserver/gnome. Se la password di root contiene qualche carattere strano lo stesso tasto poteva esser associato a simboli diversi sotto xserver rispetto alla pura interfaccia a linea di comando (dove funziona).
Ovviamente se la password contiene solo lettere e numeri tutto questo mio discorso non sta in piedi (a meno di non aver configurato la tastiera come azerty o altri layout esotici :) )

Alex_80
01-05-2010, 03:35
Infatti la prova l'ho fatta con il terminale sotto Gnome.

Comunque ho anche scritto in chiaro la password sia in modalità testuale ([CTRL]+[Alt]+[F1]) (in cui funziona) sia con il terminale sotto Gnome (in cui ***non*** funziona) e le password sono uguali, perciò sembrerebbe che la tastiera sia sempre impostata la stessa.

Per quanto riguarda l'aggiunta di "%sudo ALL=(ALL) ALL" in sudoers ha importanza in quale posizione lo inserisco?

Alex_80
03-05-2010, 00:15
Qualcuno ha installato Debian 5.0.4 su una partizione vuota (non aggiornando da una versione precedente di Debian) e la password di root funziona?

Alex_80
15-05-2010, 19:14
Ho risolto il problema usando per l'utente root una password alfabetica, anziché alfanumerica. :)

Comunque mi sembra stano che un così grande bug non sia stato ancora risolto. :eek: