View Full Version : Non riesco più ad installare nulla su xp


zetagabri
29-05-2009, 08:30
Da un po' di tempo non riesco ad installare nessun tipo di programma su xp. Neanche gli updates di windows! E' come se il registro fosse bloccato e non riesce a scrivere o modificare voci. Per esempio:
Ho provato ad installare un software .msi e dopo aver macinato un po' mi da questo errore:
"Impossibile accedere a Windows Installer. Ciò si verifica se Windows viene eseguito in modalità provvisoria o se Windows installer non è stato installato correttamente. Contattare il personale di supporto per assistenza."
Inutile aggiungere che non sono in modalità provvisoria, che sono loggato come amministratore e che ho i diritti per modificare il registro.
Che sta succedendo?
Grazie

zetagabri
29-05-2009, 09:18
Per la precisione....

Nel registro degli eventi, mi vengono fuori degli errori con i files:
wuaucpl.cpl.mui
netevent.dll
sxs.dll

Saluti di ogni bene a tutti.

PS: Ho provato l'utility windows installer cleanup, ma non parte!!!!

kiriranshelo
29-05-2009, 12:20
hai provato a fare un ripristino con il cd di installazione di windows?

marcosco
29-05-2009, 16:10
Da un po' di tempo non riesco ad installare nessun tipo di programma su xp. Neanche gli updates di windows! E' come se il registro fosse bloccato e non riesce a scrivere o modificare voci. Per esempio:
Ho provato ad installare un software .msi e dopo aver macinato un po' mi da questo errore:
"Impossibile accedere a Windows Installer. Ciò si verifica se Windows viene eseguito in modalità provvisoria o se Windows installer non è stato installato correttamente. Contattare il personale di supporto per assistenza."
Inutile aggiungere che non sono in modalità provvisoria, che sono loggato come amministratore e che ho i diritti per modificare il registro.
Che sta succedendo?
Grazie
prova a vedere in servizi se hai avviato utilità di avvio processo server dcom.Se è disabilitato avvialo.

zetagabri
01-06-2009, 13:18
Ho provato a fare un ripristino configurazione di winXP, ma nulal da fare. Ho verficato il servizio "utilità di avvio processo server dcom" e quello risulta regolarmente avviato......non riseco proprio a capire dove sia l'arcano.
Preciso che io come browser uso Firefox, e mi collego a internet tramite un proxy, ogni volta che riavvio il browser devo andare a modificare manualmente l'indirizzo del proxy perchè non viene memorizzato......evidentemente no riesce a scriverlo sul registro....
Saluti

zetagabri
01-06-2009, 14:50
...non riesco neanche a reinstallare WindowsiInstaller.....è il colmo!!!

marcosco
01-06-2009, 18:06
vedi se in msconfig al tab servizi windows installer sia spuntato.
Se è spuntato possibile che sia un virus.Prova a dare una passata di combofix.Se non risolvi vai qui (http://www.hwupgrade.it/forum/forumdisplay.php?f=125)

zetagabri
03-06-2009, 09:03
WindowsInstaller è spuntato.
Ho passato tutto con Combofix, ma nulla. Rimane tutto invariato.....Proverò a dare un'occhiata al link che mi hai dato...

zetagabri
03-06-2009, 09:37
Non riesco a far partire nessun exe....!!!!! Quindi ne CureIt ne Eset Sysinspector, ne sysclean della Trend Micro......
Non so più cosa fare!

wjmat
03-06-2009, 10:26
qui trovi varie stringhe di registro per riparare le associazioni dei file, tra cui i .exe
http://www.zonapc.it/downloads/ripara_pc/associazioni_files.php

zetagabri
03-06-2009, 11:56
Non funziona nemmeno quello...... Credo che ci sia qualcosa di irreparabile nel registro di sistema....

kiriranshelo
03-06-2009, 14:23
Non riesco a far partire nessun exe....!!!!! Quindi ne CureIt ne Eset Sysinspector, ne sysclean della Trend Micro......
Non so più cosa fare!

hai provato in modalità provvisoria?

DemianH
03-06-2009, 16:55
Se non ricordo male il fatto che tutti gli .exe siano bloccati potrebbe dipendere da un virus, hai provato a fare una scansione? magari anche con un antipsyware tipo spyware doctor (http://spywaredoctor.download-pro.net/)?

zetagabri
04-06-2009, 16:29
...non credo sia un problema nè di virus, nè di spyware.....

e comunque non riuscirei ad installarlo!!!!

pingu79
04-06-2009, 21:10
...non credo sia un problema nè di virus, nè di spyware.....

e comunque non riuscirei ad installarlo!!!!

invece potrebbe essere proprio un problema di virus.
in ogni caso il sistema è aggiornato?

zetagabri
05-06-2009, 07:21
Il S.O. è un XP SP2, ma non riesco ad installare alcun aggiornamento in quanto il servizio di controllo di Windows Update richiede l'installazione di una ActiveX che il PC non mi fa installare!!!

pingu79
05-06-2009, 11:47
prova ad entrare in provvisoria.
anche da li non puoi installare nulla?

zetagabri
06-06-2009, 15:25
Mi sa che formatto tutto......